summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2011-01-14 00:30:58 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2011-01-14 00:30:58 +0000
commit187e0501ef917b88a9edd625512a64bc9bc8385c (patch)
treed6f4e71e9b38bf0eac7e698a8dfb3f880942ccf8 /games-board
parentold (diff)
downloadgentoo-2-187e0501ef917b88a9edd625512a64bc9bc8385c.tar.gz
gentoo-2-187e0501ef917b88a9edd625512a64bc9bc8385c.tar.bz2
gentoo-2-187e0501ef917b88a9edd625512a64bc9bc8385c.zip
old
(Portage version: 2.1.9.25/cvs/Linux i686)
Diffstat (limited to 'games-board')
-rw-r--r--games-board/hexxagon/Manifest3
-rw-r--r--games-board/hexxagon/files/hexxagon-1.0-gcc44.patch65
-rw-r--r--games-board/hexxagon/hexxagon-1.0.ebuild33
3 files changed, 0 insertions, 101 deletions
diff --git a/games-board/hexxagon/Manifest b/games-board/hexxagon/Manifest
index b88c0800105c..94e9000026e2 100644
--- a/games-board/hexxagon/Manifest
+++ b/games-board/hexxagon/Manifest
@@ -1,7 +1,4 @@
-AUX hexxagon-1.0-gcc44.patch 2041 RMD160 7cd20df59ef8185c36ece5626cf37cbe7a69dd45 SHA1 364f0d0c8563abaec9105db5e5256dce590d83b5 SHA256 874465bc10b30bf4f3ada6329a3ec8ea8894673ea0fdd9ecafce5ee35be8a247
DIST hexxagon-1.0.1.tar.bz2 1278325 RMD160 fc023265a2c1bc0ba8f054197608c8024871eaab SHA1 02aaab7fab771ae58dd0d43f761763136e034f02 SHA256 a6a1579990797276132f5d0e26b5b70d60ef654cb35261e2b6c26220e7d40fd9
-DIST hexxagon-1.0.tar.bz2 1245889 RMD160 d38b98db3a694818437c6dfc8916ff0ce338f1ea SHA1 1ffe2d6d64a79888c9e5b0dde476006e251afc21 SHA256 d38c6171550a2e10ece4ae655cbc417a1bdb86912cd5f141e2a19840d4cb5f5f
EBUILD hexxagon-1.0.1.ebuild 744 RMD160 53e1cb5d3171de07ae23238dcf573a16f12eb5c1 SHA1 f75755e1044f494bf382e9ad6576b147e09eb554 SHA256 bf47df73a25deda0299ab39a25ac2827bde50fc5b5d53cca4d1c75eb5bf621a0
-EBUILD hexxagon-1.0.ebuild 806 RMD160 f3d6067684d78cac554aa2cf8b54e613bee92641 SHA1 7b06bb0541049f380a1311dd23273b16bf3f9c6e SHA256 1a7ee404aa1fcb8b2c836662eb5855591ed799b3e9baedda8294c615ed2b6613
MISC ChangeLog 2986 RMD160 e6f296dbdeae2aa317975a6fd6314310ee563577 SHA1 c7f3e7a58e65cc060263660cc9f82e98efb18012 SHA256 beebf9194b5e9001320e748ef12304b07fb43da1cab3f1bfd592776cc10cba59
MISC metadata.xml 158 RMD160 cbd9984bb6b426c8c9cee5022fe0a26261612fea SHA1 be5251fa1dacef5c41b74761bb1c8c54fb633b9e SHA256 1423a4fdd4a79b1728a2056d9e300f7e1074253095d82726218d9e9b953888a3
diff --git a/games-board/hexxagon/files/hexxagon-1.0-gcc44.patch b/games-board/hexxagon/files/hexxagon-1.0-gcc44.patch
deleted file mode 100644
index 3a6f3c8d2a2d..000000000000
--- a/games-board/hexxagon/files/hexxagon-1.0-gcc44.patch
+++ /dev/null
@@ -1,65 +0,0 @@
-Only in hexxagon-1.0.orig: hexxagon-1.0
-diff -ur hexxagon-1.0.orig/src/libhexx/bitboard64.h hexxagon-1.0/src/libhexx/bitboard64.h
---- hexxagon-1.0.orig/src/libhexx/bitboard64.h 2005-01-13 23:19:07.000000000 +0200
-+++ hexxagon-1.0/src/libhexx/bitboard64.h 2009-08-15 20:34:23.000000000 +0300
-@@ -25,6 +25,7 @@
-
- #include <netinet/in.h>
- #include <iostream>
-+#include <cstdio>
-
- namespace libhexx
- {
-@@ -54,14 +55,11 @@
- {
- printf("0x%X, 0x%X\n", lowbits, highbits);
- };
--
-- friend std::ostream& operator<<(std::ostream &output, const class BitBoard64 &b);
-- friend std::istream& operator>>(std::istream &input, class BitBoard64 &b);
--
-- private:
-
- uint32_t lowbits, highbits;
- };
-+ std::ostream& operator<<(std::ostream &output, const class BitBoard64 &b);
-+ std::istream& operator>>(std::istream &input, class BitBoard64 &b);
- }
-
- #endif
-diff -ur hexxagon-1.0.orig/src/libhexx/board.h hexxagon-1.0/src/libhexx/board.h
---- hexxagon-1.0.orig/src/libhexx/board.h 2005-01-16 13:12:23.000000000 +0200
-+++ hexxagon-1.0/src/libhexx/board.h 2009-08-15 20:34:23.000000000 +0300
-@@ -93,6 +93,7 @@
- BitBoard64 board;
- BitBoard64 color;
- };
-+ bool scoreMoves(std::vector<Move> &moves, class Board board, const LookUp& lookUp, int depth, bool (*callback)(), int maxtime);
- } // namespace libhexx
-
- #endif // _BOARD_H
-diff -ur hexxagon-1.0.orig/src/libhexx/move.h hexxagon-1.0/src/libhexx/move.h
---- hexxagon-1.0.orig/src/libhexx/move.h 2005-01-13 23:19:07.000000000 +0200
-+++ hexxagon-1.0/src/libhexx/move.h 2009-08-15 20:34:23.000000000 +0300
-@@ -20,10 +20,9 @@
- */
-
-
--#ifndef _MOVE_H
--#define _MOVE_H
-+#ifndef _LIBHEXX_MOVE_H
-+#define _LIBHEXX_MOVE_H
-
--#include "board.h"
-
- #include <list>
- #include <vector>
-@@ -53,7 +52,7 @@
- int score;
- };
-
-- bool scoreMoves(std::vector<Move> &moves, class Board board, const LookUp& lookUp, int depth, bool (*callback)(), int maxtime);
-+
- } //namespace libhexx
-
- #endif // _HEXXAGONMOVE_H
diff --git a/games-board/hexxagon/hexxagon-1.0.ebuild b/games-board/hexxagon/hexxagon-1.0.ebuild
deleted file mode 100644
index 8fcbf488fba6..000000000000
--- a/games-board/hexxagon/hexxagon-1.0.ebuild
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/hexxagon/hexxagon-1.0.ebuild,v 1.14 2010/01/01 03:37:49 sping Exp $
-
-EAPI=2
-inherit eutils games
-
-DESCRIPTION="clone of the original DOS game"
-HOMEPAGE="http://www.nesqi.se/"
-SRC_URI="http://www.nesqi.se/hexxagon/download/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ppc x86"
-IUSE=""
-
-RDEPEND=">=dev-cpp/glibmm-2.4
- >=dev-cpp/gtkmm-2.4
- x11-libs/gtk+:2"
-DEPEND="${RDEPEND}
- dev-util/pkgconfig"
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-gcc44.patch
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- newicon images/board_N_2.xpm ${PN}.xpm
- make_desktop_entry ${PN} Hexxagon ${PN}
- dodoc README
- prepgamesdirs
-}