summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2012-07-02 17:16:57 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2012-07-02 17:16:57 +0000
commitf13aa3c2e8dbca0a82d3c489c58a568c5872f5d0 (patch)
tree821a888678b49f03d284fc3cb940b9c3c03d2a97 /games-board
parentDropped darwin-arch patch, latest gcc-apple now handles this. Set mac_deploy... (diff)
downloadgentoo-2-f13aa3c2e8dbca0a82d3c489c58a568c5872f5d0.tar.gz
gentoo-2-f13aa3c2e8dbca0a82d3c489c58a568c5872f5d0.tar.bz2
gentoo-2-f13aa3c2e8dbca0a82d3c489c58a568c5872f5d0.zip
version bump
(Portage version: 2.1.10.65/cvs/Linux x86_64)
Diffstat (limited to 'games-board')
-rw-r--r--games-board/pokerth/ChangeLog9
-rw-r--r--games-board/pokerth/files/pokerth-0.8.3-boost142.patch42
-rw-r--r--games-board/pokerth/pokerth-0.8.3.ebuild79
-rw-r--r--games-board/pokerth/pokerth-0.9.5.ebuild (renamed from games-board/pokerth/pokerth-0.9.1.ebuild)11
4 files changed, 13 insertions, 128 deletions
diff --git a/games-board/pokerth/ChangeLog b/games-board/pokerth/ChangeLog
index 714ac048f5fc..4c7d3fb4e87f 100644
--- a/games-board/pokerth/ChangeLog
+++ b/games-board/pokerth/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for games-board/pokerth
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/pokerth/ChangeLog,v 1.36 2012/06/13 09:31:30 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/pokerth/ChangeLog,v 1.37 2012/07/02 17:16:57 mr_bones_ Exp $
+
+*pokerth-0.9.5 (02 Jul 2012)
+
+ 02 Jul 2012; Michael Sterrett <mr_bones_@gentoo.org> +pokerth-0.9.5.ebuild,
+ -files/pokerth-0.8.3-boost142.patch, -pokerth-0.8.3.ebuild,
+ -pokerth-0.9.1.ebuild:
+ version bump
13 Jun 2012; Johannes Huber <johu@gentoo.org> pokerth-0.9.4.ebuild:
Stable for x86, wrt bug #420139
diff --git a/games-board/pokerth/files/pokerth-0.8.3-boost142.patch b/games-board/pokerth/files/pokerth-0.8.3-boost142.patch
deleted file mode 100644
index 3abe50f18dc6..000000000000
--- a/games-board/pokerth/files/pokerth-0.8.3-boost142.patch
+++ /dev/null
@@ -1,42 +0,0 @@
---- pokerth_lib.pro.old 2011-07-03 23:52:06.769035002 +0200
-+++ pokerth_lib.pro 2011-07-03 23:52:57.994035008 +0200
-@@ -1,3 +1,4 @@
-+### eqmake4 was here ###
- # QMake pro-file for PokerTH common library
-
- isEmpty( PREFIX ){
-@@ -14,7 +15,6 @@
- OBJECTS_DIR = obj
- DEFINES += ENABLE_IPV6
- QT -= core gui
--QMAKE_CXXFLAGS += -std=gnu++0x
- #PRECOMPILED_HEADER = src/pch_lib.h
-
- INCLUDEPATH += . \
-@@ -255,3 +255,6 @@
- INCLUDEPATH += /Library/Frameworks/SDL_mixer.framework/Headers
- INCLUDEPATH += /opt/local/include
- }
-+
-+CONFIG -= debug_and_release debug
-+CONFIG += release
---- pokerth_game.pro.old 2011-07-04 06:19:32.899038048 +0200
-+++ pokerth_game.pro 2011-07-04 06:19:50.507038051 +0200
-@@ -16,7 +16,6 @@
- warn_on
- include(src/third_party/qtsingleapplication/qtsingleapplication.pri)
- QT += sql
--QMAKE_CXXFLAGS += -std=gnu++0x
- UI_DIR = uics
- MOC_DIR = mocs
- OBJECTS_DIR = obj
---- pokerth_server.pro.old 2011-07-04 09:01:20.886039321 +0200
-+++ pokerth_server.pro 2011-07-04 09:01:32.746039322 +0200
-@@ -18,7 +18,6 @@
- DEFINES += ENABLE_IPV6
- DEFINES += PREFIX=\"$${PREFIX}\"
- QT -= core gui
--QMAKE_CXXFLAGS += -std=gnu++0x
- #PRECOMPILED_HEADER = src/pch_lib.h
-
- INCLUDEPATH += . \
diff --git a/games-board/pokerth/pokerth-0.8.3.ebuild b/games-board/pokerth/pokerth-0.8.3.ebuild
deleted file mode 100644
index d9496d6969e1..000000000000
--- a/games-board/pokerth/pokerth-0.8.3.ebuild
+++ /dev/null
@@ -1,79 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/pokerth/pokerth-0.8.3.ebuild,v 1.8 2011/11/02 09:05:55 eras Exp $
-
-EAPI=2
-inherit multilib flag-o-matic eutils qt4-r2 games
-
-MY_P="PokerTH-${PV//_/-}-src"
-DESCRIPTION="Texas Hold'em poker game"
-HOMEPAGE="http://www.pokerth.net/"
-SRC_URI="mirror://sourceforge/pokerth/${MY_P}.tar.bz2"
-
-LICENSE="GPL-1 GPL-2 GPL-3 BitstreamVera public-domain"
-SLOT="0"
-KEYWORDS="amd64 ppc x86"
-IUSE="dedicated"
-
-DEPEND=">=dev-libs/boost-1.41
- >=net-libs/gnutls-2.2.2
- >=net-misc/curl-7.16
- x11-libs/qt-core:4
- virtual/gsasl
- !dedicated? (
- media-libs/libsdl
- media-libs/sdl-mixer[mikmod,vorbis]
- >=sys-libs/zlib-1.2.3
- x11-libs/qt-gui:4
- x11-libs/qt-sql:4
- )"
-
-S=${WORKDIR}/${MY_P}
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-boost142.patch
- local boost_ver
-
- if use dedicated ; then
- sed -i \
- -e 's/pokerth_game.pro//' \
- pokerth.pro \
- || die "sed failed"
- fi
- sed -i \
- -e '/no_dead_strip_inits_and_terms/d' \
- *pro \
- || die 'sed failed'
- local boost_ver=$(best_version ">=dev-libs/boost-1.41")
-
- boost_ver=${boost_ver/*boost-/}
- boost_ver=${boost_ver%.*}
- boost_ver=${boost_ver/./_}
-
- einfo "Using boost version ${boost_ver}"
- append-cxxflags \
- -I/usr/include/boost-${boost_ver}
- append-ldflags \
- -L/usr/$(get_libdir)/boost-${boost_ver}
- append-flags -DBOOST_FILESYSTEM_VERSION=2
-
- export BOOST_INCLUDEDIR="/usr/include/boost-${boost_ver}"
- export BOOST_LIBRARYDIR="/usr/$(get_libdir)/boost-${boost_ver}"
-}
-
-src_configure() {
- eqmake4
-}
-
-src_install() {
- dogamesbin bin/pokerth_server || die
- if ! use dedicated ; then
- dogamesbin ${PN} || die
- insinto "${GAMES_DATADIR}/${PN}"
- doins -r data || die
- domenu ${PN}.desktop
- doicon ${PN}.png
- fi
- dodoc ChangeLog TODO docs/{net_protocol,server_setup_howto}.txt
- prepgamesdirs
-}
diff --git a/games-board/pokerth/pokerth-0.9.1.ebuild b/games-board/pokerth/pokerth-0.9.5.ebuild
index 9ad41b2e2218..107c1cde55f3 100644
--- a/games-board/pokerth/pokerth-0.9.1.ebuild
+++ b/games-board/pokerth/pokerth-0.9.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/pokerth/pokerth-0.9.1.ebuild,v 1.2 2012/03/22 21:30:54 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/pokerth/pokerth-0.9.5.ebuild,v 1.1 2012/07/02 17:16:57 mr_bones_ Exp $
EAPI=2
inherit flag-o-matic eutils qt4-r2 games
@@ -15,8 +15,8 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="dedicated"
-RDEPEND="dev-db/sqlite
- >=dev-libs/boost-1.41
+RDEPEND="dev-db/sqlite:3
+ >=dev-libs/boost-1.44
dev-libs/libgcrypt
dev-libs/tinyxml[stl]
net-libs/libircclient
@@ -53,11 +53,10 @@ src_prepare() {
boost_ver=${boost_ver/./_}
einfo "Using boost version ${boost_ver}"
- append-cxxflags \
- -I/usr/include/boost-${boost_ver}
+ append-cppflags \
+ -I/usr/include/boost-${boost_ver} -DBOOST_FILESYSTEM_VERSION=2
append-ldflags \
-L/usr/$(get_libdir)/boost-${boost_ver}
- append-flags -DBOOST_FILESYSTEM_VERSION=2
export BOOST_INCLUDEDIR="/usr/include/boost-${boost_ver}"
export BOOST_LIBRARYDIR="/usr/$(get_libdir)/boost-${boost_ver}"