summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-03-20 09:17:29 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-03-20 09:17:29 +0000
commitdf9adeff4424570c52a38e6a7b7902cc409e3fba (patch)
tree0e3ca82f01c086f100edb9e35ad12c77abfc0a8c /games-emulation/generator/generator-0.35.ebuild
parentgnome 2.6 commit (Manifest recommit) (diff)
downloadgentoo-2-df9adeff4424570c52a38e6a7b7902cc409e3fba.tar.gz
gentoo-2-df9adeff4424570c52a38e6a7b7902cc409e3fba.tar.bz2
gentoo-2-df9adeff4424570c52a38e6a7b7902cc409e3fba.zip
fix bug #44709 by turning off logging; other clean ups if you can call this package "cleaner"
Diffstat (limited to 'games-emulation/generator/generator-0.35.ebuild')
-rw-r--r--games-emulation/generator/generator-0.35.ebuild57
1 files changed, 39 insertions, 18 deletions
diff --git a/games-emulation/generator/generator-0.35.ebuild b/games-emulation/generator/generator-0.35.ebuild
index 74dd930ec7a2..97fd45da0925 100644
--- a/games-emulation/generator/generator-0.35.ebuild
+++ b/games-emulation/generator/generator-0.35.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/generator/generator-0.35.ebuild,v 1.4 2004/03/10 17:32:13 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/generator/generator-0.35.ebuild,v 1.5 2004/03/20 09:17:29 mr_bones_ Exp $
-inherit games gcc
+inherit eutils gcc flag-o-matic games
DESCRIPTION="Sega Genesis / Mega Drive console emulator"
HOMEPAGE="http://www.squish.net/generator/"
@@ -11,50 +11,71 @@ SRC_URI="http://www.squish.net/generator/files/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86 ppc"
-IUSE="svga tcltk gtk" #allegro fails to compile
+IUSE="svga gtk"
-DEPEND="gtk? ( =x11-libs/gtk+-1* media-libs/libsdl )
+DEPEND="virtual/glibc
+ gtk? (
+ =x11-libs/gtk+-1*
+ media-libs/libsdl
+ )
svga? ( media-libs/svgalib )
jpeg? ( media-libs/jpeg )
x86? ( dev-lang/nasm )"
-# allegro? ( media-libs/allegro )
-# tcltk? ( dev-lang/tk dev-lang/tcl ) #deprecated upstream
src_unpack() {
unpack ${A}
cd ${S}
+ mkdir my-bins
if [ "${ARCH}" == "ppc" ]; then
- sed -i -e 's/-minline-all-stringops//g' configure
+ sed -i \
+ -e 's/-minline-all-stringops//g' configure \
+ || die "sed configure failed"
+ fi
+
+ if [ $(gcc-major-version) -eq 3 ] ; then
+ sed -i \
+ -e "s/-malign-functions/-falign-functions/" \
+ -e "s/-malign-loops/-falign-loops/" \
+ -e "s/-malign-jumps/-falign-jumps/" configure \
+ || die "sed configure failed"
fi
+ epatch "${FILESDIR}/logging.patch"
}
src_compile() {
- mkdir my-bins
+ local myconf="--with-gcc=$(gcc-major-version)"
+
+ append-flags "-DNOLOGGING"
- local myconf="--with-gcc=`gcc-major-version`"
[ "${ARCH}" == "x86" ] \
&& myconf="${myconf} --with-raze" \
|| myconf="${myconf} --with-cmz80"
local mygui
- for mygui in `use gtk` `use svga` ; do #`use allegro` `use tcltk`
+ for mygui in `use gtk` `use svga` ; do
[ "${mygui}" == "svga" ] && mygui=svgalib
- make clean
- egamesconf ${myconf} --with-${mygui} || die
- make || die "building ${mygui}"
+
+ if [ -f Makefile ] ; then
+ make clean
+ fi
+ egamesconf \
+ ${myconf} \
+ --with-${mygui} || die
+ emake -j1 || die "building ${mygui}"
mv main/generator-${mygui} my-bins/
done
- if [ -z "`use gtk``use allegro``use svga``use tcltk`" ] ; then
- egamesconf ${myconf} --with-gtk || die
- make || die "building ${mygui}"
+ if [ -z "`use gtk``use svga`" ] ; then
+ egamesconf \
+ ${myconf} \
+ --with-gtk || die
+ emake -j1 || die "building ${mygui}"
mv main/generator-gtk my-bins/
fi
}
src_install() {
- #make install DESTDIR=${D} || die #all it does is install the binary ;)
- dogamesbin my-bins/*
+ dogamesbin my-bins/* || die "dogamesbin failed"
dodoc AUTHORS ChangeLog NEWS README TODO
prepgamesdirs
}