summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2005-09-20 15:04:28 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2005-09-20 15:04:28 +0000
commit76e996991344194de810a4c1f80e4fdaabddf95c (patch)
tree5178b8164f12ac67495ed4ad5bc6163214f0db76 /games-emulation/mupen64-alsasnd
parentBack to ~x86 because of bug 106652 (diff)
downloadgentoo-2-76e996991344194de810a4c1f80e4fdaabddf95c.tar.gz
gentoo-2-76e996991344194de810a4c1f80e4fdaabddf95c.tar.bz2
gentoo-2-76e996991344194de810a4c1f80e4fdaabddf95c.zip
remove gtk2 use flag
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'games-emulation/mupen64-alsasnd')
-rw-r--r--games-emulation/mupen64-alsasnd/ChangeLog6
-rw-r--r--games-emulation/mupen64-alsasnd/mupen64-alsasnd-0.4.ebuild18
2 files changed, 13 insertions, 11 deletions
diff --git a/games-emulation/mupen64-alsasnd/ChangeLog b/games-emulation/mupen64-alsasnd/ChangeLog
index 43f734bff2d7..700649553a80 100644
--- a/games-emulation/mupen64-alsasnd/ChangeLog
+++ b/games-emulation/mupen64-alsasnd/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-emulation/mupen64-alsasnd
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64-alsasnd/ChangeLog,v 1.7 2005/07/07 04:36:55 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64-alsasnd/ChangeLog,v 1.8 2005/09/20 15:04:28 mr_bones_ Exp $
+
+ 20 Sep 2005; Michael Sterrett <mr_bones_@gentoo.org>
+ mupen64-alsasnd-0.4.ebuild:
+ remove gtk2 use flag
07 Jul 2005; Caleb Tennis <caleb@gentoo.org> mupen64-alsasnd-0.4.ebuild:
Fix qt dep
diff --git a/games-emulation/mupen64-alsasnd/mupen64-alsasnd-0.4.ebuild b/games-emulation/mupen64-alsasnd/mupen64-alsasnd-0.4.ebuild
index a4351b21a6db..53e56c74ad4f 100644
--- a/games-emulation/mupen64-alsasnd/mupen64-alsasnd-0.4.ebuild
+++ b/games-emulation/mupen64-alsasnd/mupen64-alsasnd-0.4.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64-alsasnd/mupen64-alsasnd-0.4.ebuild,v 1.12 2005/07/07 04:36:55 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64-alsasnd/mupen64-alsasnd-0.4.ebuild,v 1.13 2005/09/20 15:04:28 mr_bones_ Exp $
-inherit games eutils
+inherit eutils games
DESCRIPTION="Alsa plugin for the mupen64 N64 emulator"
HOMEPAGE="http://www.emutalk.net/showthread.php?threadid=16895"
@@ -11,17 +11,16 @@ SRC_URI="mirror://gentoo/alsa-plugin-${PV}fix.tar.bz2"
LICENSE="as-is"
SLOT="0"
KEYWORDS="-* x86"
-IUSE="qt gtk gtk2"
+IUSE="gtk qt"
DEPEND=">=media-libs/alsa-lib-0.9.0
|| (
- gtk? ( !gtk2? ( =x11-libs/gtk+-1* )
- gtk2? ( =x11-libs/gtk+-2* ) )
+ gtk? ( =x11-libs/gtk+-2* )
qt? ( =x11-libs/qt-3* )
=x11-libs/gtk+-2*
)"
-S="${WORKDIR}/alsa_plugin"
+S=${WORKDIR}/alsa_plugin
pkg_nofetch() {
einfo "Please visit this page to download the tarball:"
@@ -32,15 +31,14 @@ pkg_nofetch() {
src_unpack() {
unpack ${A}
cd "${S}"
- epatch "${FILESDIR}/${PV}-gentoo.patch" || die "gentoo patch failed"
- epatch "${FILESDIR}/${PV}-gtk.patch" || die "gtk patch failed"
+ epatch "${FILESDIR}/${PV}-gentoo.patch" \
+ "${FILESDIR}/${PV}-gtk.patch"
}
src_compile() {
export GRAPHICAL_INTERFACE=gtk2
use qt && export GRAPHICAL_INTERFACE=qt3
- use gtk && export GRAPHICAL_INTERFACE=gtk1
- use gtk2 && export GRAPHICAL_INTERFACE=gtk2
+ use gtk && export GRAPHICAL_INTERFACE=gtk2
emake || die "make failed"
}