summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Goller <morfic@gentoo.org>2005-04-24 00:35:19 +0000
committerDaniel Goller <morfic@gentoo.org>2005-04-24 00:35:19 +0000
commitfa4f93401842189d7ab9ab87f135de23a027a4b5 (patch)
treecefa877e66e695edf4846f69220cbf50dd65102b /games-emulation/mupen64-glN64
parentfix for apple gcc-4.0 on ppc-macos (diff)
downloadgentoo-2-fa4f93401842189d7ab9ab87f135de23a027a4b5.tar.gz
gentoo-2-fa4f93401842189d7ab9ab87f135de23a027a4b5.tar.bz2
gentoo-2-fa4f93401842189d7ab9ab87f135de23a027a4b5.zip
adding amd64
(Portage version: 2.0.51.19)
Diffstat (limited to 'games-emulation/mupen64-glN64')
-rw-r--r--games-emulation/mupen64-glN64/ChangeLog6
-rw-r--r--games-emulation/mupen64-glN64/mupen64-glN64-0.4.1_rc2-r1.ebuild34
2 files changed, 25 insertions, 15 deletions
diff --git a/games-emulation/mupen64-glN64/ChangeLog b/games-emulation/mupen64-glN64/ChangeLog
index c3899e7bd1bb..72d01a776cc6 100644
--- a/games-emulation/mupen64-glN64/ChangeLog
+++ b/games-emulation/mupen64-glN64/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-emulation/mupen64-glN64
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64-glN64/ChangeLog,v 1.7 2005/04/17 17:10:26 morfic Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64-glN64/ChangeLog,v 1.8 2005/04/24 00:34:33 morfic Exp $
+
+ 23 Apr 2005; Daniel Goller <morfic@gentoo.org>
+ mupen64-glN64-0.4.1_rc2-r1.ebuild:
+ adding amd64
17 Apr 2005; Daniel Goller <morfic@gentoo.org>
+files/mupen64-glN64-ucode.patch, mupen64-glN64-0.4.1_rc2-r1.ebuild:
diff --git a/games-emulation/mupen64-glN64/mupen64-glN64-0.4.1_rc2-r1.ebuild b/games-emulation/mupen64-glN64/mupen64-glN64-0.4.1_rc2-r1.ebuild
index 0bcb956e7017..3703e901123d 100644
--- a/games-emulation/mupen64-glN64/mupen64-glN64-0.4.1_rc2-r1.ebuild
+++ b/games-emulation/mupen64-glN64/mupen64-glN64-0.4.1_rc2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64-glN64/mupen64-glN64-0.4.1_rc2-r1.ebuild,v 1.3 2005/04/17 17:10:26 morfic Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64-glN64/mupen64-glN64-0.4.1_rc2-r1.ebuild,v 1.4 2005/04/24 00:34:33 morfic Exp $
inherit eutils games
@@ -10,27 +10,33 @@ DESCRIPTION="An OpenGL graphics plugin for the mupen64 N64 emulator"
SRC_URI="mirror://gentoo/glN64-0.4.1-rc2.tar.bz2"
HOMEPAGE="http://deltaanime.ath.cx/~blight/n64/"
-KEYWORDS="x86"
+KEYWORDS="x86 ~amd64"
LICENSE="as-is"
SLOT="0"
-IUSE="asm"
+IUSE="asm gtk2"
-RDEPEND="media-libs/libsdl"
+RDEPEND="media-libs/libsdl
+ !gtk2? ( =x11-libs/gtk+-1.2* )
+ gtk2? ( =x11-libs/gtk+-2* )"
+DEPEND="${RDEPEND}
+ gtk2? ( dev-util/pkgconfig )"
src_compile () {
- epatch ${FILESDIR}/${PN}-compile.patch || die "icompile patch failed"
- epatch ${FILESDIR}/${PN}-gtk2.patch || die "gtk2 patch failed"
+ epatch ${FILESDIR}/${PN}-compile.patch || die "compile patch failed"
+
+ if use gtk2; then
+ epatch ${FILESDIR}/${PN}-gtk2.patch || die "gtk2 patch failed"
+ fi
+
epatch ${FILESDIR}/${PN}-ucode.patch || die "ucode patch failed"
- if use x86; then
- if use asm; then
- einfo "using x86 asm where available"
- else
- epatch ${FILESDIR}/${PN}-noasm.patch
- fi
+
+ if ! use asm; then
+ epatch ${FILESDIR}/${PN}-noasm.patch
fi
- sed -i -e "s:CXXFLAGS.*=\(.*\):CXXFLAGS=\1 ${CXXFLAGS}:" Makefile || \
- die "couldn't apply cflags"
+ sed -i -e "s:CXXFLAGS.*=\(.*\):CXXFLAGS=\1 -fPIC ${CXXFLAGS}:" \
+ Makefile || die "couldn't apply cflags"
+
make || die
}