summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2006-01-31 22:27:25 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2006-01-31 22:27:25 +0000
commit4c2c61362ef430cf76612e3afa903fcf774e813c (patch)
tree2ebf7c055e02e625a0c5ef0ca49cf4c12fe3b1a6 /games-emulation/stella/stella-2.1.ebuild
parentFixed problem reported in bug #83071. Parallel build broken bug #121089, work... (diff)
downloadgentoo-2-4c2c61362ef430cf76612e3afa903fcf774e813c.tar.gz
gentoo-2-4c2c61362ef430cf76612e3afa903fcf774e813c.tar.bz2
gentoo-2-4c2c61362ef430cf76612e3afa903fcf774e813c.zip
version bump
(Portage version: 2.0.54)
Diffstat (limited to 'games-emulation/stella/stella-2.1.ebuild')
-rw-r--r--games-emulation/stella/stella-2.1.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/games-emulation/stella/stella-2.1.ebuild b/games-emulation/stella/stella-2.1.ebuild
new file mode 100644
index 000000000000..42becdde64a5
--- /dev/null
+++ b/games-emulation/stella/stella-2.1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/stella/stella-2.1.ebuild,v 1.1 2006/01/31 22:27:25 mr_bones_ Exp $
+
+inherit eutils games
+
+DESCRIPTION="Stella Atari 2600 VCS Emulator"
+HOMEPAGE="http://stella.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}-src.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ppc x86"
+IUSE="opengl"
+
+DEPEND="media-libs/libsdl
+ media-libs/libpng
+ opengl? ( virtual/opengl )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i \
+ -e "s:/etc:${GAMES_SYSCONFDIR}:g" \
+ src/macosx/OSystemMACOSX.cxx \
+ src/unix/OSystemUNIX.cxx \
+ src/unix/stella.spec \
+ src/psp/OSystemPSP.cxx \
+ docs/stella.html \
+ docs/debugger.html \
+ Makefile \
+ || die "sed failed"
+ sed -i \
+ -e "/icons/d" \
+ Makefile \
+ || die "sed failed"
+}
+
+src_compile() {
+ # not an autoconf script
+ ./configure \
+ --prefix="/usr" \
+ --bindir="${GAMES_BINDIR}" \
+ --docdir="/usr/share/doc/${PF}" \
+ --datadir="${GAMES_DATADIR}" \
+ $(use_enable opengl) \
+ || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ doicon src/common/stella.xpm
+ make_desktop_entry stella Stella stella.xpm
+ prepgamesdirs
+}