summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2009-01-30 14:51:21 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2009-01-30 14:51:21 +0000
commit5775b71a47b43708ce6806ba3722d26383c984aa (patch)
treea419e48ee16b61c3c1a9f7bd62860d1b823980da /games-emulation/xmame
parentnot parallel safe in the build (diff)
downloadgentoo-2-5775b71a47b43708ce6806ba3722d26383c984aa.tar.gz
gentoo-2-5775b71a47b43708ce6806ba3722d26383c984aa.tar.bz2
gentoo-2-5775b71a47b43708ce6806ba3722d26383c984aa.zip
not parallel build safe
(Portage version: 2.1.6.4/cvs/Linux 2.6.28.1 i686)
Diffstat (limited to 'games-emulation/xmame')
-rw-r--r--games-emulation/xmame/ChangeLog7
-rw-r--r--games-emulation/xmame/xmame-0.106.ebuild12
2 files changed, 11 insertions, 8 deletions
diff --git a/games-emulation/xmame/ChangeLog b/games-emulation/xmame/ChangeLog
index 7b73382efceb..731e24986954 100644
--- a/games-emulation/xmame/ChangeLog
+++ b/games-emulation/xmame/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-emulation/xmame
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/xmame/ChangeLog,v 1.71 2007/03/12 14:05:45 genone Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/xmame/ChangeLog,v 1.72 2009/01/30 14:51:21 mr_bones_ Exp $
+
+ 30 Jan 2009; Michael Sterrett <mr_bones_@gentoo.org> xmame-0.106.ebuild:
+ not parallel build safe
12 Mar 2007; Marius Mauch <genone@gentoo.org> xmame-0.106.ebuild:
Replacing einfo with elog
diff --git a/games-emulation/xmame/xmame-0.106.ebuild b/games-emulation/xmame/xmame-0.106.ebuild
index 38781d1848a5..7860f740cf38 100644
--- a/games-emulation/xmame/xmame-0.106.ebuild
+++ b/games-emulation/xmame/xmame-0.106.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/xmame/xmame-0.106.ebuild,v 1.8 2008/02/28 19:05:57 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/xmame/xmame-0.106.ebuild,v 1.9 2009/01/30 14:51:21 mr_bones_ Exp $
inherit flag-o-matic toolchain-funcs eutils games
@@ -149,20 +149,20 @@ EOF
src_compile() {
local disp=0
if use sdl ; then
- emake DISPLAY_METHOD=SDL || die "emake failed (SDL)"
+ emake -j1 DISPLAY_METHOD=SDL || die "emake failed (SDL)"
disp=1
fi
if use svga ; then
- emake DISPLAY_METHOD=svgalib || die "emake failed (svgalib)"
+ emake -j1 DISPLAY_METHOD=svgalib || die "emake failed (svgalib)"
disp=1
fi
if use ggi ; then
- #emake DISPLAY_METHOD=ggi || die "emake failed (ggi)"
+ #emake -j1 DISPLAY_METHOD=ggi || die "emake failed (ggi)"
#disp=1
ewarn "GGI support is currently (${PV}) broken :("
fi
if [[ ${disp} -eq 0 ]] || use opengl || use X || use dga || use xv ; then
- emake DISPLAY_METHOD=x11 || die "emake failed (x11)"
+ emake -j1 DISPLAY_METHOD=x11 || die "emake failed (x11)"
fi
}