summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-01-12 05:50:50 +0000
committerMike Frysinger <vapier@gentoo.org>2004-01-12 05:50:50 +0000
commit393db375993cc07a8c1c946eaef361522da2b3e6 (patch)
tree7603b18732d6ebae13bbd18df2e584d43a98b853 /games-emulation
parentver bump #37940 (diff)
downloadgentoo-2-393db375993cc07a8c1c946eaef361522da2b3e6.tar.gz
gentoo-2-393db375993cc07a8c1c946eaef361522da2b3e6.tar.bz2
gentoo-2-393db375993cc07a8c1c946eaef361522da2b3e6.zip
ver bump #37937
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/advancemame/ChangeLog7
-rw-r--r--games-emulation/advancemame/advancemame-0.78.0.ebuild61
-rw-r--r--games-emulation/advancemame/files/digest-advancemame-0.78.01
3 files changed, 68 insertions, 1 deletions
diff --git a/games-emulation/advancemame/ChangeLog b/games-emulation/advancemame/ChangeLog
index 5f6b1be080d3..ffbe8c357699 100644
--- a/games-emulation/advancemame/ChangeLog
+++ b/games-emulation/advancemame/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-emulation/advancemame
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/advancemame/ChangeLog,v 1.6 2004/01/06 03:53:00 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/advancemame/ChangeLog,v 1.7 2004/01/12 05:50:50 vapier Exp $
+
+*advancemame-0.78.0 (12 Jan 2004)
+
+ 12 Jan 2004; Mike Frysinger <vapier@gentoo.org> :
+ Version bump #37937.
*advancemame-0.77.2 (05 Jan 2004)
diff --git a/games-emulation/advancemame/advancemame-0.78.0.ebuild b/games-emulation/advancemame/advancemame-0.78.0.ebuild
new file mode 100644
index 000000000000..9a2232389faa
--- /dev/null
+++ b/games-emulation/advancemame/advancemame-0.78.0.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/advancemame/advancemame-0.78.0.ebuild,v 1.1 2004/01/12 05:50:50 vapier Exp $
+
+inherit games eutils
+
+DESCRIPTION="GNU/Linux port of the MAME emulator with GUI menu"
+HOMEPAGE="http://advancemame.sourceforge.net/"
+SRC_URI="mirror://sourceforge/advancemame/${P}.tar.gz"
+
+LICENSE="GPL-2 xmame"
+SLOT="0"
+KEYWORDS="x86 ppc"
+IUSE="debug static svga fbcon alsa oss slang sdl"
+
+RDEPEND="virtual/glibc
+ app-arch/unzip
+ x86? ( >=dev-lang/nasm-0.98 )
+ sdl? ( media-libs/libsdl )
+ slang? ( sys-libs/slang )
+ alsa? ( media-libs/alsa-lib )
+ svga? ( >=media-libs/svgalib-1.9 )"
+DEPEND="${RDEPEND}
+ virtual/os-headers"
+
+src_compile() {
+ export PATH="${PATH}:${T}"
+ ln -s `which nasm` ${T}/${CHOST}-nasm
+ use sdl && ln -s `which sdl-config` ${T}/${CHOST}-sdl-config
+ egamesconf \
+ `use_enable debug` \
+ `use_enable static` \
+ `use_enable x86 asm` \
+ `use_enable svga svgalib` \
+ `use_enable fbcon fb` \
+ `use_enable alsa` \
+ `use_enable oss` \
+ `use_enable slang` \
+ `use_enable sdl` \
+ --with-emu=${PN/advance} \
+ || die
+ emake || die
+}
+
+src_install() {
+ dogamesbin adv* || die "dogamesbin failed"
+
+ dodir ${GAMES_DATADIR}/advance/{artwork,diff,image,rom,sample,snap}
+ insinto ${GAMES_DATADIR}/advance
+ doins support/event.dat
+
+ dodoc HISTORY README RELEASE
+ cd obj/doc
+ dodoc *.txt
+ dohtml *.html
+ for m in *.1 ; do
+ newman ${m} ${m/1/6}
+ done
+
+ prepgamesdirs
+}
diff --git a/games-emulation/advancemame/files/digest-advancemame-0.78.0 b/games-emulation/advancemame/files/digest-advancemame-0.78.0
new file mode 100644
index 000000000000..33ae01c874a5
--- /dev/null
+++ b/games-emulation/advancemame/files/digest-advancemame-0.78.0
@@ -0,0 +1 @@
+MD5 4bb7453c181113b3a4bb54c013589439 advancemame-0.78.0.tar.gz 10444418