summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Holm <dholm@gentoo.org>2005-06-06 20:40:39 +0000
committerDavid Holm <dholm@gentoo.org>2005-06-06 20:40:39 +0000
commitfb1a3b9955739f7e644cee4314d4b32cf0bfea5d (patch)
treef72aacaf355295ca80aa8aabe0e4c304697a673e /games-emulation
parentdep for flowscan (diff)
downloadgentoo-2-fb1a3b9955739f7e644cee4314d4b32cf0bfea5d.tar.gz
gentoo-2-fb1a3b9955739f7e644cee4314d4b32cf0bfea5d.tar.bz2
gentoo-2-fb1a3b9955739f7e644cee4314d4b32cf0bfea5d.zip
Version bumped
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/hatari/ChangeLog9
-rw-r--r--games-emulation/hatari/Manifest6
-rw-r--r--games-emulation/hatari/files/digest-hatari-0.701
-rw-r--r--games-emulation/hatari/hatari-0.70.ebuild60
4 files changed, 72 insertions, 4 deletions
diff --git a/games-emulation/hatari/ChangeLog b/games-emulation/hatari/ChangeLog
index 3adb2204f2cb..4816080a91cf 100644
--- a/games-emulation/hatari/ChangeLog
+++ b/games-emulation/hatari/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-emulation/hatari
-# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/hatari/ChangeLog,v 1.7 2004/06/24 22:29:36 agriffis Exp $
+# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/hatari/ChangeLog,v 1.8 2005/06/06 20:40:39 dholm Exp $
+
+*hatari-0.70 (06 Jun 2005)
+
+ 06 Jun 2005; David Holm <dholm@gentoo.org> +hatari-0.70.ebuild:
+ Version bumped
26 May 2004; Michael Sterrett <mr_bones_@gentoo.org> hatari-0.40.ebuild,
hatari-0.45.ebuild:
diff --git a/games-emulation/hatari/Manifest b/games-emulation/hatari/Manifest
index 7d0774e1b3f0..ceac71227f04 100644
--- a/games-emulation/hatari/Manifest
+++ b/games-emulation/hatari/Manifest
@@ -1,4 +1,6 @@
-MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
+MD5 0a9cae417cbe4abbd9e0dc17516018a0 ChangeLog 1443
MD5 09908f04b13581f68880f4ddb9ba1a55 hatari-0.45.ebuild 1502
-MD5 b42c4265294aa4cc234cd4d2f3896531 ChangeLog 1331
+MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
+MD5 bebdff93c098fa687bd8506d89d90bd2 hatari-0.70.ebuild 1492
MD5 805ba6098c50b3ada3ee70778d225fc3 files/digest-hatari-0.45 63
+MD5 56916d0e45717c2c29fb53390294458a files/digest-hatari-0.70 63
diff --git a/games-emulation/hatari/files/digest-hatari-0.70 b/games-emulation/hatari/files/digest-hatari-0.70
new file mode 100644
index 000000000000..aa89ef59553e
--- /dev/null
+++ b/games-emulation/hatari/files/digest-hatari-0.70
@@ -0,0 +1 @@
+MD5 e54bf0519f1487e98a30b9715a702e70 hatari-0.70.tar.gz 521778
diff --git a/games-emulation/hatari/hatari-0.70.ebuild b/games-emulation/hatari/hatari-0.70.ebuild
new file mode 100644
index 000000000000..a979e52067af
--- /dev/null
+++ b/games-emulation/hatari/hatari-0.70.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/hatari/hatari-0.70.ebuild,v 1.1 2005/06/06 20:40:39 dholm Exp $
+
+inherit games
+
+DESCRIPTION="Atari ST emulator"
+HOMEPAGE="http://hatari.sourceforge.net/"
+SRC_URI="mirror://sourceforge/hatari/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+IUSE=""
+
+RDEPEND="games-emulation/emutos
+ media-libs/libsdl
+ sys-libs/zlib"
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ sed -i \
+ -e "/^CFLAGS/ s:-O3.*:${CFLAGS}:" \
+ -e "/^DATADIR/ s:=.*:= ${GAMES_DATADIR}/${PN}:" Makefile.cnf \
+ || die "sed Makefile.cnf failed"
+}
+
+src_compile() {
+ cd src
+ emake -j1 || die "emake failed"
+}
+
+src_install() {
+ dogamesbin "${S}/src/hatari"
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins src/gui-sdl/font5x8.bmp
+ doins src/gui-sdl/font10x16.bmp
+ dodoc readme.txt doc/*.txt
+ dohtml -r doc/
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ echo
+ einfo "You need a TOS ROM to run hatari. EmuTOS, a free TOS implementation,"
+ einfo "has been installed in /usr/games/lib/ with a .img extension (there"
+ einfo "are several from which to choose)."
+ echo
+ einfo "Another option is to go to http://www.atari.st/ and get a real TOS:"
+ einfo " http://www.atari.st/"
+ echo
+ einfo "The first time you run hatari, you should configure it to find the"
+ einfo "TOS you prefer to use. Be sure to save your settings."
+ echo
+}