summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichele Noberasco <s4t4n@gentoo.org>2010-08-31 15:38:31 +0000
committerMichele Noberasco <s4t4n@gentoo.org>2010-08-31 15:38:31 +0000
commitf8c0f5c0de7654ba191dbcb3b149bc859a5fa811 (patch)
tree750e46ecc6ad167f34393b597a274453a3ad96a7 /games-engines/gargoyle
parent2.6.32-r16: Linux patch 2.6.32.21. 2.6.34-r8: Linux patch 2.6.34.6 (diff)
downloadgentoo-2-f8c0f5c0de7654ba191dbcb3b149bc859a5fa811.tar.gz
gentoo-2-f8c0f5c0de7654ba191dbcb3b149bc859a5fa811.tar.bz2
gentoo-2-f8c0f5c0de7654ba191dbcb3b149bc859a5fa811.zip
Honour Gentoo LDFLAGS. Closes bug #333653.
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'games-engines/gargoyle')
-rw-r--r--games-engines/gargoyle/ChangeLog7
-rw-r--r--games-engines/gargoyle/gargoyle-20060917-r1.ebuild13
2 files changed, 15 insertions, 5 deletions
diff --git a/games-engines/gargoyle/ChangeLog b/games-engines/gargoyle/ChangeLog
index 8f56230f26f4..3389739b800f 100644
--- a/games-engines/gargoyle/ChangeLog
+++ b/games-engines/gargoyle/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-engines/gargoyle
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-engines/gargoyle/ChangeLog,v 1.9 2009/08/05 22:01:05 mr_bones_ Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-engines/gargoyle/ChangeLog,v 1.10 2010/08/31 15:38:31 s4t4n Exp $
+
+ 31 Aug 2010; Michele Noberasco <s4t4n@gentoo.org> gargoyle-20060917-r1.ebuild:
+ Honour Gentoo LDFLAGS. Closes bug #333653.
05 Aug 2009; Michael Sterrett <mr_bones_@gentoo.org>
gargoyle-20060917-r1.ebuild:
diff --git a/games-engines/gargoyle/gargoyle-20060917-r1.ebuild b/games-engines/gargoyle/gargoyle-20060917-r1.ebuild
index b14a1bebceac..553f009dce26 100644
--- a/games-engines/gargoyle/gargoyle-20060917-r1.ebuild
+++ b/games-engines/gargoyle/gargoyle-20060917-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-engines/gargoyle/gargoyle-20060917-r1.ebuild,v 1.6 2009/08/05 22:01:05 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-engines/gargoyle/gargoyle-20060917-r1.ebuild,v 1.7 2010/08/31 15:38:31 s4t4n Exp $
EAPI=2
inherit eutils
@@ -50,10 +50,17 @@ src_prepare() {
-e "s/getline/${PN}_getline/" \
terps/alan3/parse.c terps/alan2/parse.c \
|| die "sed failed"
+
+ #Fix LDFLAGS for shared libraries
+ sed -i \
+ -e 's/$(SHRLINKFLAGS) /$(SHRLINKFLAGS) $(LDFLAGS) /' \
+ Jamshared \
+ || die "sed failed"
}
src_compile() {
- jam || die "jam failed"
+ #Compile honouring LDFLAGS for binaries
+ jam LINKFLAGS="${LDFLAGS}" || die "jam failed"
}
src_install() {