summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2009-06-30 05:37:55 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2009-06-30 05:37:55 +0000
commitd1f70bcf78f751a7053e9e6200f91aaf6ab21281 (patch)
tree4c06dbf195cba08e9ca27f36fb19adabca515129 /games-engines/qtads
parentold (diff)
downloadgentoo-2-d1f70bcf78f751a7053e9e6200f91aaf6ab21281.tar.gz
gentoo-2-d1f70bcf78f751a7053e9e6200f91aaf6ab21281.tar.bz2
gentoo-2-d1f70bcf78f751a7053e9e6200f91aaf6ab21281.zip
version bump (bug #217341)
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'games-engines/qtads')
-rw-r--r--games-engines/qtads/ChangeLog9
-rw-r--r--games-engines/qtads/qtads-1.9.ebuild41
2 files changed, 48 insertions, 2 deletions
diff --git a/games-engines/qtads/ChangeLog b/games-engines/qtads/ChangeLog
index 6105f8f3ccbd..d12cc5c09909 100644
--- a/games-engines/qtads/ChangeLog
+++ b/games-engines/qtads/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-engines/qtads
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-engines/qtads/ChangeLog,v 1.6 2008/07/27 21:22:22 carlo Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-engines/qtads/ChangeLog,v 1.7 2009/06/30 05:37:55 mr_bones_ Exp $
+
+*qtads-1.9 (30 Jun 2009)
+
+ 30 Jun 2009; Michael Sterrett <mr_bones_@gentoo.org> +qtads-1.9.ebuild:
+ version bump (bug #217341)
27 Jul 2008; Carsten Lohrke <carlo@gentoo.org> qtads-1.6c.ebuild:
QA: Get rid of deprecated qt_min_version().
diff --git a/games-engines/qtads/qtads-1.9.ebuild b/games-engines/qtads/qtads-1.9.ebuild
new file mode 100644
index 000000000000..1a0d13758785
--- /dev/null
+++ b/games-engines/qtads/qtads-1.9.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-engines/qtads/qtads-1.9.ebuild,v 1.1 2009/06/30 05:37:55 mr_bones_ Exp $
+
+EAPI=2
+inherit flag-o-matic qt3 games
+
+DESCRIPTION="Qt3-based GUI interpreter for TADS 2 and TADS 3 text adventures"
+HOMEPAGE="http://qtads.sourceforge.net/"
+SRC_URI="mirror://sourceforge/qtads/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="x11-libs/qt:3"
+
+src_prepare() {
+ gunzip qtads.6.gz || die "gunzip qtads.6.gz failed"
+}
+
+src_configure() {
+ # Work-around for a bug when compiling with some versions of g++;
+ # strict-aliasing will break the Tads 3 VM.
+ append-cxxflags -fno-strict-aliasing
+ eqmake3 qtads.pro \
+ BIN_INSTALL="${GAMES_BINDIR}" DATA_INSTALL="${GAMES_DATADIR}"
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install_{target,charmaps,i18n} \
+ || die "emake install failed"
+ # install documentation manually to comply with Gentoo guidelines.
+ dodoc \
+ AUTHORS BUGS CREDITS INSTALL NEWS PORTABILITY README \
+ SOURCE_README TIPS TODO
+ doman qtads.6
+ make_desktop_entry qtads QTads
+ prepgamesdirs
+}