summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2009-11-17 08:04:15 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2009-11-17 08:04:15 +0000
commitd09726c1fb19ff1a8e2949c5d1dcbf25e09f1c97 (patch)
tree775005c7165585f26ec4ffa474710ba76d6c7017 /games-engines/scummvm-tools
parentversion bump (diff)
downloadgentoo-2-d09726c1fb19ff1a8e2949c5d1dcbf25e09f1c97.tar.gz
gentoo-2-d09726c1fb19ff1a8e2949c5d1dcbf25e09f1c97.tar.bz2
gentoo-2-d09726c1fb19ff1a8e2949c5d1dcbf25e09f1c97.zip
version bump
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'games-engines/scummvm-tools')
-rw-r--r--games-engines/scummvm-tools/ChangeLog8
-rw-r--r--games-engines/scummvm-tools/scummvm-tools-1.0.0.ebuild40
2 files changed, 47 insertions, 1 deletions
diff --git a/games-engines/scummvm-tools/ChangeLog b/games-engines/scummvm-tools/ChangeLog
index 5ffd3ee7fba4..706ae7df4267 100644
--- a/games-engines/scummvm-tools/ChangeLog
+++ b/games-engines/scummvm-tools/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-engines/scummvm-tools
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-engines/scummvm-tools/ChangeLog,v 1.28 2009/11/14 20:47:06 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-engines/scummvm-tools/ChangeLog,v 1.29 2009/11/17 08:04:15 mr_bones_ Exp $
+
+*scummvm-tools-1.0.0 (17 Nov 2009)
+
+ 17 Nov 2009; Michael Sterrett <mr_bones_@gentoo.org>
+ +scummvm-tools-1.0.0.ebuild:
+ version bump
14 Nov 2009; Markus Meier <maekke@gentoo.org>
scummvm-tools-1.0.0_rc1.ebuild:
diff --git a/games-engines/scummvm-tools/scummvm-tools-1.0.0.ebuild b/games-engines/scummvm-tools/scummvm-tools-1.0.0.ebuild
new file mode 100644
index 000000000000..db983a8645cc
--- /dev/null
+++ b/games-engines/scummvm-tools/scummvm-tools-1.0.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-engines/scummvm-tools/scummvm-tools-1.0.0.ebuild,v 1.1 2009/11/17 08:04:15 mr_bones_ Exp $
+
+EAPI=2
+WX_GTK_VER=2.8
+inherit toolchain-funcs wxwidgets games
+
+DESCRIPTION="utilities for the SCUMM game engine"
+HOMEPAGE="http://scummvm.sourceforge.net/"
+SRC_URI="mirror://sourceforge/scummvm/${P/_/}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="media-libs/libpng
+ media-libs/flac
+ media-libs/libvorbis
+ x11-libs/wxGTK:2.8"
+
+S=${WORKDIR}/${P/_/}
+
+src_prepare() {
+ rm -f *.bat
+ sed -ri \
+ -e '/^(CC|CXX)\b/d' \
+ Makefile \
+ || die "sed failed"
+}
+
+src_install() {
+ local f
+ for f in $(find . -type f -perm +1 -print); do
+ newgamesbin $f ${PN}-${f##*/} || die "newgamesbin $f failed"
+ done
+ dodoc README TODO
+ prepgamesdirs
+}