summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoseph Jezak <josejx@gentoo.org>2005-11-21 20:20:34 +0000
committerJoseph Jezak <josejx@gentoo.org>2005-11-21 20:20:34 +0000
commit7b5d1f26745391ac2ca53561628046c7c780b67a (patch)
treec6c298a1da4c5d2b5141877683f79907d4e01bf3 /games-fps/cube/cube-20050829.ebuild
parentamd64 doesn't support 2.4 kernels, thus setting KEYWORDS="-amd64" (diff)
downloadgentoo-2-7b5d1f26745391ac2ca53561628046c7c780b67a.tar.gz
gentoo-2-7b5d1f26745391ac2ca53561628046c7c780b67a.tar.bz2
gentoo-2-7b5d1f26745391ac2ca53561628046c7c780b67a.zip
Added -fsigned-char to fix bug #98813.
(Portage version: 2.0.53_rc7)
Diffstat (limited to 'games-fps/cube/cube-20050829.ebuild')
-rw-r--r--games-fps/cube/cube-20050829.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/games-fps/cube/cube-20050829.ebuild b/games-fps/cube/cube-20050829.ebuild
index 1490d080365e..31c159ad305c 100644
--- a/games-fps/cube/cube-20050829.ebuild
+++ b/games-fps/cube/cube-20050829.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/cube/cube-20050829.ebuild,v 1.1 2005/09/25 01:14:19 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/cube/cube-20050829.ebuild,v 1.2 2005/11/21 20:20:34 josejx Exp $
-inherit eutils games
+inherit eutils games flag-o-matic
MY_PV=${PV:0:4}_${PV:4:2}_${PV:6:2}
MY_P=${PN}_${MY_PV}
@@ -52,6 +52,7 @@ src_unpack() {
}
src_compile() {
+ append-flags -fsigned-char
cd enet
egamesconf || die "egamesconf failed"
emake || die "emake failed"