summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-09-09 18:10:15 +0000
committerMike Frysinger <vapier@gentoo.org>2003-09-09 18:10:15 +0000
commitc22ea1f9962983b3583d00085024413d77102212 (patch)
treeacd80fa59d92f27b0609b3d58893ef500cd09925 /games-fps/ttyquake/ttyquake-0.4.2.ebuild
parentNew version 'n cleanup (diff)
downloadgentoo-2-c22ea1f9962983b3583d00085024413d77102212.tar.gz
gentoo-2-c22ea1f9962983b3583d00085024413d77102212.tar.bz2
gentoo-2-c22ea1f9962983b3583d00085024413d77102212.zip
games-fps uNF uNF uNF
Diffstat (limited to 'games-fps/ttyquake/ttyquake-0.4.2.ebuild')
-rw-r--r--games-fps/ttyquake/ttyquake-0.4.2.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/games-fps/ttyquake/ttyquake-0.4.2.ebuild b/games-fps/ttyquake/ttyquake-0.4.2.ebuild
new file mode 100644
index 000000000000..474e93c9376d
--- /dev/null
+++ b/games-fps/ttyquake/ttyquake-0.4.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/ttyquake/ttyquake-0.4.2.ebuild,v 1.1 2003/09/09 18:10:14 vapier Exp $
+
+inherit games eutils gcc
+
+DESCRIPTION="Play Quake at a text terminal, in an xterm, or over a telnet session"
+HOMEPAGE="http://webpages.mr.net/bobz/ttyquake/"
+SRC_URI="ftp://ftp.skypoint.com/pub/members/b/bobz/${P}.tar.gz
+ http://webpages.mr.net/bobz/ttyquake/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+
+RDEPEND="app-games/quake1"
+
+S=${WORKDIR}
+
+pkg_setup() {
+ [ -x ${GAMES_BINDIR}/squake ] || die "You must emerge quake1 with svga in your USE"
+ games_pkg_setup
+}
+
+src_install() {
+ exeinto ${GAMES_LIBDIR}/${PN}
+ doexe tty/*
+ dogamesbin ${FILESDIR}/ttyquake
+ dosed "s:GENTOO_LIBDIR:${GAMES_LIBDIR}/${PN}:" ${GAMES_BINDIR}/ttyquake
+ dosed "s:GENTOO_BINDIR:${GAMES_BINDIR}:" ${GAMES_BINDIR}/ttyquake
+
+ dodoc README.ttyquake
+ prepgamesdirs
+}