summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2006-03-14 22:58:45 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2006-03-14 22:58:45 +0000
commit6283506f5641b57e60faee9f491756b4a5cc5f33 (patch)
tree02c7be7557f5bbe76186ba8db17174f3395d37cd /games-fps/ut2004-bonuspack-ece
parentInitial import. Ebuild by Allen Booker <gentoo-bugs@allen.brooker.gb.net>. ... (diff)
downloadgentoo-2-6283506f5641b57e60faee9f491756b4a5cc5f33.tar.gz
gentoo-2-6283506f5641b57e60faee9f491756b4a5cc5f33.tar.bz2
gentoo-2-6283506f5641b57e60faee9f491756b4a5cc5f33.zip
Added new ebuild using the megapack distfile. Ebuild by Paul Bredbury <brebs@sent.com>. Closing bug #116334.
(Portage version: 2.1_pre4-r1)
Diffstat (limited to 'games-fps/ut2004-bonuspack-ece')
-rw-r--r--games-fps/ut2004-bonuspack-ece/ChangeLog11
-rw-r--r--games-fps/ut2004-bonuspack-ece/files/digest-ut2004-bonuspack-ece-1-r13
-rw-r--r--games-fps/ut2004-bonuspack-ece/ut2004-bonuspack-ece-1-r1.ebuild88
-rw-r--r--games-fps/ut2004-bonuspack-ece/ut2004-bonuspack-ece-1.ebuild6
4 files changed, 103 insertions, 5 deletions
diff --git a/games-fps/ut2004-bonuspack-ece/ChangeLog b/games-fps/ut2004-bonuspack-ece/ChangeLog
index 5c511cb6ab78..4cb2ff77401a 100644
--- a/games-fps/ut2004-bonuspack-ece/ChangeLog
+++ b/games-fps/ut2004-bonuspack-ece/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for games-fps/ut2004-bonuspack-ece
-# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/ut2004-bonuspack-ece/ChangeLog,v 1.3 2005/08/30 19:12:48 wolf31o2 Exp $
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/ut2004-bonuspack-ece/ChangeLog,v 1.4 2006/03/14 22:58:45 wolf31o2 Exp $
+
+*ut2004-bonuspack-ece-1-r1 (14 Mar 2006)
+
+ 14 Mar 2006; Chris Gianelloni <wolf31o2@gentoo.org>
+ ut2004-bonuspack-ece-1.ebuild, +ut2004-bonuspack-ece-1-r1.ebuild:
+ Added new ebuild using the megapack distfile. Ebuild by Paul Bredbury
+ <brebs@sent.com>. Closing bug #116334.
30 Aug 2005; Chris Gianelloni <wolf31o2@gentoo.org>
ut2004-bonuspack-ece-1.ebuild:
diff --git a/games-fps/ut2004-bonuspack-ece/files/digest-ut2004-bonuspack-ece-1-r1 b/games-fps/ut2004-bonuspack-ece/files/digest-ut2004-bonuspack-ece-1-r1
new file mode 100644
index 000000000000..38b19955bc69
--- /dev/null
+++ b/games-fps/ut2004-bonuspack-ece/files/digest-ut2004-bonuspack-ece-1-r1
@@ -0,0 +1,3 @@
+MD5 098be93d06823c5fd416fa701e83418f ut2004megapack-linux.tar.bz2 203124107
+RMD160 8a5fa450c0a5cb9c3a66c5996a2a92bff2a1302f ut2004megapack-linux.tar.bz2 203124107
+SHA256 b9122c8c405945d29c3cdf61f57fe4d21e886b79ea9caa0d8e0ca2e520aa472c ut2004megapack-linux.tar.bz2 203124107
diff --git a/games-fps/ut2004-bonuspack-ece/ut2004-bonuspack-ece-1-r1.ebuild b/games-fps/ut2004-bonuspack-ece/ut2004-bonuspack-ece-1-r1.ebuild
new file mode 100644
index 000000000000..680ad0f2c03a
--- /dev/null
+++ b/games-fps/ut2004-bonuspack-ece/ut2004-bonuspack-ece-1-r1.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/ut2004-bonuspack-ece/ut2004-bonuspack-ece-1-r1.ebuild,v 1.1 2006/03/14 22:58:45 wolf31o2 Exp $
+
+inherit games games-ut2k4mod
+
+MY_P="ut2004megapack-linux.tar.bz2"
+
+DESCRIPTION="Unreal Tournament 2004 - Editor's Choice Edition bonus pack"
+HOMEPAGE="http://www.unrealtournament2004.com/"
+SRC_URI="mirror://3dgamers/unrealtourn2k4/Missions/${MY_P}
+ http://0day.icculus.org/ut2004/${MY_P}
+ ftp://ftp.games.skynet.be/pub/misc/${MY_P}
+ http://sonic-lux.net/data/mirror/ut2004/${MY_P}"
+
+LICENSE="ut2003"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="nostrip nomirror"
+IUSE=""
+
+# Override games-ut2k4mod eclass
+RDEPEND=">=games-fps/ut2004-3369-r1
+ games-fps/ut2004-data"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/UT2004MegaPack
+dir=${GAMES_PREFIX_OPT}/ut2004
+Ddir=${D}/${dir}
+
+pkg_setup() {
+ check_dvd
+
+ if [[ ! ${USE_ECE_DVD} -eq 1 ]]
+ then
+ games_pkg_setup
+ fi
+}
+
+src_unpack() {
+ if [[ ! ${USE_ECE_DVD} -eq 1 ]]
+ then
+ unpack ${A}
+ fi
+}
+
+src_install() {
+ if [[ ! ${USE_ECE_DVD} -eq 1 ]]
+ then
+ # Remove megapack files which are not in ece
+ rm Animations/ONSNewTank-A.ukx
+ rm Help/ReadMePatch.int.txt
+ # Help/{DebuggerLogo.bmp,InstallerLogo.bmp,Unreal.ico,UnrealEd.ico}
+ # are not in megapack.
+ # Keep new Help/UT2004Logo.bmp
+ # Manual dir does not exist in megapack
+ rm Maps/{AS*,CTF*,DM*}
+ rm Sounds/A_Announcer_BP2.uax
+ rm StaticMeshes/{JumpShipObjects.usx,Ty_RocketSMeshes.usx}
+ rm System/{A*,b*,B*,CacheRecords.ucl,*.det,*.est,*.frt,*.itt,*.kot}
+ rm System/{CTF*,D*,Editor*,G*,I*,L*,ONS-Arc*,Onslaught.*,*.md5}
+ rm System/{u*,U*,V*,X*,Core.u,Engine.u,F*,*.ucl,Sk*}
+ rm Textures/{J*,j*,T*}
+ rm -r Web
+
+ # The file lists of ut2004-3369-r1 and -r2 are identical
+ # Remove files owned by ut2004-3369-r2
+ rm Help/UT2004Logo.bmp
+ # The 2 Manifest files have not changed
+ rm System/{Manifest.in{i,t},OnslaughtFull.int}
+ rm System/{Core.int,Engine.int,Setup.int,Window.int}
+ rm System/{OnslaughtFull.u,OnslaughtBP.u}
+
+ # Install Editor's Choice Edition
+ for n in {Animations,Help,Maps,Sounds,StaticMeshes,System,Textures}
+ do
+ dodir "${dir}"/${n}
+ cp -r "${S}"/${n}/* "${Ddir}"/${n} \
+ || die "copying ${n} from Editor's Choice Edition"
+ done
+
+ prepgamesdirs
+ fi
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+}
diff --git a/games-fps/ut2004-bonuspack-ece/ut2004-bonuspack-ece-1.ebuild b/games-fps/ut2004-bonuspack-ece/ut2004-bonuspack-ece-1.ebuild
index 52107eb60a12..aa5f37869bcf 100644
--- a/games-fps/ut2004-bonuspack-ece/ut2004-bonuspack-ece-1.ebuild
+++ b/games-fps/ut2004-bonuspack-ece/ut2004-bonuspack-ece-1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/ut2004-bonuspack-ece/ut2004-bonuspack-ece-1.ebuild,v 1.3 2005/08/30 19:12:48 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/ut2004-bonuspack-ece/ut2004-bonuspack-ece-1.ebuild,v 1.4 2006/03/14 22:58:45 wolf31o2 Exp $
inherit games games-ut2k4mod
@@ -11,7 +11,7 @@ SRC_URI="mirror://3dgamers/unrealtourn2k4/Missions/${MY_P}"
LICENSE="ut2003"
SLOT="0"
-KEYWORDS="x86 amd64"
+KEYWORDS="amd64 x86"
RESTRICT="nostrip nomirror"
IUSE=""