summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2005-05-04 13:07:07 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2005-05-04 13:07:07 +0000
commit83757f1cae25192e85725049063e6cea65ced311 (patch)
treeb9634d66b298b83a773922d2e3ae919c79549b2c /games-fps
parentAdded to ~ppc (diff)
downloadgentoo-2-83757f1cae25192e85725049063e6cea65ced311.tar.gz
gentoo-2-83757f1cae25192e85725049063e6cea65ced311.tar.bz2
gentoo-2-83757f1cae25192e85725049063e6cea65ced311.zip
Removing sof script and changing to use games_make_wrapper. Added loki_patch dependency. General code cleanup.
(Portage version: 2.0.51.21)
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/soldieroffortune/ChangeLog7
-rw-r--r--games-fps/soldieroffortune/files/sof3
-rw-r--r--games-fps/soldieroffortune/soldieroffortune-1.06a.ebuild32
3 files changed, 20 insertions, 22 deletions
diff --git a/games-fps/soldieroffortune/ChangeLog b/games-fps/soldieroffortune/ChangeLog
index 0dcc07fe5644..24343f379d9f 100644
--- a/games-fps/soldieroffortune/ChangeLog
+++ b/games-fps/soldieroffortune/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-fps/soldieroffortune
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/soldieroffortune/ChangeLog,v 1.8 2005/03/07 13:55:38 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/soldieroffortune/ChangeLog,v 1.9 2005/05/04 13:07:07 wolf31o2 Exp $
+
+ 04 May 2005; Chris Gianelloni <wolf31o2@gentoo.org> -files/sof,
+ soldieroffortune-1.06a.ebuild:
+ Removing sof script and changing to use games_make_wrapper. Added loki_patch
+ dependency. General code cleanup.
07 Mar 2005; Chris Gianelloni <wolf31o2@gentoo.org>
soldieroffortune-1.06a.ebuild:
diff --git a/games-fps/soldieroffortune/files/sof b/games-fps/soldieroffortune/files/sof
deleted file mode 100644
index 7f83b44bbdc4..000000000000
--- a/games-fps/soldieroffortune/files/sof
+++ /dev/null
@@ -1,3 +0,0 @@
-#!/bin/sh
-cd GENTOO_DIR
-exec ./sof $*
diff --git a/games-fps/soldieroffortune/soldieroffortune-1.06a.ebuild b/games-fps/soldieroffortune/soldieroffortune-1.06a.ebuild
index 513a52e96c2f..82785216b4cb 100644
--- a/games-fps/soldieroffortune/soldieroffortune-1.06a.ebuild
+++ b/games-fps/soldieroffortune/soldieroffortune-1.06a.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/soldieroffortune/soldieroffortune-1.06a.ebuild,v 1.9 2005/03/07 13:55:38 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/soldieroffortune/soldieroffortune-1.06a.ebuild,v 1.10 2005/05/04 13:07:07 wolf31o2 Exp $
inherit games
-DESCRIPTION="Soldier of Fortune - First-person shooter based on the mercenary trade"
+DESCRIPTION="First-person shooter based on the mercenary trade"
HOMEPAGE="http://www.lokigames.com/products/sof/"
SRC_URI="ftp://ftp.planetmirror.com/pub/lokigames/updates/sof/sof-${PV}-cdrom-x86.run
ftp://snuffleupagus.animearchive.org/loki/updates/sof/sof-${PV}-cdrom-x86.run"
@@ -15,9 +15,9 @@ KEYWORDS="x86"
RESTRICT="nostrip"
IUSE=""
-DEPEND="virtual/libc"
-RDEPEND="${DEPEND}
- virtual/opengl"
+DEPEND="virtual/libc
+ games-util/loki_patch"
+RDEPEND="virtual/opengl"
S=${WORKDIR}
@@ -40,28 +40,24 @@ src_install() {
exeinto ${dir}
doexe ${CDROM_ROOT}/bin/x86/glibc-2.1/sof
insinto ${dir}
+ doins ${CDROM_ROOT}/{README,kver.pub,sof.xpm}
- cp ${CDROM_ROOT}/{README,kver.pub,sof.xpm} ${Ddir}
-
- cd ${Ddir}
-
- tar xzf ${CDROM_ROOT}/paks.tar.gz || die "uncompressing data"
- tar xzf ${CDROM_ROOT}/binaries.tar.gz || die "uncompressing binaries"
+ tar xzf ${CDROM_ROOT}/paks.tar.gz -C ${Ddir} \
+ || die "uncompressing data"
+ tar xzf ${CDROM_ROOT}/binaries.tar.gz -C ${Ddir} \
+ || die "uncompressing binaries"
cd ${S}
- bin/Linux/x86/loki_patch --verify patch.dat
- bin/Linux/x86/loki_patch patch.dat ${Ddir} >& /dev/null || die "patching"
+ loki_patch --verify patch.dat
+ loki_patch patch.dat ${Ddir} >& /dev/null || die "patching"
# now, since these files are coming off a cd, the times/sizes/md5sums wont
# be different ... that means portage will try to unmerge some files (!)
# we run touch on ${D} so as to make sure portage doesnt do any such thing
find ${Ddir} -exec touch '{}' \;
- dodir ${GAMES_BINDIR}
- dogamesbin ${FILESDIR}/sof
- dosed "s:GENTOO_DIR:${dir}:" ${GAMES_BINDIR}/sof
- insinto /usr/share/pixmaps
- doins ${CDROM_ROOT}/sof.xpm
+ games_make_wrapper sof ./sof ${dir}
+ doicon ${CDROM_ROOT}/sof.xpm
prepgamesdirs
make_desktop_entry sof "Soldier of Fortune" sof.xpm