summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2008-09-06 15:39:16 +0000
committerTristan Heaven <nyhm@gentoo.org>2008-09-06 15:39:16 +0000
commitd3d1cf522f2eb8991ac5c39ade7b9ee5c4bfc592 (patch)
tree8b72d10b81aba8284d95047e7f2c1291428af8e6 /games-fps
parentInitial commit, bug #198078 (diff)
downloadgentoo-2-d3d1cf522f2eb8991ac5c39ade7b9ee5c4bfc592.tar.gz
gentoo-2-d3d1cf522f2eb8991ac5c39ade7b9ee5c4bfc592.tar.bz2
gentoo-2-d3d1cf522f2eb8991ac5c39ade7b9ee5c4bfc592.zip
Initial commit, bug #196452
(Portage version: 2.2_rc8/cvs/Linux 2.6.26.3 x86_64)
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/etqw-bin/ChangeLog10
-rw-r--r--games-fps/etqw-bin/Manifest4
-rw-r--r--games-fps/etqw-bin/etqw-bin-1.5.ebuild75
-rw-r--r--games-fps/etqw-bin/metadata.xml9
4 files changed, 98 insertions, 0 deletions
diff --git a/games-fps/etqw-bin/ChangeLog b/games-fps/etqw-bin/ChangeLog
new file mode 100644
index 000000000000..e218e46855e3
--- /dev/null
+++ b/games-fps/etqw-bin/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for games-fps/etqw-bin
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/etqw-bin/ChangeLog,v 1.1 2008/09/06 15:39:16 nyhm Exp $
+
+*etqw-bin-1.5 (06 Sep 2008)
+
+ 06 Sep 2008; Tristan Heaven <nyhm@gentoo.org> +metadata.xml,
+ +etqw-bin-1.5.ebuild:
+ Initial commit, bug #196452
+
diff --git a/games-fps/etqw-bin/Manifest b/games-fps/etqw-bin/Manifest
new file mode 100644
index 000000000000..6895595b357c
--- /dev/null
+++ b/games-fps/etqw-bin/Manifest
@@ -0,0 +1,4 @@
+DIST ETQW-client-1.5-full.x86.run 556383725 RMD160 617a28844e4fc1e03e5265e700eb0f9dd6d65bab SHA1 de70a06681f647671bfd18de84276276afc1db61 SHA256 827395c5ad7bff36a8456f7f210ab43b8cc2b0d18e9f366d15ff4f11eacfc4c5
+EBUILD etqw-bin-1.5.ebuild 1828 RMD160 1bdb099df76a6f351f0b12c006b4cee0fe02bde0 SHA1 74450fcd77cd629e4d50db67349fc05bd3e01df6 SHA256 c477e5528747ba4fdd79ca7906f380bd57b563c06c60d4b540f55a8630b0d0be
+MISC ChangeLog 266 RMD160 8761b94f7a0278f0e2a0378a0271c80fe20390d5 SHA1 fc2d3f5de0bba130397f6484887587dc7d983f4a SHA256 4b58449d3c60ac7fca3400e6e33ef6a91f71b73f0b4c3367803d89ef4a1d4c0b
+MISC metadata.xml 251 RMD160 06f6da1d444a200da939f3a66efda69e106d437a SHA1 33620e22c3208afee5b6c4641a7fcfe30bfc2009 SHA256 1ee2ce2802a2ce864b396d3300b3a8f7bea466b1280840097c29265e2ad4a7b2
diff --git a/games-fps/etqw-bin/etqw-bin-1.5.ebuild b/games-fps/etqw-bin/etqw-bin-1.5.ebuild
new file mode 100644
index 000000000000..9e489a4f868b
--- /dev/null
+++ b/games-fps/etqw-bin/etqw-bin-1.5.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/etqw-bin/etqw-bin-1.5.ebuild,v 1.1 2008/09/06 15:39:16 nyhm Exp $
+
+inherit eutils games
+
+DESCRIPTION="Enemy Territory: Quake Wars"
+HOMEPAGE="http://zerowing.idsoftware.com/linux/etqw/"
+SRC_URI="ETQW-client-${PV}-full.x86.run"
+
+LICENSE="ETQW"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE="cdinstall"
+RESTRICT="fetch strip"
+
+DEPEND="app-arch/unzip"
+RDEPEND="sys-libs/glibc
+ virtual/opengl
+ amd64? ( app-emulation/emul-linux-x86-sdl )
+ x86? (
+ media-libs/libsdl
+ media-libs/alsa-lib
+ )
+ cdinstall? ( games-fps/etqw-data )"
+
+S=${WORKDIR}/data
+dir=${GAMES_PREFIX_OPT}/etqw
+
+QA_TEXTRELS="${dir:1}/pb/*.so"
+QA_EXECSTACK="${dir:1}/*.x86
+ ${dir:1}/*.so*"
+
+GAMES_CHECK_LICENSE="yes"
+
+pkg_nofetch() {
+ einfo "Please download ${A} from"
+ einfo "${HOMEPAGE} (requires a BitTorrent client)"
+ einfo "and copy it to ${DISTDIR}"
+}
+
+src_unpack() {
+ tail -c +194885 "${DISTDIR}"/${A} > ${A}.zip
+ unpack ./${A}.zip
+ rm -f ${A}.zip
+}
+
+src_install() {
+ insinto "${dir}"
+ doins -r base pb *.png *.txt || die "doins failed"
+
+ exeinto "${dir}"
+ doexe etqw{,-rthread}.x86 openurl.sh *.so* || die "doexe failed"
+
+ newicon etqw_icon.png etqw.png
+ games_make_wrapper etqw ./etqw.x86 "${dir}" "${dir}"
+ make_desktop_entry etqw "Enemy Territory: Quake Wars" etqw.png
+
+ games_make_wrapper etqw-rthread ./etqw-rthread.x86 "${dir}" "${dir}"
+ make_desktop_entry etqw-rthread "Enemy Territory: Quake Wars (SMP)" etqw.png
+
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+
+ if ! use cdinstall ; then
+ elog "You need to copy pak00*.pk4, zpak_*.pk4 and the megatextures"
+ elog "directory to ${dir}/base before running the game."
+ fi
+ elog "To change the game language from English, add"
+ elog "seta sys_lang \"your_language\" to your autoexec.cfg file."
+ elog "Menu fonts may not show up until you do so."
+}
diff --git a/games-fps/etqw-bin/metadata.xml b/games-fps/etqw-bin/metadata.xml
new file mode 100644
index 000000000000..2f55aed2d76d
--- /dev/null
+++ b/games-fps/etqw-bin/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <maintainer>
+ <email>nyhm@gentoo.org</email>
+ <name>Tristan Heaven</name>
+ </maintainer>
+</pkgmetadata>