summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2011-10-19 21:14:37 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2011-10-19 21:14:37 +0000
commitf2f4893e1ae13bc7403f11e7e8a3dcee32d2985e (patch)
treeca6e3f96006b43ebbabfeec3999cdffd46680ecc /games-kids
parentFix java 7 sandbox violation, bug 387227 (diff)
downloadgentoo-2-f2f4893e1ae13bc7403f11e7e8a3dcee32d2985e.tar.gz
gentoo-2-f2f4893e1ae13bc7403f11e7e8a3dcee32d2985e.tar.bz2
gentoo-2-f2f4893e1ae13bc7403f11e7e8a3dcee32d2985e.zip
EAPI=2; fix up desktop file
(Portage version: 2.1.10.11/cvs/Linux i686)
Diffstat (limited to 'games-kids')
-rw-r--r--games-kids/gmult/ChangeLog5
-rw-r--r--games-kids/gmult/gmult-5.3.ebuild22
2 files changed, 14 insertions, 13 deletions
diff --git a/games-kids/gmult/ChangeLog b/games-kids/gmult/ChangeLog
index 715fc60d2e67..3e67f300500d 100644
--- a/games-kids/gmult/ChangeLog
+++ b/games-kids/gmult/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-kids/gmult
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-kids/gmult/ChangeLog,v 1.13 2011/03/29 07:54:52 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-kids/gmult/ChangeLog,v 1.14 2011/10/19 21:14:37 mr_bones_ Exp $
+
+ 19 Oct 2011; Michael Sterrett <mr_bones_@gentoo.org> gmult-5.3.ebuild:
+ EAPI=2; fix up desktop file
29 Mar 2011; Christoph Mende <angelos@gentoo.org> gmult-5.3.ebuild:
Fixed slot deps
diff --git a/games-kids/gmult/gmult-5.3.ebuild b/games-kids/gmult/gmult-5.3.ebuild
index 2538176443f8..a67d0cf2c035 100644
--- a/games-kids/gmult/gmult-5.3.ebuild
+++ b/games-kids/gmult/gmult-5.3.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-kids/gmult/gmult-5.3.ebuild,v 1.5 2011/03/29 07:54:52 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-kids/gmult/gmult-5.3.ebuild,v 1.6 2011/10/19 21:14:37 mr_bones_ Exp $
-EAPI=1
+EAPI=2
inherit eutils gnome2-utils games
DESCRIPTION="Multiplication Puzzle is a simple GTK+ 2 game that emulates the multiplication game found in Emacs"
@@ -19,21 +19,19 @@ RDEPEND=">=dev-cpp/gtkmm-2.6:2.4
DEPEND="${RDEPEND}
sys-devel/gettext"
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
epatch "${FILESDIR}"/${P}-gcc43.patch
+ sed -i -e 's/-pedantic//' gmult/Makefile.in || die
sed -i \
- -e 's/-pedantic//' \
- gmult/Makefile.in \
- || die "sed failed"
+ -e '/Encoding/d' \
+ -e '/FilePattern/d' \
+ -e '/Categories/s/Application;//' \
+ gmult.desktop.in || die
}
-src_compile() {
+src_configure() {
egamesconf \
- --datadir=/usr/share \
- || die
- emake || die "emake failed"
+ --datadir=/usr/share
}
src_install() {