summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2015-01-09 01:51:55 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2015-01-09 01:51:55 +0000
commit8ab4ca1bd035118eb85be5b64dfca0b32eba6419 (patch)
tree41603ff141f8c15fa4f64099f30c560a437a2bce /games-misc
parentAdded prefix keywords. (diff)
downloadgentoo-2-8ab4ca1bd035118eb85be5b64dfca0b32eba6419.tar.gz
gentoo-2-8ab4ca1bd035118eb85be5b64dfca0b32eba6419.tar.bz2
gentoo-2-8ab4ca1bd035118eb85be5b64dfca0b32eba6419.zip
initial commit to support live exult ebuild
(Portage version: 2.2.14/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-misc')
-rw-r--r--games-misc/exult-sound/ChangeLog9
-rw-r--r--games-misc/exult-sound/exult-sound-0.ebuild37
-rw-r--r--games-misc/exult-sound/metadata.xml5
3 files changed, 51 insertions, 0 deletions
diff --git a/games-misc/exult-sound/ChangeLog b/games-misc/exult-sound/ChangeLog
new file mode 100644
index 000000000000..6c92c1b8dbfe
--- /dev/null
+++ b/games-misc/exult-sound/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for games-misc/exult-sound
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-misc/exult-sound/ChangeLog,v 1.1 2015/01/09 01:51:55 mr_bones_ Exp $
+
+*exult-sound-0 (09 Jan 2015)
+
+ 09 Jan 2015; Michael Sterrett <mr_bones_@gentoo.org> +exult-sound-0.ebuild,
+ +metadata.xml:
+ initial commit to support live exult ebuild
diff --git a/games-misc/exult-sound/exult-sound-0.ebuild b/games-misc/exult-sound/exult-sound-0.ebuild
new file mode 100644
index 000000000000..39f1ca4576c9
--- /dev/null
+++ b/games-misc/exult-sound/exult-sound-0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-misc/exult-sound/exult-sound-0.ebuild,v 1.1 2015/01/09 01:51:55 mr_bones_ Exp $
+
+EAPI=5
+inherit games
+
+DESCRIPTION="sound data for games-engines/exult"
+HOMEPAGE="http://exult.sourceforge.net/"
+SRC_URI="mirror://sourceforge/exult/U7MusicOGG_1of2.zip
+ mirror://sourceforge/exult/U7MusicOGG_2of2.zip
+ mirror://sourceforge/exult/jmsfx.zip
+ mirror://sourceforge/exult/jmsfxsi.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+S=${WORKDIR}
+
+src_unpack() {
+ mkdir music && cd music || die
+ unpack U7MusicOGG_{1,2}of2.zip
+ cd "${WORKDIR}" || die
+ mkdir flx && cd flx || die
+ unpack jmsfx{,si}.zip
+}
+
+src_install() {
+ insinto "${GAMES_DATADIR}/exult/music"
+ doins "${WORKDIR}/music/"*ogg
+ insinto "${GAMES_DATADIR}/exult/"
+ doins "${WORKDIR}/flx/"*.flx
+ newdoc "${WORKDIR}/music/readme.txt" music-readme.txt
+ prepgamesdirs
+}
diff --git a/games-misc/exult-sound/metadata.xml b/games-misc/exult-sound/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-misc/exult-sound/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>