summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2006-10-01 23:49:32 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2006-10-01 23:49:32 +0000
commitc0681a0e446e8f48d2d94db1d3909ccbce8db091 (patch)
treec24a4b9accdbc6f19e99e61ee3c7a35ffbed8cda /games-mud/tf/tf-40-r2.ebuild
parentversion bump (diff)
downloadgentoo-2-c0681a0e446e8f48d2d94db1d3909ccbce8db091.tar.gz
gentoo-2-c0681a0e446e8f48d2d94db1d3909ccbce8db091.tar.bz2
gentoo-2-c0681a0e446e8f48d2d94db1d3909ccbce8db091.zip
fix compile with gcc4 (bug #149079) with patch from Alexander Graf; avoid prestripped binaries; tidy
(Portage version: 2.1.2_pre1-r4)
Diffstat (limited to 'games-mud/tf/tf-40-r2.ebuild')
-rw-r--r--games-mud/tf/tf-40-r2.ebuild16
1 files changed, 10 insertions, 6 deletions
diff --git a/games-mud/tf/tf-40-r2.ebuild b/games-mud/tf/tf-40-r2.ebuild
index 70e938d3cad8..8ccacb88919a 100644
--- a/games-mud/tf/tf-40-r2.ebuild
+++ b/games-mud/tf/tf-40-r2.ebuild
@@ -1,11 +1,10 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-mud/tf/tf-40-r2.ebuild,v 1.8 2004/06/24 23:01:12 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-mud/tf/tf-40-r2.ebuild,v 1.9 2006/10/01 23:49:32 mr_bones_ Exp $
inherit eutils
MY_P=${P}s1
-S="${WORKDIR}/${MY_P}"
DESCRIPTION="A small full-featured MUD client"
HOMEPAGE="http://tf.tcp.com/~hawkeye/tf/"
SRC_URI="mirror://tinyfugue/${MY_P}.tar.gz
@@ -13,16 +12,21 @@ SRC_URI="mirror://tinyfugue/${MY_P}.tar.gz
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="x86 ~amd64 ~sparc"
+KEYWORDS=" ~amd64 ~sparc x86"
IUSE="doc"
DEPEND=">=sys-libs/ncurses-5.2"
+S=${WORKDIR}/${MY_P}
+
src_unpack() {
unpack ${A}
- cd ${S}
- epatch "${FILESDIR}/${P}-gentoo.diff"
+ cd "${S}"
+ epatch \
+ "${FILESDIR}/${P}-gentoo.diff" \
+ "${FILESDIR}/${P}-gcc4.patch"
}
+
src_compile() {
echo 'y' | ./unixmake config || die
./unixmake all || die