summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2009-01-23 08:32:19 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2009-01-23 08:32:19 +0000
commit5cf86895a3da0e1c7485c3e091cdabce4df35798 (patch)
tree716bbad3a77165b828713ffa7f6b0d2e5afb7674 /games-puzzle/ensemblist/ensemblist-040126.ebuild
parentVersion bump (diff)
downloadgentoo-2-5cf86895a3da0e1c7485c3e091cdabce4df35798.tar.gz
gentoo-2-5cf86895a3da0e1c7485c3e091cdabce4df35798.tar.bz2
gentoo-2-5cf86895a3da0e1c7485c3e091cdabce4df35798.zip
EAPI=2; add use-based dep; fixup build process a bit
(Portage version: 2.1.6.4/cvs/Linux 2.6.28.1 i686)
Diffstat (limited to 'games-puzzle/ensemblist/ensemblist-040126.ebuild')
-rw-r--r--games-puzzle/ensemblist/ensemblist-040126.ebuild23
1 files changed, 10 insertions, 13 deletions
diff --git a/games-puzzle/ensemblist/ensemblist-040126.ebuild b/games-puzzle/ensemblist/ensemblist-040126.ebuild
index f0b11d7a9aba..af8f1cd636f9 100644
--- a/games-puzzle/ensemblist/ensemblist-040126.ebuild
+++ b/games-puzzle/ensemblist/ensemblist-040126.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/ensemblist/ensemblist-040126.ebuild,v 1.6 2006/12/06 16:59:33 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/ensemblist/ensemblist-040126.ebuild,v 1.7 2009/01/23 08:32:19 mr_bones_ Exp $
-inherit games
+EAPI=2
+inherit eutils games
DESCRIPTION="Put together several primitives to build a given shape. (C.S.G. Game)"
HOMEPAGE="http://www.nongnu.org/ensemblist/index_en.html"
@@ -18,17 +19,12 @@ DEPEND="x11-libs/libXmu
virtual/glut
virtual/glu
media-libs/libpng
- media-libs/libmikmod"
+ media-libs/libmikmod[oss]"
-src_unpack() {
- unpack ${A}
- cd "${S}"
- sed -i \
- -e '/^CC/d' \
- -e '/strip/d' \
- -e "s:^DATADIR=.*:DATADIR=${GAMES_DATADIR}/${PN}/datas:" \
- -e "/^COMPILE_FLAGS/s/-Wall -O3 -fomit-frame-pointer/${CFLAGS}/" \
- Makefile || die "sed failed"
+PATCHES=( "${FILESDIR}"/${P}-build.patch )
+
+src_compile() {
+ emake DATADIR="\"${GAMES_DATADIR}\"/${PN}/datas" || die "emake failed"
}
src_install() {
@@ -36,5 +32,6 @@ src_install() {
insinto "${GAMES_DATADIR}/${PN}"
doins -r datas || die "doins failed"
dodoc README Changelog
+ make_desktop_entry ${PN} Ensemblist
prepgamesdirs
}