summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-09-21 04:27:10 +0000
committerMike Frysinger <vapier@gentoo.org>2006-09-21 04:27:10 +0000
commitc19bd2e3f223a1a5d14922bca087b6b3cf01ba17 (patch)
treef46fc2f3f2679cd05360316dcce86c4721aa8aee /games-puzzle/fish-fillets/fish-fillets-0.7.3-r1.ebuild
parentStable on SPARC wrt bug #146702. (diff)
downloadgentoo-2-c19bd2e3f223a1a5d14922bca087b6b3cf01ba17.tar.gz
gentoo-2-c19bd2e3f223a1a5d14922bca087b6b3cf01ba17.tar.bz2
gentoo-2-c19bd2e3f223a1a5d14922bca087b6b3cf01ba17.zip
Push out patches and fix datadir path.
(Portage version: 2.1.2_pre1)
Diffstat (limited to 'games-puzzle/fish-fillets/fish-fillets-0.7.3-r1.ebuild')
-rw-r--r--games-puzzle/fish-fillets/fish-fillets-0.7.3-r1.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/games-puzzle/fish-fillets/fish-fillets-0.7.3-r1.ebuild b/games-puzzle/fish-fillets/fish-fillets-0.7.3-r1.ebuild
new file mode 100644
index 000000000000..94ab07de3a43
--- /dev/null
+++ b/games-puzzle/fish-fillets/fish-fillets-0.7.3-r1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/fish-fillets/fish-fillets-0.7.3-r1.ebuild,v 1.1 2006/09/21 04:27:10 vapier Exp $
+
+inherit autotools eutils games
+
+DATA_PV="0.7.1"
+DESCRIPTION="Underwater puzzle game - find a safe way out"
+HOMEPAGE="http://fillets.sourceforge.net/"
+SRC_URI="mirror://sourceforge/fillets/fillets-ng-${PV}.tar.gz
+ mirror://sourceforge/fillets/fillets-ng-data-${DATA_PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="X"
+
+DEPEND=">=media-libs/libsdl-1.2
+ >=media-libs/sdl-mixer-1.2.5
+ >=media-libs/sdl-image-1.2.2
+ X? ( x11-libs/libX11 )
+ media-libs/sdl-ttf
+ >=dev-lang/lua-5"
+
+S=${WORKDIR}/fillets-ng-${PV}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-check-for-X.patch
+ epatch "${FILESDIR}"/${P}-custom-datadir.patch
+ epatch "${FILESDIR}"/${P}-no-local-paths.patch
+ epatch "${FILESDIR}"/${P}-use-lua-pkg-config.patch
+ eautoreconf
+}
+
+src_compile() {
+ egamesconf \
+ --datadir="${GAMES_DATADIR}/${PN}" \
+ $(use_with X) \
+ || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog NEWS README TODO
+ insinto "${GAMES_DATADIR}/${PN}"
+ cd "${WORKDIR}"/fillets-ng-data-${DATA_PV} || die
+ rm -f COPYING
+ doins -r * || die "doins failed"
+ newicon images/icon.png fillets.png
+ make_desktop_entry fillets FishFillets fillets.png
+ prepgamesdirs
+}