summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2009-02-10 10:29:56 +0000
committerAlfredo Tupone <tupone@gentoo.org>2009-02-10 10:29:56 +0000
commit4b8fc2521cbbe4fd7f2776267e0d17e526e60c64 (patch)
tree89ad9806bf046d2625f99c105443c599d4956482 /games-puzzle/krystaldrop/krystaldrop-0.7.2.ebuild
parentchanged SRC_URI to use project page (requires EAPI2) (diff)
downloadgentoo-2-4b8fc2521cbbe4fd7f2776267e0d17e526e60c64.tar.gz
gentoo-2-4b8fc2521cbbe4fd7f2776267e0d17e526e60c64.tar.bz2
gentoo-2-4b8fc2521cbbe4fd7f2776267e0d17e526e60c64.zip
Fix --as-needed bug #247443
Use package name in distfiles (Portage version: 2.1.6.4/cvs/Linux 2.6.27-gentoo-r8 x86_64)
Diffstat (limited to 'games-puzzle/krystaldrop/krystaldrop-0.7.2.ebuild')
-rw-r--r--games-puzzle/krystaldrop/krystaldrop-0.7.2.ebuild17
1 files changed, 8 insertions, 9 deletions
diff --git a/games-puzzle/krystaldrop/krystaldrop-0.7.2.ebuild b/games-puzzle/krystaldrop/krystaldrop-0.7.2.ebuild
index 163ee93eb609..611ae3aaba24 100644
--- a/games-puzzle/krystaldrop/krystaldrop-0.7.2.ebuild
+++ b/games-puzzle/krystaldrop/krystaldrop-0.7.2.ebuild
@@ -1,13 +1,14 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/krystaldrop/krystaldrop-0.7.2.ebuild,v 1.9 2008/07/31 04:21:55 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/krystaldrop/krystaldrop-0.7.2.ebuild,v 1.10 2009/02/10 10:29:56 tupone Exp $
+EAPI=2
inherit eutils games
DESCRIPTION="Free clone of an excellent NeoGeo puzzle game, Magical Drop"
HOMEPAGE="http://krystaldrop.sourceforge.net/"
-SRC_URI="mirror://sourceforge/krystaldrop/art_${PV}.tgz
- mirror://sourceforge/krystaldrop/src_${PV}.tgz"
+SRC_URI="mirror://sourceforge/krystaldrop/art_${PV}.tgz -> ${P}-art.tgz
+ mirror://sourceforge/krystaldrop/src_${PV}.tgz -> ${P}-src.tgz"
LICENSE="GPL-2"
SLOT="0"
@@ -23,16 +24,14 @@ DEPEND="virtual/opengl
S=${WORKDIR}/${PN}
-src_unpack() {
- unpack src_${PV}.tgz
- cd "${S}"
+src_prepare() {
+ mv ../art .
epatch "${FILESDIR}/krystaldrop-assert.patch" \
"${FILESDIR}/${P}"-gcc41.patch \
"${FILESDIR}/${P}"-gcc43.patch \
+ "${FILESDIR}/${P}"-as-needed.patch \
"${FILESDIR}/${P}"-deps.patch
- unpack art_${PV}.tgz
-
sed -i \
-e "/^EXEDIR:=/ s|$|/bin|" \
-e "/^INSTALL_PREFIX:=/ s|$|${D}|" Makefile \