summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2010-08-07 14:38:26 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2010-08-07 14:38:26 +0000
commite08c9436962a9f883e5093a75285ef57a2a58afa (patch)
treee5dd12a2db426f2289990a2e867d3936a3a45733 /games-puzzle/pingus
parentChange virtual/ruby to dev-lang/ruby, bug 265054. (diff)
downloadgentoo-2-e08c9436962a9f883e5093a75285ef57a2a58afa.tar.gz
gentoo-2-e08c9436962a9f883e5093a75285ef57a2a58afa.tar.bz2
gentoo-2-e08c9436962a9f883e5093a75285ef57a2a58afa.zip
version bump
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'games-puzzle/pingus')
-rw-r--r--games-puzzle/pingus/ChangeLog10
-rw-r--r--games-puzzle/pingus/files/pingus-0.7.3-paths.patch34
-rw-r--r--games-puzzle/pingus/pingus-0.7.3.ebuild56
3 files changed, 98 insertions, 2 deletions
diff --git a/games-puzzle/pingus/ChangeLog b/games-puzzle/pingus/ChangeLog
index 475ef2b123a1..1fa26129d775 100644
--- a/games-puzzle/pingus/ChangeLog
+++ b/games-puzzle/pingus/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-puzzle/pingus
-# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/pingus/ChangeLog,v 1.24 2009/06/08 04:41:08 mr_bones_ Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/pingus/ChangeLog,v 1.25 2010/08/07 14:38:25 mr_bones_ Exp $
+
+*pingus-0.7.3 (07 Aug 2010)
+
+ 07 Aug 2010; Michael Sterrett <mr_bones_@gentoo.org> +pingus-0.7.3.ebuild,
+ +files/pingus-0.7.3-paths.patch:
+ version bump
08 Jun 2009; Michael Sterrett <mr_bones_@gentoo.org> pingus-0.7.2.ebuild:
only use the -j part of MAKEOPTS
diff --git a/games-puzzle/pingus/files/pingus-0.7.3-paths.patch b/games-puzzle/pingus/files/pingus-0.7.3-paths.patch
new file mode 100644
index 000000000000..00d974f92bb3
--- /dev/null
+++ b/games-puzzle/pingus/files/pingus-0.7.3-paths.patch
@@ -0,0 +1,34 @@
+--- install.sh
++++ install.sh
+@@ -14,8 +14,8 @@
+ exit 1
+ fi
+
+- BINDIR="$1/bin/"
+- DATADIR="$1/share/pingus/"
++ BINDIR="${1}GENTOO_BINDIR"
++ DATADIR="${1}GENTOO_DATADIR"
+
+ echo "Installing Pingus in: $1"
+
+--- SConstruct
++++ SConstruct
+@@ -406,7 +406,6 @@
+
+ config_h = open('config.h', 'w')
+ config_h.write('#define VERSION "0.7.2"\n')
+- config_h.write('#define ENABLE_BINRELOC 1\n')
+ config_h.write('#define ICONV_CONST %s\n' % iconv_const)
+ for (v,k) in config_h_defines:
+ config_h.write('#define %s %s\n' % (v, k))
+--- src/pingus_main.cpp
++++ src/pingus_main.cpp
+@@ -583,7 +583,7 @@
+ path_manager.add_path("data"); // assume game is run from source dir, without any magic
+ free(exe_path);
+ #else
+- path_manager.add_path("data"); // assume game is run from source dir
++ path_manager.add_path("GENTOO_DATADIR/data");
+ #endif
+
+ if (!path_manager.find_path("data/core.res"))
diff --git a/games-puzzle/pingus/pingus-0.7.3.ebuild b/games-puzzle/pingus/pingus-0.7.3.ebuild
new file mode 100644
index 000000000000..e1a76df51ccd
--- /dev/null
+++ b/games-puzzle/pingus/pingus-0.7.3.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/pingus/pingus-0.7.3.ebuild,v 1.1 2010/08/07 14:38:26 mr_bones_ Exp $
+
+EAPI=2
+inherit eutils toolchain-funcs games
+
+DESCRIPTION="free Lemmings clone"
+HOMEPAGE="http://pingus.seul.org/"
+SRC_URI="http://pingus.seul.org/files/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="media-libs/libsdl[joystick,video]
+ media-libs/sdl-image[png]
+ media-libs/sdl-mixer
+ media-libs/libpng
+ dev-libs/boost"
+DEPEND="${RDEPEND}
+ >=dev-util/scons-0.97"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-paths.patch
+ sed -i \
+ -e "s:GENTOO_BINDIR:${GAMES_BINDIR}:" \
+ -e "s:GENTOO_DATADIR:${GAMES_DATADIR}/${PN}:" \
+ install.sh src/pingus_main.cpp \
+ || die "sed failed"
+}
+
+src_configure() {
+ scons configure \
+ CXX="$(tc-getCXX)" \
+ CCFLAGS="${CXXFLAGS}" \
+ LINKFLAGS="${LDFLAGS}" \
+ || die "scons configure failed"
+}
+
+src_compile() {
+ local sconsopts=$(echo "${MAKEOPTS}" | sed -ne "/-j/ { s/.*\(-j[[:space:]]*[0-9]\+\).*/\1/; p }")
+ [[ ${MAKEOPTS/-s/} != ${MAKEOPTS} ]] && sconsopts="${sconsopts} -s"
+
+ scons ${sconsopts} || die "scons failed"
+}
+
+src_install() {
+ ./install.sh "${D}" || die "install.sh failed"
+ newicon data/images/core/worldmap/pingus_standing.png ${PN}.png
+ make_desktop_entry ${PN} Pingus
+ dodoc AUTHORS NEWS README TODO
+ prepgamesdirs
+}