summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-03-24 05:00:58 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-03-24 05:00:58 +0000
commit97487047fb1fbab630b321964b952dcb93a4cdc6 (patch)
tree47d20c582c65dee8bddcfd2decc784ff198861ab /games-puzzle/xblockout/xblockout-1.1.2.ebuild
parentdon't rdepend on sed (Manifest recommit) (diff)
downloadgentoo-2-97487047fb1fbab630b321964b952dcb93a4cdc6.tar.gz
gentoo-2-97487047fb1fbab630b321964b952dcb93a4cdc6.tar.bz2
gentoo-2-97487047fb1fbab630b321964b952dcb93a4cdc6.zip
IUSE; don't rdepend on sed; tidy
Diffstat (limited to 'games-puzzle/xblockout/xblockout-1.1.2.ebuild')
-rw-r--r--games-puzzle/xblockout/xblockout-1.1.2.ebuild19
1 files changed, 11 insertions, 8 deletions
diff --git a/games-puzzle/xblockout/xblockout-1.1.2.ebuild b/games-puzzle/xblockout/xblockout-1.1.2.ebuild
index 8f40ee57d11d..f5eb4328beaf 100644
--- a/games-puzzle/xblockout/xblockout-1.1.2.ebuild
+++ b/games-puzzle/xblockout/xblockout-1.1.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/xblockout/xblockout-1.1.2.ebuild,v 1.2 2004/02/20 06:53:36 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/xblockout/xblockout-1.1.2.ebuild,v 1.3 2004/03/24 05:00:58 mr_bones_ Exp $
inherit games
@@ -11,17 +11,20 @@ SRC_URI="ftp://ftp710.univ-lyon1.fr/pub/xbl/xbl-${PV}.tar.gz"
LICENSE="GPL-1"
SLOT="0"
KEYWORDS="x86"
+IUSE=""
-DEPEND="virtual/x11
+RDEPEND="virtual/x11
+ virtual/glibc"
+DEPEND="${RDEPEND}
>=sys-apps/sed-4"
-S=${WORKDIR}/xbl-${PV}
+S="${WORKDIR}/xbl-${PV}"
src_unpack() {
unpack ${A}
sed -i \
- -e "s:-g$:${CFLAGS}:" ${S}/Makefile.in || \
- die "sed Makefile.in failed"
+ -e "s:-g$:${CFLAGS}:" ${S}/Makefile.in \
+ || die "sed Makefile.in failed"
}
src_compile() {
@@ -29,12 +32,12 @@ src_compile() {
emake \
SCOREDIR=${GAMES_STATEDIR}/${PN} \
GROUP_GID=`id -g ${GAMES_GROUP}` \
- RESOURCEDIR=${GAMES_DATADIR}/${PN} || \
- die "emake failed"
+ RESOURCEDIR=${GAMES_DATADIR}/${PN} \
+ || die "emake failed"
}
src_install() {
- newgamesbin bl xbl
+ newgamesbin bl xbl || die "newgamesbin failed"
insinto ${GAMES_DATADIR}/${PN}
newins Xbl.ad Xbl
insinto ${GAMES_STATEDIR}/${PN}