summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2006-05-07 20:45:39 +0000
committerAlfredo Tupone <tupone@gentoo.org>2006-05-07 20:45:39 +0000
commit89b1e0aa0bcfab014a04d878989b3822689d1a23 (patch)
treeef8e8257f74f7fde0f849050e146d56a4753f2b9 /games-puzzle
parentStable on ppc64 (diff)
downloadgentoo-2-89b1e0aa0bcfab014a04d878989b3822689d1a23.tar.gz
gentoo-2-89b1e0aa0bcfab014a04d878989b3822689d1a23.tar.bz2
gentoo-2-89b1e0aa0bcfab014a04d878989b3822689d1a23.zip
Fix for gcc-4.1
(Portage version: 2.1_pre10-r3)
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/groundhog/ChangeLog6
-rw-r--r--games-puzzle/groundhog/files/groundhog-1.4-gcc41.patch11
-rw-r--r--games-puzzle/groundhog/groundhog-1.4.ebuild5
3 files changed, 19 insertions, 3 deletions
diff --git a/games-puzzle/groundhog/ChangeLog b/games-puzzle/groundhog/ChangeLog
index f25e5a9e7ae0..b60af08a0d44 100644
--- a/games-puzzle/groundhog/ChangeLog
+++ b/games-puzzle/groundhog/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-puzzle/groundhog
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/groundhog/ChangeLog,v 1.8 2006/02/17 22:08:27 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/groundhog/ChangeLog,v 1.9 2006/05/07 20:45:39 tupone Exp $
+
+ 07 May 2006; <Tupone@gentoo.org> +files/groundhog-1.4-gcc41.patch,
+ groundhog-1.4.ebuild:
+ Fix for gcc-4.1
17 Feb 2006; <Tupone@gentoo.org> groundhog-1.4.ebuild:
Modular X dependency fix
diff --git a/games-puzzle/groundhog/files/groundhog-1.4-gcc41.patch b/games-puzzle/groundhog/files/groundhog-1.4-gcc41.patch
new file mode 100644
index 000000000000..ace1ac2383b0
--- /dev/null
+++ b/games-puzzle/groundhog/files/groundhog-1.4-gcc41.patch
@@ -0,0 +1,11 @@
+--- src/options_dialog.h.old 2006-05-07 22:26:32.000000000 +0200
++++ src/options_dialog.h 2006-05-07 22:26:46.000000000 +0200
+@@ -28,7 +28,7 @@
+ Game* _game;
+ GtkWidget* _tooltips;
+
+- void OptionsDialog::OnOk();
++ void OnOk();
+ public:
+ OptionsDialog(Game* game);
+ };
diff --git a/games-puzzle/groundhog/groundhog-1.4.ebuild b/games-puzzle/groundhog/groundhog-1.4.ebuild
index f9fb34fb807e..45a2bfcca26a 100644
--- a/games-puzzle/groundhog/groundhog-1.4.ebuild
+++ b/games-puzzle/groundhog/groundhog-1.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/groundhog/groundhog-1.4.ebuild,v 1.13 2006/02/17 22:08:27 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/groundhog/groundhog-1.4.ebuild,v 1.14 2006/05/07 20:45:39 tupone Exp $
inherit eutils gnuconfig games
@@ -18,7 +18,8 @@ DEPEND="=x11-libs/gtk+-2*"
src_unpack() {
unpack ${A}
cd "${S}"
- epatch "${FILESDIR}"/${PV}-gcc3.patch
+ epatch "${FILESDIR}"/${PV}-gcc3.patch \
+ "${FILESDIR}/${P}"-gcc41.patch
}
src_compile() {