summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2014-11-19 05:01:17 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2014-11-19 05:01:17 +0000
commitdbfd24c51109d51cf1ed1f8058418a0a17dede30 (patch)
tree4e4a751a59e1a6d32ab9e3d4032a2ec87b7b193d /games-puzzle
parentFix datashape dependencies a bit (diff)
downloadgentoo-2-dbfd24c51109d51cf1ed1f8058418a0a17dede30.tar.gz
gentoo-2-dbfd24c51109d51cf1ed1f8058418a0a17dede30.tar.bz2
gentoo-2-dbfd24c51109d51cf1ed1f8058418a0a17dede30.zip
build with ncurses[tinfo] (bug #529784)
(Portage version: 2.2.8-r2/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/ngstar/ChangeLog9
-rw-r--r--games-puzzle/ngstar/files/ngstar-2.1.8-ldflags.patch16
-rw-r--r--games-puzzle/ngstar/ngstar-2.1.8-r2.ebuild17
3 files changed, 29 insertions, 13 deletions
diff --git a/games-puzzle/ngstar/ChangeLog b/games-puzzle/ngstar/ChangeLog
index ee13bd17b0ba..e3405b59728a 100644
--- a/games-puzzle/ngstar/ChangeLog
+++ b/games-puzzle/ngstar/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-puzzle/ngstar
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/ngstar/ChangeLog,v 1.10 2012/07/21 20:33:46 tupone Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/ngstar/ChangeLog,v 1.11 2014/11/19 05:01:17 mr_bones_ Exp $
+
+ 19 Nov 2014; Michael Sterrett <mr_bones_@gentoo.org>
+ files/ngstar-2.1.8-ldflags.patch, ngstar-2.1.8-r2.ebuild:
+ build with ncurses[tinfo] (bug #529784)
21 Jul 2012; Tupone Alfredo <tupone@gentoo.org> ngstar-2.1.8-r2.ebuild,
+files/ngstar-2.1.8-gcc47.patch:
@@ -45,4 +49,3 @@
11 Apr 2006; <Tupone@gentoo.org> +metadata.xml, +ngstar-2.1.8.ebuild:
Initial import. Ebuild submitted by Alexandru Toma, bug #66294
-
diff --git a/games-puzzle/ngstar/files/ngstar-2.1.8-ldflags.patch b/games-puzzle/ngstar/files/ngstar-2.1.8-ldflags.patch
index 3c8dd8e8fad8..17e0ed9f7188 100644
--- a/games-puzzle/ngstar/files/ngstar-2.1.8-ldflags.patch
+++ b/games-puzzle/ngstar/files/ngstar-2.1.8-ldflags.patch
@@ -1,5 +1,17 @@
---- src/Makefile.old 2010-09-10 09:22:06.000000000 +0200
-+++ src/Makefile 2010-09-10 09:33:20.000000000 +0200
+diff -ru ngstar-2.1.8.orig/src/Makefile ngstar-2.1.8/src/Makefile
+--- ngstar-2.1.8.orig/src/Makefile 2005-11-09 08:11:22.000000000 -0500
++++ ngstar-2.1.8/src/Makefile 2014-11-18 23:58:45.565366080 -0500
+@@ -33,8 +33,8 @@
+ endif
+ endif
+ ifdef USE_NCURSES
+- CC_LIBS += -lncurses -lgpm
+- CC_LIBS_STATIC += -lncurses -lgpm
++ CC_LIBS += $(shell pkg-config ncurses --libs) -lgpm
++ CC_LIBS_STATIC += $(shell pkg-config ncurses --libs) -lgpm
+
+ NCURSES_UI_OBJ = Ncurses_UI.o
+
@@ -56,8 +56,7 @@
$(BIN) : $(SOURCE) $(BIN_DEPS)
diff --git a/games-puzzle/ngstar/ngstar-2.1.8-r2.ebuild b/games-puzzle/ngstar/ngstar-2.1.8-r2.ebuild
index 4c4db3b6b78d..842794fc3bc4 100644
--- a/games-puzzle/ngstar/ngstar-2.1.8-r2.ebuild
+++ b/games-puzzle/ngstar/ngstar-2.1.8-r2.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/ngstar/ngstar-2.1.8-r2.ebuild,v 1.9 2012/07/21 20:33:46 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/ngstar/ngstar-2.1.8-r2.ebuild,v 1.10 2014/11/19 05:01:17 mr_bones_ Exp $
-EAPI=2
+EAPI=5
inherit eutils games
DESCRIPTION="NGStar is a clone of a HP48 game called dstar"
@@ -14,8 +14,10 @@ SLOT="0"
KEYWORDS="~amd64 x86"
IUSE=""
-DEPEND="sys-libs/ncurses
+RDEPEND="sys-libs/ncurses
sys-libs/gpm"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
src_prepare() {
epatch \
@@ -28,17 +30,16 @@ src_prepare() {
-e "s:@GENTOO_BIN@:${GAMES_BINDIR}:" \
-e "/^CPPFLAGS/s:+=:+= ${CXXFLAGS}:" \
-e "/SILENT/d" \
- configure || die "sed configure failed"
+ configure || die
}
src_configure() {
./configure \
--prefix "" \
- --without-fltk2 || die "configure failed"
+ --without-fltk2 || die
}
src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- dodoc AUTHORS Changelog README TODO
+ default
prepgamesdirs
}