summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2014-11-10 08:43:21 +0000
committerJeroen Roovers <jer@gentoo.org>2014-11-10 08:43:21 +0000
commitf63913f78323552f43b524242cf69cc3d7b12332 (patch)
treefba513fac5fac3799d7f18b03f01c4b0861d2c44 /games-puzzle
parentproxy commit for Pawel Stankowski, fix bugs 499806 513220 524996 519050 50632... (diff)
downloadgentoo-2-f63913f78323552f43b524242cf69cc3d7b12332.tar.gz
gentoo-2-f63913f78323552f43b524242cf69cc3d7b12332.tar.bz2
gentoo-2-f63913f78323552f43b524242cf69cc3d7b12332.zip
Fix building against sys-libs/ncurses[tinfo] (bug #527876).
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/tetrinet/ChangeLog8
-rw-r--r--games-puzzle/tetrinet/files/tetrinet-0.11-build.patch22
-rw-r--r--games-puzzle/tetrinet/files/tetrinet-0.11-no-ipv6.patch4
-rw-r--r--games-puzzle/tetrinet/tetrinet-0.11.ebuild19
4 files changed, 29 insertions, 24 deletions
diff --git a/games-puzzle/tetrinet/ChangeLog b/games-puzzle/tetrinet/ChangeLog
index 9ba042119ef9..9be80173ff19 100644
--- a/games-puzzle/tetrinet/ChangeLog
+++ b/games-puzzle/tetrinet/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-puzzle/tetrinet
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/tetrinet/ChangeLog,v 1.11 2010/07/14 17:38:21 mr_bones_ Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/tetrinet/ChangeLog,v 1.12 2014/11/10 08:43:21 jer Exp $
+
+ 10 Nov 2014; Jeroen Roovers <jer@gentoo.org> tetrinet-0.11.ebuild,
+ files/tetrinet-0.11-build.patch, files/tetrinet-0.11-no-ipv6.patch:
+ Fix building against sys-libs/ncurses[tinfo] (bug #527876).
14 Jul 2010; Michael Sterrett <mr_bones_@gentoo.org> tetrinet-0.11.ebuild,
+files/tetrinet-0.11-build.patch:
diff --git a/games-puzzle/tetrinet/files/tetrinet-0.11-build.patch b/games-puzzle/tetrinet/files/tetrinet-0.11-build.patch
index 719691cad4e9..0540b7bc8ce9 100644
--- a/games-puzzle/tetrinet/files/tetrinet-0.11-build.patch
+++ b/games-puzzle/tetrinet/files/tetrinet-0.11-build.patch
@@ -1,6 +1,5 @@
-diff -ru tetrinet-0.11.orig/Makefile tetrinet-0.11/Makefile
---- tetrinet-0.11.orig/Makefile 2003-09-07 12:29:29.000000000 -0400
-+++ tetrinet-0.11/Makefile 2010-07-14 13:23:52.526003482 -0400
+--- a/Makefile
++++ b/Makefile
@@ -1,6 +1,4 @@
-CC = cc
-
@@ -14,7 +13,7 @@ diff -ru tetrinet-0.11.orig/Makefile tetrinet-0.11/Makefile
tetrinet: $(OBJS)
- $(CC) -o $@ $(OBJS) -lncurses
-+ $(CC) $(LDFLAGS) -o $@ $(OBJS) -lncurses
++ $(CC) $(LDFLAGS) -o $@ $(OBJS) $(shell ${PKG_CONFIG} --libs ncurses)
tetrinet-server: server.c sockets.c tetrinet.c tetris.c server.h sockets.h tetrinet.h tetris.h
- $(CC) $(CFLAGS) -o $@ -DSERVER_ONLY server.c sockets.c tetrinet.c tetris.c
@@ -22,9 +21,8 @@ diff -ru tetrinet-0.11.orig/Makefile tetrinet-0.11/Makefile
.c.o:
$(CC) $(CFLAGS) -c $<
-diff -ru tetrinet-0.11.orig/sockets.c tetrinet-0.11/sockets.c
---- tetrinet-0.11.orig/sockets.c 2003-09-09 15:15:04.000000000 -0400
-+++ tetrinet-0.11/sockets.c 2010-07-14 13:18:28.999213319 -0400
+--- a/sockets.c
++++ b/sockets.c
@@ -66,7 +66,7 @@
if (c == 0xFF)
ptr--;
@@ -43,9 +41,8 @@ diff -ru tetrinet-0.11.orig/sockets.c tetrinet-0.11/sockets.c
if (!logfile)
logfile = fopen(logname, "a");
if (logfile) {
-diff -ru tetrinet-0.11.orig/tetrinet.c tetrinet-0.11/tetrinet.c
---- tetrinet-0.11.orig/tetrinet.c 2003-09-07 12:29:29.000000000 -0400
-+++ tetrinet-0.11/tetrinet.c 2010-07-14 13:22:33.529265565 -0400
+--- a/tetrinet.c
++++ b/tetrinet.c
@@ -21,7 +21,7 @@
/*************************************************************************/
@@ -74,9 +71,8 @@ diff -ru tetrinet-0.11.orig/tetrinet.c tetrinet-0.11/tetrinet.c
i++;
if (i >= ac) {
fprintf(stderr, "Option -log requires an argument\n");
-diff -ru tetrinet-0.11.orig/tetrinet.h tetrinet-0.11/tetrinet.h
---- tetrinet-0.11.orig/tetrinet.h 2003-09-07 12:12:51.000000000 -0400
-+++ tetrinet-0.11/tetrinet.h 2010-07-14 13:18:20.061828023 -0400
+--- a/tetrinet.h
++++ b/tetrinet.h
@@ -74,7 +74,7 @@
/* Externs */
diff --git a/games-puzzle/tetrinet/files/tetrinet-0.11-no-ipv6.patch b/games-puzzle/tetrinet/files/tetrinet-0.11-no-ipv6.patch
index 5b0cb82f75c0..addfd9a0047c 100644
--- a/games-puzzle/tetrinet/files/tetrinet-0.11-no-ipv6.patch
+++ b/games-puzzle/tetrinet/files/tetrinet-0.11-no-ipv6.patch
@@ -1,5 +1,5 @@
---- sockets.c
-+++ sockets.c
+--- a/sockets.c
++++ b/sockets.c
@@ -188,7 +188,7 @@
return -1;
}
diff --git a/games-puzzle/tetrinet/tetrinet-0.11.ebuild b/games-puzzle/tetrinet/tetrinet-0.11.ebuild
index 9232850d4fa3..fe258210bec9 100644
--- a/games-puzzle/tetrinet/tetrinet-0.11.ebuild
+++ b/games-puzzle/tetrinet/tetrinet-0.11.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/tetrinet/tetrinet-0.11.ebuild,v 1.14 2010/07/14 17:38:21 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/tetrinet/tetrinet-0.11.ebuild,v 1.15 2014/11/10 08:43:21 jer Exp $
-EAPI=2
-inherit eutils flag-o-matic games
+EAPI=5
+inherit eutils flag-o-matic games toolchain-funcs
DESCRIPTION="console based tetrinet inc. standalone server"
HOMEPAGE="http://tetrinet.or.cz/"
@@ -14,18 +14,23 @@ SLOT="0"
KEYWORDS="~amd64 ppc x86"
IUSE="ipv6"
-DEPEND=">=sys-libs/ncurses-5"
+RDEPEND=">=sys-libs/ncurses-5"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
src_prepare() {
epatch \
"${FILESDIR}"/${P}-no-ipv6.patch \
"${FILESDIR}"/${P}-build.patch
- use ipv6 && append-flags -DHAVE_IPV6
+ use ipv6 && append-cflags -DHAVE_IPV6
+ tc-export PKG_CONFIG
}
src_install() {
- dogamesbin tetrinet tetrinet-server || die "dogamesbin failed"
+ dogamesbin tetrinet tetrinet-server
dodoc README TODO tetrinet.txt
prepgamesdirs
}