summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2013-01-01 21:12:12 +0000
committerJulian Ospald <hasufell@gentoo.org>2013-01-01 21:12:12 +0000
commit3ee7cc3b344b6f8c5f060dd5bae8a64ac1fb234e (patch)
tree263056e776a282693394658abbd8ef81d8138e63 /games-roguelike/FTL/FTL-1.03.1.ebuild
parentFix LICENSE, add mirror and bindist restrictions, bug 444424. (diff)
downloadgentoo-2-3ee7cc3b344b6f8c5f060dd5bae8a64ac1fb234e.tar.gz
gentoo-2-3ee7cc3b344b6f8c5f060dd5bae8a64ac1fb234e.tar.bz2
gentoo-2-3ee7cc3b344b6f8c5f060dd5bae8a64ac1fb234e.zip
initial import
(Portage version: 2.2.0_alpha149/cvs/Linux x86_64, signed Manifest commit with key E73C35B3)
Diffstat (limited to 'games-roguelike/FTL/FTL-1.03.1.ebuild')
-rw-r--r--games-roguelike/FTL/FTL-1.03.1.ebuild68
1 files changed, 68 insertions, 0 deletions
diff --git a/games-roguelike/FTL/FTL-1.03.1.ebuild b/games-roguelike/FTL/FTL-1.03.1.ebuild
new file mode 100644
index 000000000000..dd8ccbc9bddd
--- /dev/null
+++ b/games-roguelike/FTL/FTL-1.03.1.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-roguelike/FTL/FTL-1.03.1.ebuild,v 1.1 2013/01/01 21:12:12 hasufell Exp $
+
+EAPI=5
+
+inherit eutils games
+
+DESCRIPTION="Faster Than Light: A spaceship simulation real-time roguelike-like game"
+HOMEPAGE="http://www.ftlgame.com/"
+SRC_URI="ftl_faster_than_light-linux-${PV}.tar.gz"
+
+LICENSE="all-rights-reserved Boost-1.0 free-noncomm MIT !system-libs? ( FTL GPL-2 LGPL-2.1 ZLIB )"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE="+system-libs"
+RESTRICT="fetch"
+
+RDEPEND="
+ media-libs/libpng:0
+ sys-devel/gcc[cxx]
+ virtual/opengl
+ system-libs? (
+ media-libs/devil[png,opengl]
+ media-libs/freetype:2
+ media-libs/libsdl[X,audio,joystick,opengl,video]
+ sys-libs/zlib
+ )"
+
+QA_PREBUILT="${GAMES_PREFIX_OPT}/${PN}/bin/${PN}
+ ${GAMES_PREFIX_OPT}/${PN}/lib/*"
+
+S=${WORKDIR}/${PN}
+
+pkg_nofetch() {
+ einfo "Please buy & download ${SRC_URI} from:"
+ einfo " ${HOMEPAGE}"
+ einfo "and move it to ${DISTDIR}"
+ einfo
+}
+
+src_prepare() {
+ if use system-libs ; then
+ # no system lib for libbass available
+ find data/${ARCH}/lib -type f \! -name "libbass*" -delete || die
+ fi
+}
+
+src_install() {
+ local dir=${GAMES_PREFIX_OPT}/${PN}
+
+ insinto "${dir}"
+ doins -r data/resources
+ doins data/exe_icon.bmp
+
+ exeinto "${dir}"/bin
+ doexe data/${ARCH}/bin/${PN}
+ exeinto "${dir}"/lib
+ doexe data/${ARCH}/lib/*.so*
+
+ games_make_wrapper ${PN} "${dir}/bin/${PN}" "${dir}" "${dir}/lib"
+ make_desktop_entry ${PN} "Faster Than Light" "/usr/share/pixmaps/FTL.bmp"
+
+ newicon data/exe_icon.bmp FTL.bmp
+ dohtml ${PN}_README.html
+
+ prepgamesdirs
+}