summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2009-07-26 22:03:30 +0000
committerRyan Hill <dirtyepic@gentoo.org>2009-07-26 22:03:30 +0000
commitabc36a07d64c2c70d5757f9f85c50e9506cadc63 (patch)
tree8a72288282832d56186662cc8f102cbecf0548c5 /games-rpg
parentVersion bump. Performance enhancements, translation updates. Move application... (diff)
downloadgentoo-2-abc36a07d64c2c70d5757f9f85c50e9506cadc63.tar.gz
gentoo-2-abc36a07d64c2c70d5757f9f85c50e9506cadc63.tar.bz2
gentoo-2-abc36a07d64c2c70d5757f9f85c50e9506cadc63.zip
Fix building with glibc-2.10. (bug #226191)
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'games-rpg')
-rw-r--r--games-rpg/adonthell/ChangeLog8
-rw-r--r--games-rpg/adonthell/adonthell-0.3.4a-r1.ebuild7
-rw-r--r--games-rpg/adonthell/files/adonthell-0.3.4a-glibc-2.10.patch22
3 files changed, 32 insertions, 5 deletions
diff --git a/games-rpg/adonthell/ChangeLog b/games-rpg/adonthell/ChangeLog
index 517c3fb6dc32..2ca97833c67e 100644
--- a/games-rpg/adonthell/ChangeLog
+++ b/games-rpg/adonthell/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-rpg/adonthell
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-rpg/adonthell/ChangeLog,v 1.15 2008/05/29 12:16:46 nyhm Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/adonthell/ChangeLog,v 1.16 2009/07/26 22:03:30 dirtyepic Exp $
+
+ 26 Jul 2009; Ryan Hill <dirtyepic@gentoo.org> adonthell-0.3.4a-r1.ebuild,
+ +files/adonthell-0.3.4a-glibc-2.10.patch:
+ Fix building with glibc-2.10. (bug #226191)
29 May 2008; Tristan Heaven <nyhm@gentoo.org> adonthell-0.3.4a-r1.ebuild:
Move swig to DEPEND, bug #221483
diff --git a/games-rpg/adonthell/adonthell-0.3.4a-r1.ebuild b/games-rpg/adonthell/adonthell-0.3.4a-r1.ebuild
index 01a6705082f7..250a50ee661d 100644
--- a/games-rpg/adonthell/adonthell-0.3.4a-r1.ebuild
+++ b/games-rpg/adonthell/adonthell-0.3.4a-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-rpg/adonthell/adonthell-0.3.4a-r1.ebuild,v 1.2 2008/05/29 12:16:46 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/adonthell/adonthell-0.3.4a-r1.ebuild,v 1.3 2009/07/26 22:03:30 dirtyepic Exp $
inherit autotools eutils games
@@ -34,7 +34,8 @@ src_unpack() {
"${FILESDIR}"/${PV}-configure.in.patch \
"${FILESDIR}"/${P}-gcc-41.patch \
"${FILESDIR}"/${P}-inline.patch \
- "${FILESDIR}"/${P}-external-libs.patch
+ "${FILESDIR}"/${P}-external-libs.patch \
+ "${FILESDIR}"/${P}-glibc-2.10.patch
rm -f src/SDL_ttf.* # SDL_ttf
rm -f src/{music*,SDL_mixer.h,wavestream*,mixer.c} # SDL_mixer
rm -f ac{local,include}.m4
diff --git a/games-rpg/adonthell/files/adonthell-0.3.4a-glibc-2.10.patch b/games-rpg/adonthell/files/adonthell-0.3.4a-glibc-2.10.patch
new file mode 100644
index 000000000000..7aec808cd5f1
--- /dev/null
+++ b/games-rpg/adonthell/files/adonthell-0.3.4a-glibc-2.10.patch
@@ -0,0 +1,22 @@
+diff -Naurp adonthell-0.3.4-orig/src/dialog.cc adonthell-0.3.4/src/dialog.cc
+--- adonthell-0.3.4-orig/src/dialog.cc 2005-03-10 12:39:41.000000000 -0600
++++ adonthell-0.3.4/src/dialog.cc 2009-07-26 15:57:01.410882131 -0600
+@@ -265,7 +265,8 @@ string dialog::scan_string (const char *
+ {
+ u_int32 begin, end, len;
+ PyObject *result;
+- char *tmp, *start, *mid, *str = NULL;
++ const char *start;
++ char *tmp, *mid, *str = NULL;
+ character *the_player = data::the_player;
+ string newstr (s);
+
+@@ -318,7 +319,7 @@ string dialog::scan_string (const char *
+
+ // Error!
+ cout << "\n*** Error, unknown macro " << start << flush;
+- start[0] = ' ';
++ newstr[newstr.length () - strlen (start)] = ' ';
+ }
+
+ // execute python functions