summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2010-07-29 22:50:26 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2010-07-29 22:50:26 +0000
commitab73b78e21d9767f6ddc0d87c007f5360260f3e3 (patch)
treeb9adf67d59816b120f3b47d21b2adc45edb79b14 /games-simulation/singularity
parentChange libXt depend to libX11... can't see Xt used anywhere (diff)
downloadgentoo-2-ab73b78e21d9767f6ddc0d87c007f5360260f3e3.tar.gz
gentoo-2-ab73b78e21d9767f6ddc0d87c007f5360260f3e3.tar.bz2
gentoo-2-ab73b78e21d9767f6ddc0d87c007f5360260f3e3.zip
version bump
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'games-simulation/singularity')
-rw-r--r--games-simulation/singularity/ChangeLog10
-rw-r--r--games-simulation/singularity/singularity-0.30b.ebuild36
2 files changed, 44 insertions, 2 deletions
diff --git a/games-simulation/singularity/ChangeLog b/games-simulation/singularity/ChangeLog
index 75f4a5a2ea95..8809c3594485 100644
--- a/games-simulation/singularity/ChangeLog
+++ b/games-simulation/singularity/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-simulation/singularity
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/singularity/ChangeLog,v 1.12 2009/08/02 00:06:45 chainsaw Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/singularity/ChangeLog,v 1.13 2010/07/29 22:50:26 mr_bones_ Exp $
+
+*singularity-0.30b (29 Jul 2010)
+
+ 29 Jul 2010; Michael Sterrett <mr_bones_@gentoo.org>
+ +singularity-0.30b.ebuild:
+ version bump
02 Aug 2009; <chainsaw@gentoo.org> singularity-0.30.ebuild:
Marked stable on AMD64 as requested by Michael "Mr. Bones" Sterrett
diff --git a/games-simulation/singularity/singularity-0.30b.ebuild b/games-simulation/singularity/singularity-0.30b.ebuild
new file mode 100644
index 000000000000..aaaf3a699623
--- /dev/null
+++ b/games-simulation/singularity/singularity-0.30b.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/singularity/singularity-0.30b.ebuild,v 1.1 2010/07/29 22:50:26 mr_bones_ Exp $
+
+EAPI=2
+inherit eutils games
+
+MUSIC=endgame-${PN}-music-006
+DESCRIPTION="A simulation of a true AI. Go from computer to computer, pursued by the entire world"
+HOMEPAGE="http://www.emhsoft.com/singularity/"
+SRC_URI="http://endgame-singularity.googlecode.com/files/${P}-src.tar.gz
+ music? ( http://endgame-singularity.googlecode.com/files/${MUSIC}.zip )"
+
+LICENSE="GPL-2 CCPL-Attribution-ShareAlike-2.5"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+music"
+
+RDEPEND="dev-python/pygame"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+src_prepare() {
+ rm -f code/{,*}/*.pyc data/*.html # Remove unecessary files
+}
+
+src_install() {
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins -r code data ${PN}.py || die "doins failed"
+ if use music ; then
+ doins -r ../${MUSIC}/music || die "doins failed"
+ fi
+ games_make_wrapper ${PN} "python ${PN}.py" "${GAMES_DATADIR}/${PN}"
+ dodoc README.txt TODO Changelog AUTHORS
+ prepgamesdirs
+}