summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-07-02 21:16:20 +0000
committerMike Frysinger <vapier@gentoo.org>2005-07-02 21:16:20 +0000
commit4b5148d8f38d6156a14232414afab392689fe4ba (patch)
tree72b012dcd7518352312debfcbe3b6849023a3d92 /games-simulation
parentRemoving obsolete ebuild (diff)
downloadgentoo-2-4b5148d8f38d6156a14232414afab392689fe4ba.tar.gz
gentoo-2-4b5148d8f38d6156a14232414afab392689fe4ba.tar.bz2
gentoo-2-4b5148d8f38d6156a14232414afab392689fe4ba.zip
Fix a traceback from using wrong var name #97762 by Peter Roozemaal.
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'games-simulation')
-rw-r--r--games-simulation/qct/ChangeLog8
-rw-r--r--games-simulation/qct/files/qct-0.7-constant.patch21
-rw-r--r--games-simulation/qct/qct-0.7.ebuild16
3 files changed, 38 insertions, 7 deletions
diff --git a/games-simulation/qct/ChangeLog b/games-simulation/qct/ChangeLog
index 7583bc50b612..37cb98eaa1ca 100644
--- a/games-simulation/qct/ChangeLog
+++ b/games-simulation/qct/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-simulation/qct
-# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/qct/ChangeLog,v 1.4 2004/12/16 15:58:49 josejx Exp $
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/qct/ChangeLog,v 1.5 2005/07/02 21:16:20 vapier Exp $
+
+ 02 Jul 2005; Mike Frysinger <vapier@gentoo.org>
+ +files/qct-0.7-constant.patch, qct-0.7.ebuild:
+ Fix a traceback from using wrong var name #97762 by Peter Roozemaal.
16 Dec 2004; Joseph Jezak <josejx@gentoo.org> qct-0.7.ebuild:
Marked ppc stable.
diff --git a/games-simulation/qct/files/qct-0.7-constant.patch b/games-simulation/qct/files/qct-0.7-constant.patch
new file mode 100644
index 000000000000..43a01ea1a4a9
--- /dev/null
+++ b/games-simulation/qct/files/qct-0.7-constant.patch
@@ -0,0 +1,21 @@
+Fix traceback from using wrong name.
+
+Patch by Peter `MathFox' Roozemaal.
+
+http://bugs.gentoo.org/97762
+http://sourceforge.net/tracker/index.php?func=detail&aid=801329&group_id=74836&atid=542163
+
+--- qct/specializations.py
++++ qct/specializations.py
+@@ -131,9 +131,9 @@
+ mods = self.getModsFor('incomeMod', employer)
+ if resident:
+ if resident.job == trainer:
+- return prospect.level * INCOMEMULT * mods
++ return prospect.level * constants.INCOMEMULT * mods
+ else:
+- return prospect.level * INCOMEMULT / 2 * mods
++ return prospect.level * constants.INCOMEMULT / 2 * mods
+ else:
+ return 0
+
diff --git a/games-simulation/qct/qct-0.7.ebuild b/games-simulation/qct/qct-0.7.ebuild
index cd704e1c70f7..ae62e359b55b 100644
--- a/games-simulation/qct/qct-0.7.ebuild
+++ b/games-simulation/qct/qct-0.7.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/qct/qct-0.7.ebuild,v 1.5 2004/12/16 15:58:49 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/qct/qct-0.7.ebuild,v 1.6 2005/07/02 21:16:20 vapier Exp $
-inherit games
+inherit games eutils
DESCRIPTION="Quiet Console Town puts you in the place of the mayor of a budding new console RPG city"
HOMEPAGE="http://sourceforge.net/projects/qct/"
@@ -10,13 +10,19 @@ SRC_URI="mirror://sourceforge/qct/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="x86 ppc ~amd64"
+KEYWORDS="amd64 ppc x86"
IUSE=""
RDEPEND=">=dev-lang/python-2.2.1
>=dev-python/pygame-1.5.5"
-S="${WORKDIR}/${PN}"
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-constant.patch
+}
src_install() {
local destdir="${GAMES_DATADIR}/${PN}"