summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2006-08-14 06:45:52 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2006-08-14 06:45:52 +0000
commit7aedc31f3b7332aa580cfb3ae37f9515549e9f67 (patch)
treefcf2e8c5167f6ad556b0a4518bc50efd0617e2c9 /games-simulation
parentold (diff)
downloadgentoo-2-7aedc31f3b7332aa580cfb3ae37f9515549e9f67.tar.gz
gentoo-2-7aedc31f3b7332aa580cfb3ae37f9515549e9f67.tar.bz2
gentoo-2-7aedc31f3b7332aa580cfb3ae37f9515549e9f67.zip
version bump
(Portage version: 2.1.1_pre5)
Diffstat (limited to 'games-simulation')
-rw-r--r--games-simulation/singularity/ChangeLog8
-rw-r--r--games-simulation/singularity/files/digest-singularity-0.253
-rw-r--r--games-simulation/singularity/singularity-0.25.ebuild31
3 files changed, 41 insertions, 1 deletions
diff --git a/games-simulation/singularity/ChangeLog b/games-simulation/singularity/ChangeLog
index 4c165cff9f5c..aebf396dc53d 100644
--- a/games-simulation/singularity/ChangeLog
+++ b/games-simulation/singularity/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-simulation/singularity
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/singularity/ChangeLog,v 1.1 2006/07/31 06:50:02 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/singularity/ChangeLog,v 1.2 2006/08/14 06:45:52 mr_bones_ Exp $
+
+*singularity-0.25 (14 Aug 2006)
+
+ 14 Aug 2006; Michael Sterrett <mr_bones_@gentoo.org>
+ +singularity-0.25.ebuild:
+ version bump
*singularity-0.24 (31 Jul 2006)
diff --git a/games-simulation/singularity/files/digest-singularity-0.25 b/games-simulation/singularity/files/digest-singularity-0.25
new file mode 100644
index 000000000000..7bd2d46641cd
--- /dev/null
+++ b/games-simulation/singularity/files/digest-singularity-0.25
@@ -0,0 +1,3 @@
+MD5 7dd3654c4e1dd34ba0d80e56bfa885f3 singularity_0.25.tar.gz 468709
+RMD160 e77e89153ca564af20d40520b55081604618fbb8 singularity_0.25.tar.gz 468709
+SHA256 d32cab6e03d01f48b2f09adfaf9b245511820017991b26fd2472a93a3edd1ea3 singularity_0.25.tar.gz 468709
diff --git a/games-simulation/singularity/singularity-0.25.ebuild b/games-simulation/singularity/singularity-0.25.ebuild
new file mode 100644
index 000000000000..5ea9c1bba9d7
--- /dev/null
+++ b/games-simulation/singularity/singularity-0.25.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/singularity/singularity-0.25.ebuild,v 1.1 2006/08/14 06:45:52 mr_bones_ Exp $
+
+inherit games
+
+DESCRIPTION="A simulation of a true AI. Go from computer to computer, pursued by the entire world. Keep hidden, and you might have a chance."
+HOMEPAGE="http://www.emhsoft.net/singularity/"
+SRC_URI="http://www.emhsoft.net/singularity/${PN}_${PV}.tar.gz"
+
+LICENSE="GPL-2 CCPL-Attribution-ShareAlike-2.5"
+SLOT="0"
+KEYWORDS="x86"
+IUSE=""
+
+DEPEND="dev-python/pygame"
+
+src_unpack() {
+ unpack "${A}"
+ cd "${S}"
+
+ rm code/*.pyc data/*.html # Remove unecessary files
+}
+
+src_install() {
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins -r code data || die "doins failed"
+ games_make_wrapper singularity "python ./singularity.py" "${GAMES_DATADIR}/${PN}/code"
+ dodoc README.txt TODO Changelog AUTHORS
+ prepgamesdirs
+}