summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Weiler <pylon@gentoo.org>2006-08-21 07:58:38 +0000
committerLars Weiler <pylon@gentoo.org>2006-08-21 07:58:38 +0000
commit85b3ebc1040be57cf81d3ed8a22275b2ff41a09c (patch)
tree612c894f36ea4d61266b0fdb3938cb2c5826fda3 /games-simulation
parentVersion bump (diff)
downloadgentoo-2-85b3ebc1040be57cf81d3ed8a22275b2ff41a09c.tar.gz
gentoo-2-85b3ebc1040be57cf81d3ed8a22275b2ff41a09c.tar.bz2
gentoo-2-85b3ebc1040be57cf81d3ed8a22275b2ff41a09c.zip
Correct install of scenarios; bug #144301.
(Portage version: 2.1.1_pre5-r2)
Diffstat (limited to 'games-simulation')
-rw-r--r--games-simulation/openttd/ChangeLog5
-rw-r--r--games-simulation/openttd/openttd-0.4.8.ebuild5
2 files changed, 7 insertions, 3 deletions
diff --git a/games-simulation/openttd/ChangeLog b/games-simulation/openttd/ChangeLog
index 8aa19f84807b..22b48b1c0231 100644
--- a/games-simulation/openttd/ChangeLog
+++ b/games-simulation/openttd/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-simulation/openttd
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/openttd/ChangeLog,v 1.27 2006/08/18 22:23:31 tcort Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/openttd/ChangeLog,v 1.28 2006/08/21 07:58:38 pylon Exp $
+
+ 21 Aug 2006; Lars Weiler <pylon@gentoo.org> openttd-0.4.8.ebuild:
+ Correct install of scenarios; bug #144301.
18 Aug 2006; Thomas Cort <tcort@gentoo.org> openttd-0.4.8.ebuild:
Stable on amd64 wrt security Bug #131010.
diff --git a/games-simulation/openttd/openttd-0.4.8.ebuild b/games-simulation/openttd/openttd-0.4.8.ebuild
index 5593a9e8bb58..aa82c3dbd7c2 100644
--- a/games-simulation/openttd/openttd-0.4.8.ebuild
+++ b/games-simulation/openttd/openttd-0.4.8.ebuild
@@ -1,10 +1,11 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/openttd/openttd-0.4.8.ebuild,v 1.4 2006/08/18 22:23:31 tcort Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/openttd/openttd-0.4.8.ebuild,v 1.5 2006/08/21 07:58:38 pylon Exp $
inherit eutils games
SCENARIOS_A="${P}-scenarios.tar.bz2"
+SCENARIOS_DIR="${P}-RC1-scenarios"
DESCRIPTION="OpenTTD is a clone of Transport Tycoon Deluxe"
HOMEPAGE="http://www.openttd.com/"
@@ -75,7 +76,7 @@ src_install() {
if use scenarios; then
insinto "${GAMES_DATADIR}/${PN}/scenario"
- doins scenario/* || die "doins failed (scenario)"
+ doins scenario/${SCENARIOS_DIR}/* || die "doins failed (scenario)"
fi
insinto "${GAMES_DATADIR}/${PN}/scripts"