summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2007-01-11 19:17:36 +0000
committerTristan Heaven <nyhm@gentoo.org>2007-01-11 19:17:36 +0000
commitbe6a5758f6389117df34367c126739572e82cf3f (patch)
tree3f0c0c10263de4a5039ab45d61312f145d866fdd /games-strategy/freecol/freecol-0.5.3-r1.ebuild
parentRemove java-pkg_jar-from call for jdbc2-stdext as it is not needed to compile... (diff)
downloadgentoo-2-be6a5758f6389117df34367c126739572e82cf3f.tar.gz
gentoo-2-be6a5758f6389117df34367c126739572e82cf3f.tar.bz2
gentoo-2-be6a5758f6389117df34367c126739572e82cf3f.zip
No more bundled jars thanks to caster
(Portage version: 2.1.2_rc4-r8)
Diffstat (limited to 'games-strategy/freecol/freecol-0.5.3-r1.ebuild')
-rw-r--r--games-strategy/freecol/freecol-0.5.3-r1.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/games-strategy/freecol/freecol-0.5.3-r1.ebuild b/games-strategy/freecol/freecol-0.5.3-r1.ebuild
new file mode 100644
index 000000000000..ed6bb0bd9fdd
--- /dev/null
+++ b/games-strategy/freecol/freecol-0.5.3-r1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/freecol/freecol-0.5.3-r1.ebuild,v 1.1 2007/01/11 19:17:36 nyhm Exp $
+
+inherit eutils java-ant-2 java-pkg-2 games
+
+DESCRIPTION="An open source clone of the game Colonization"
+HOMEPAGE="http://www.freecol.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}-src.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+IUSE=""
+
+RDEPEND="dev-java/higlayout"
+DEPEND="${RDEPEND}
+ >=virtual/jdk-1.5
+ dev-java/ant"
+RDEPEND="${RDEPEND}
+ >=virtual/jre-1.5"
+
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ rm -rf FreeCol.jar src/classes jars/*
+
+ epatch \
+ "${FILESDIR}"/${P}-build.patch \
+ "${FILESDIR}"/${P}-home.patch
+
+ sed -i "/Class-Path/s:jars/.*$:$(java-pkg_getjars higlayout):" \
+ src/MANIFEST.MF \
+ || die "sed failed"
+
+ cd jars
+ java-pkg_jar-from higlayout
+}
+
+src_compile() {
+ eant
+}
+
+src_install () {
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r data || die "doins failed"
+
+ java-pkg_jarinto "${GAMES_DATADIR}"/${PN}
+ java-pkg_dojar FreeCol.jar
+
+ java-pkg_dolauncher ${PN} \
+ -into "${GAMES_PREFIX}" \
+ --pwd "${GAMES_DATADIR}"/${PN} \
+ --java_args -Xmx512M
+
+ dodoc README
+ doicon ${PN}.xpm
+ make_desktop_entry ${PN} FreeCol ${PN}.xpm
+ prepgamesdirs
+}