summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2008-04-30 17:06:38 +0000
committerTristan Heaven <nyhm@gentoo.org>2008-04-30 17:06:38 +0000
commit09256112de4b113cff60d52eb518036daef6a899 (patch)
treec70edb5396e628c0ca45991c0065451345cbeaa3 /games-strategy/netpanzer
parentPatch to fix building with gcc-4.3 from Martin Väth, bug #218939 (diff)
downloadgentoo-2-09256112de4b113cff60d52eb518036daef6a899.tar.gz
gentoo-2-09256112de4b113cff60d52eb518036daef6a899.tar.bz2
gentoo-2-09256112de4b113cff60d52eb518036daef6a899.zip
Patch to fix building with gcc-4.3 from Peter Alfredsen, bug #218837
(Portage version: 2.1.5_rc6)
Diffstat (limited to 'games-strategy/netpanzer')
-rw-r--r--games-strategy/netpanzer/ChangeLog8
-rw-r--r--games-strategy/netpanzer/files/netpanzer-0.8.2-gcc43.patch62
-rw-r--r--games-strategy/netpanzer/netpanzer-0.8.2.ebuild10
3 files changed, 76 insertions, 4 deletions
diff --git a/games-strategy/netpanzer/ChangeLog b/games-strategy/netpanzer/ChangeLog
index 5eb61e0d5d9c..1e7764d9f916 100644
--- a/games-strategy/netpanzer/ChangeLog
+++ b/games-strategy/netpanzer/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-strategy/netpanzer
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/netpanzer/ChangeLog,v 1.27 2007/11/21 04:26:02 dirtyepic Exp $
+# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/netpanzer/ChangeLog,v 1.28 2008/04/30 17:06:37 nyhm Exp $
+
+ 30 Apr 2008; Tristan Heaven <nyhm@gentoo.org>
+ +files/netpanzer-0.8.2-gcc43.patch, netpanzer-0.8.2.ebuild:
+ Patch to fix building with gcc-4.3 from Peter Alfredsen, bug #218837
21 Nov 2007; Ryan Hill <dirtyepic@gentoo.org> netpanzer-0.8.1.ebuild:
Also allow building 0.8.2 with ftjam for bug #188194
diff --git a/games-strategy/netpanzer/files/netpanzer-0.8.2-gcc43.patch b/games-strategy/netpanzer/files/netpanzer-0.8.2-gcc43.patch
new file mode 100644
index 000000000000..cf73ba4c2252
--- /dev/null
+++ b/games-strategy/netpanzer/files/netpanzer-0.8.2-gcc43.patch
@@ -0,0 +1,62 @@
+Index: netpanzer-0.8.2/src/Lib/2D/ColorTable.cpp
+===================================================================
+--- netpanzer-0.8.2.orig/src/Lib/2D/ColorTable.cpp 2008-02-05 16:36:27.000000000 +0000
++++ netpanzer-0.8.2/src/Lib/2D/ColorTable.cpp 2008-02-05 16:36:39.000000000 +0000
+@@ -17,6 +17,8 @@
+ */
+ #include <config.h>
+
++#include <memory>
++
+ #include "Util/FileSystem.hpp"
+ #include "Util/Log.hpp"
+ #include "Util/Exception.hpp"
+Index: netpanzer-0.8.2/src/Lib/2D/Palette.cpp
+===================================================================
+--- netpanzer-0.8.2.orig/src/Lib/2D/Palette.cpp 2008-02-05 16:36:27.000000000 +0000
++++ netpanzer-0.8.2/src/Lib/2D/Palette.cpp 2008-02-05 16:36:39.000000000 +0000
+@@ -18,6 +18,7 @@
+ #include <config.h>
+
+ #include <math.h>
++#include <memory>
+
+ #include "Palette.hpp"
+ #include "Util/FileSystem.hpp"
+Index: netpanzer-0.8.2/src/NetPanzer/Network/ProxyServer.cpp
+===================================================================
+--- netpanzer-0.8.2.orig/src/NetPanzer/Network/ProxyServer.cpp 2008-02-05 16:36:27.000000000 +0000
++++ netpanzer-0.8.2/src/NetPanzer/Network/ProxyServer.cpp 2008-02-05 16:36:39.000000000 +0000
+@@ -17,6 +17,7 @@
+ */
+ #include <config.h>
+
++#include <cstdlib>
+ #include <string>
+ #include <stdexcept>
+ #include <ctype.h>
+Index: netpanzer-0.8.2/src/NetPanzer/Views/MainMenu/Multi/MapSelectionView.cpp
+===================================================================
+--- netpanzer-0.8.2.orig/src/NetPanzer/Views/MainMenu/Multi/MapSelectionView.cpp 2008-02-05 16:36:27.000000000 +0000
++++ netpanzer-0.8.2/src/NetPanzer/Views/MainMenu/Multi/MapSelectionView.cpp 2008-02-05 16:36:39.000000000 +0000
+@@ -17,6 +17,7 @@
+ */
+ #include <config.h>
+
++#include <memory>
+ #include <vector>
+ #include <string>
+ #include "MapSelectionView.hpp"
+Index: netpanzer-0.8.2/src/Lib/Util/Log.cpp
+===================================================================
+--- netpanzer-0.8.2.orig/src/Lib/Util/Log.cpp 2008-02-05 17:13:36.000000000 +0000
++++ netpanzer-0.8.2/src/Lib/Util/Log.cpp 2008-02-05 17:13:43.000000000 +0000
+@@ -26,6 +26,7 @@
+ #include <vector>
+ #include <exception>
+ #include <iomanip>
++#include <algorithm>
+
+ #include "Exception.hpp"
+ #include "FileSystem.hpp"
+
diff --git a/games-strategy/netpanzer/netpanzer-0.8.2.ebuild b/games-strategy/netpanzer/netpanzer-0.8.2.ebuild
index c6cfc0dbde00..0c8715e01544 100644
--- a/games-strategy/netpanzer/netpanzer-0.8.2.ebuild
+++ b/games-strategy/netpanzer/netpanzer-0.8.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/netpanzer/netpanzer-0.8.2.ebuild,v 1.2 2007/11/20 17:26:08 fmccor Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/netpanzer/netpanzer-0.8.2.ebuild,v 1.3 2008/04/30 17:06:37 nyhm Exp $
inherit eutils games
@@ -23,6 +23,12 @@ RDEPEND="dedicated? ( app-misc/screen )
DEPEND="${RDEPEND}
|| ( dev-util/ftjam dev-util/jam )"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-gcc43.patch
+}
+
src_compile() {
egamesconf || die
jam -q || die "jam failed"