summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2005-09-09 01:56:57 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2005-09-09 01:56:57 +0000
commit8d442c2994625e4a29d8170b470cb109cfb45a98 (patch)
treedbcf35bd1b774e7f11aed725bfd3af942adeded1 /games-strategy/smac
parent2.12 release vbump (diff)
downloadgentoo-2-8d442c2994625e4a29d8170b470cb109cfb45a98.tar.gz
gentoo-2-8d442c2994625e4a29d8170b470cb109cfb45a98.tar.bz2
gentoo-2-8d442c2994625e4a29d8170b470cb109cfb45a98.zip
Initial import. Ebuild by <anakin.skyw@gmx.de> and submitted to bug #98687. Closing bug #98687 and bug #31395.
(Portage version: 1.589-cvs)
Diffstat (limited to 'games-strategy/smac')
-rw-r--r--games-strategy/smac/ChangeLog11
-rw-r--r--games-strategy/smac/files/digest-smac-6.0a1
-rw-r--r--games-strategy/smac/metadata.xml5
-rw-r--r--games-strategy/smac/smac-6.0a.ebuild88
4 files changed, 105 insertions, 0 deletions
diff --git a/games-strategy/smac/ChangeLog b/games-strategy/smac/ChangeLog
new file mode 100644
index 000000000000..c4b56cc05ea3
--- /dev/null
+++ b/games-strategy/smac/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for games-strategy/smac
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/smac/ChangeLog,v 1.1 2005/09/09 01:56:57 wolf31o2 Exp $
+
+*smac-6.0a (09 Sep 2005)
+
+ 09 Sep 2005; Chris Gianelloni <wolf31o2@gentoo.org> +metadata.xml,
+ +smac-6.0a.ebuild:
+ Initial import. Ebuild by <anakin.skyw@gmx.de> and submitted to bug #98687.
+ Closing bug #98687 and bug #31395.
+
diff --git a/games-strategy/smac/files/digest-smac-6.0a b/games-strategy/smac/files/digest-smac-6.0a
new file mode 100644
index 000000000000..7c8f27c222e5
--- /dev/null
+++ b/games-strategy/smac/files/digest-smac-6.0a
@@ -0,0 +1 @@
+MD5 b170edcde8ea753f7eef3ac6f13da6a7 smac-6.0a-x86.run 6801730
diff --git a/games-strategy/smac/metadata.xml b/games-strategy/smac/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-strategy/smac/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>
diff --git a/games-strategy/smac/smac-6.0a.ebuild b/games-strategy/smac/smac-6.0a.ebuild
new file mode 100644
index 000000000000..abdbc1421c51
--- /dev/null
+++ b/games-strategy/smac/smac-6.0a.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/smac/smac-6.0a.ebuild,v 1.1 2005/09/09 01:56:57 wolf31o2 Exp $
+
+inherit games
+
+IUSE="videos"
+
+DESCRIPTION="Sid Meier's Alpha Centauri"
+HOMEPAGE="http://www.lokigames.com/products/smac/"
+SRC_URI="ftp://sunsite.dk/mirrors/lokigames/updates/${PN}/${P}-x86.run"
+
+LICENSE="LOKI-EULA"
+SLOT="0"
+KEYWORDS="~x86"
+RESTRICT="nostrip"
+
+DEPEND="games-util/loki_patch"
+RDEPEND="virtual/x11
+ sys-libs/lib-compat-loki"
+
+pkg_setup() {
+ cdrom_get_cds Alien_Crossfire_Manual.pdf
+ games_pkg_setup
+}
+
+src_unpack() {
+ mkdir -p ${S}/a ${S}/b
+ cd ${S}/a
+ unpack_makeself ${P}-x86.run
+}
+
+dir=${GAMES_PREFIX_OPT}/${PN}
+Ddir=${D}/${dir}
+
+src_install() {
+ dodir ${dir}
+ einfo "Copying files... this may take a while..."
+ exeinto ${dir}
+ doexe ${CDROM_ROOT}/bin/x86/{smac,smacx,smacpack}
+
+ insinto ${dir}
+ doins ${CDROM_ROOT}/{{Alien_Crossfire,Alpha_Centauri}_Manual.pdf,QuickStart.txt,README,icon.{bmp,xpm}}
+
+ cd ${Ddir}
+ tar xzf ${CDROM_ROOT}/data.tar.gz || die "unpack"
+ insinto ${dir}/data
+ doins ${CDROM_ROOT}/data/*.{pcx,cvr,flc,gif} || die "copying data"
+ doins -r ${CDROM_ROOT}/data/facs || die "copying fac-data"
+ doins -r ${CDROM_ROOT}/data/fx || die "copying fx-data"
+ doins -r ${CDROM_ROOT}/data/projs || die "copying projects-data"
+ doins -r ${CDROM_ROOT}/data/techs || die "copying tech-data"
+ doins -r ${CDROM_ROOT}/data/voices || die "copying voices"
+
+ if use videos ; then
+ doins -r ${CDROM_ROOT}/data/movies || die "copying movies"
+ fi
+
+ cd ${S}/a
+ loki_patch --verify patch.dat
+ loki_patch patch.dat ${Ddir} >& /dev/null || die "patching"
+
+ # now, since these files are coming off a cd, the times/sizes/md5sums wont
+ # be different ... that means portage will try to unmerge some files (!)
+ # we run touch on ${D} so as to make sure portage doesnt do any such thing
+ find ${Ddir} -exec touch '{}' \;
+
+ insinto /usr/share/pixmaps
+ newins ${CDROM_ROOT}/icon.xpm smac.xpm
+
+ games_make_wrapper ${PN} ./${PN} "${dir}"
+ games_make_wrapper ${PN}x ./${PN}x "${dir}"
+ prepgamesdirs
+
+ einfo "Linking libs provided by 'sys-libs/lib-compat-loki' to '${dir}'."
+ dosym /lib/loki_ld-linux.so.2 ${dir}/ld-linux.so.2 && \
+ dosym /usr/lib/loki_libc.so.6 ${dir}/libc.so.6 && \
+ dosym /usr/lib/loki_libnss_files.so.2 ${dir}/libnss_files.so.2 || die "dosym failed"
+}
+
+pkg_postinst() {
+ einfo "To play Sid Meyer's Alpha Centauri run:"
+ einfo " smac"
+ einfo "To play Alien Crossfire run:"
+ einfo " smacx"
+
+ games_pkg_postinst
+}