summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2009-12-22 03:38:10 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2009-12-22 03:38:10 +0000
commit5329ae94f614b62ec623d37adda127ca6c42f59d (patch)
tree90dee5b834c52f9af0ab7ac2597dafa78a5dd04c /games-strategy
parentStable for HPPA (bug #293127). (diff)
downloadgentoo-2-5329ae94f614b62ec623d37adda127ca6c42f59d.tar.gz
gentoo-2-5329ae94f614b62ec623d37adda127ca6c42f59d.tar.bz2
gentoo-2-5329ae94f614b62ec623d37adda127ca6c42f59d.zip
version bump
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/asc/ChangeLog9
-rw-r--r--games-strategy/asc/asc-2.4.0.0.ebuild73
2 files changed, 80 insertions, 2 deletions
diff --git a/games-strategy/asc/ChangeLog b/games-strategy/asc/ChangeLog
index a7a4264b005f..8b6b6f2ad443 100644
--- a/games-strategy/asc/ChangeLog
+++ b/games-strategy/asc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-strategy/asc
-# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/asc/ChangeLog,v 1.31 2009/02/22 15:52:00 armin76 Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/asc/ChangeLog,v 1.32 2009/12/22 03:38:10 mr_bones_ Exp $
+
+*asc-2.4.0.0 (22 Dec 2009)
+
+ 22 Dec 2009; Michael Sterrett <mr_bones_@gentoo.org> +asc-2.4.0.0.ebuild:
+ version bump
22 Feb 2009; Raúl Porcel <armin76@gentoo.org> asc-2.2.0.0.ebuild:
x86 stable wrt #257719
diff --git a/games-strategy/asc/asc-2.4.0.0.ebuild b/games-strategy/asc/asc-2.4.0.0.ebuild
new file mode 100644
index 000000000000..b561045168b1
--- /dev/null
+++ b/games-strategy/asc/asc-2.4.0.0.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/asc/asc-2.4.0.0.ebuild,v 1.1 2009/12/22 03:38:10 mr_bones_ Exp $
+
+EAPI=2
+inherit toolchain-funcs flag-o-matic games
+
+DESCRIPTION="turn based strategy game designed in the tradition of the Battle Isle series"
+HOMEPAGE="http://www.asc-hq.org/"
+SRC_URI="mirror://sourceforge/asc-hq/${P}.tar.bz2
+ http://www.asc-hq.org/music/frontiers.ogg
+ http://www.asc-hq.org/music/time_to_strike.ogg
+ http://www.asc-hq.org/music/machine_wars.ogg"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="app-arch/bzip2
+ media-libs/jpeg
+ media-libs/libsdl
+ media-libs/libpng
+ media-libs/sdl-image[gif,jpeg,png]
+ media-libs/sdl-mixer[vorbis]
+ media-libs/sdl-sound
+ dev-libs/boost
+ dev-games/physfs
+ media-libs/libvorbis
+ media-libs/xvid
+ dev-libs/expat
+ media-libs/freetype
+ dev-lang/lua
+ x11-libs/wxGTK
+ dev-libs/libsigc++:1.2"
+DEPEND="${RDEPEND}
+ dev-lang/perl
+ dev-util/pkgconfig"
+
+src_unpack() {
+ local f
+
+ unpack ${P}.tar.bz2
+ for f in ${A}
+ do
+ case ${f} in
+ *ogg)
+ cp "${DISTDIR}/${f}" "${S}/data/music" || die "cp music failed"
+ ;;
+ esac
+ done
+}
+
+src_configure() {
+ # Added --disable-paraguitest for bugs 26402 and 4488
+ # Added --disable-paragui for bug 61154 since it's not really used much
+ # and the case is well documented at http://www.asc-hq.org/
+ if [[ $(gcc-major-version) -eq 4 ]] ; then
+ replace-flags -O3 -O2
+ fi
+ egamesconf \
+ --disable-dependency-tracking \
+ --disable-paraguitest \
+ --disable-paragui \
+ --datadir="${GAMES_DATADIR_BASE}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog README TODO
+ dohtml -r doc/*
+ prepgamesdirs
+}