summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2010-12-20 03:41:10 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2010-12-20 03:41:10 +0000
commit6c6b16a16afaa42639d23e6d5eb810f87c577fea (patch)
treeca103362b63cb9e114688ebf17faa59b0a6bd0d7 /games-strategy
parentStable on amd64 wrt bug #294256 (diff)
downloadgentoo-2-6c6b16a16afaa42639d23e6d5eb810f87c577fea.tar.gz
gentoo-2-6c6b16a16afaa42639d23e6d5eb810f87c577fea.tar.bz2
gentoo-2-6c6b16a16afaa42639d23e6d5eb810f87c577fea.zip
rev bump (changed upstream tarball) - bug #349149
(Portage version: 2.1.9.24/cvs/Linux i686)
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/outerspace/ChangeLog8
-rw-r--r--games-strategy/outerspace/outerspace-0.5.67-r1.ebuild46
2 files changed, 53 insertions, 1 deletions
diff --git a/games-strategy/outerspace/ChangeLog b/games-strategy/outerspace/ChangeLog
index e86c3233cc81..1da2e56f9777 100644
--- a/games-strategy/outerspace/ChangeLog
+++ b/games-strategy/outerspace/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-strategy/outerspace
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/outerspace/ChangeLog,v 1.15 2010/10/22 14:16:56 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/outerspace/ChangeLog,v 1.16 2010/12/20 03:41:10 mr_bones_ Exp $
+
+*outerspace-0.5.67-r1 (20 Dec 2010)
+
+ 20 Dec 2010; Michael Sterrett <mr_bones_@gentoo.org>
+ +outerspace-0.5.67-r1.ebuild:
+ rev bump (changed upstream tarball) - bug #349149
22 Oct 2010; Christian Faulhammer <fauli@gentoo.org>
outerspace-0.5.67.ebuild:
diff --git a/games-strategy/outerspace/outerspace-0.5.67-r1.ebuild b/games-strategy/outerspace/outerspace-0.5.67-r1.ebuild
new file mode 100644
index 000000000000..dbe2e6bde181
--- /dev/null
+++ b/games-strategy/outerspace/outerspace-0.5.67-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/outerspace/outerspace-0.5.67-r1.ebuild,v 1.1 2010/12/20 03:41:10 mr_bones_ Exp $
+
+EAPI=2
+PYTHON_DEPEND="2"
+
+inherit eutils python games
+
+MY_PN=${PN/outerspace/Outer Space}
+DESCRIPTION="on-line strategy game taking place in the dangerous universe"
+HOMEPAGE="http://www.ospace.net/"
+SRC_URI="mirror://sourceforge/ospace/Client/${PV}/Outer%20Space-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-python/pygame-1.7"
+
+S=${WORKDIR}/${MY_PN}-${PV}
+
+src_prepare() {
+ sed -e "s:@GENTOO_DATADIR@:${GAMES_DATADIR}/${PN}:" \
+ -e "s:@GENTOO_LIBDIR@:$(games_get_libdir)/${PN}:" \
+ -e "s:python:$(PYTHON -a):" \
+ "${FILESDIR}"/${PN} > ${PN} \
+ || die "sed failed"
+}
+
+src_install() {
+ insinto "$(games_get_libdir)"/${PN}
+ doins -r osc.py lib libsrvr || die "doins lib failed"
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r res || die "doins data failed"
+ dogamesbin ${PN} || die "dogamesbin failed"
+ newicon res/icon48.png ${PN}.png
+ make_desktop_entry ${PN} "${MY_PN}"
+ prepgamesdirs
+}
+
+pkg_setup() {
+ python_set_active_version 2
+ games_pkg_setup
+}