summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2014-06-17 20:44:56 +0000
committerJulian Ospald <hasufell@gentoo.org>2014-06-17 20:44:56 +0000
commit8c60dfb4d98f8efbc9789621bf1d7060d8575d13 (patch)
tree3fec4ec3a435c9378b8486b26637880ff9903aa2 /games-strategy
parentEnable multilib support. (diff)
downloadgentoo-2-8c60dfb4d98f8efbc9789621bf1d7060d8575d13.tar.gz
gentoo-2-8c60dfb4d98f8efbc9789621bf1d7060d8575d13.tar.bz2
gentoo-2-8c60dfb4d98f8efbc9789621bf1d7060d8575d13.zip
add patch that fixes UD, fix HOMEPAGE
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key BDEED020)
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/0ad/0ad-0.0.16_alpha-r2.ebuild (renamed from games-strategy/0ad/0ad-0.0.16_alpha-r1.ebuild)7
-rw-r--r--games-strategy/0ad/ChangeLog8
-rw-r--r--games-strategy/0ad/files/0ad-0.0.16_alpha-gcc-4.9.patch42
3 files changed, 53 insertions, 4 deletions
diff --git a/games-strategy/0ad/0ad-0.0.16_alpha-r1.ebuild b/games-strategy/0ad/0ad-0.0.16_alpha-r2.ebuild
index 76043c9de79d..64934bc671ca 100644
--- a/games-strategy/0ad/0ad-0.0.16_alpha-r1.ebuild
+++ b/games-strategy/0ad/0ad-0.0.16_alpha-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/0ad/0ad-0.0.16_alpha-r1.ebuild,v 1.1 2014/05/22 12:06:23 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/0ad/0ad-0.0.16_alpha-r2.ebuild,v 1.1 2014/06/17 20:44:55 hasufell Exp $
EAPI=5
@@ -10,7 +10,7 @@ inherit eutils wxwidgets toolchain-funcs gnome2-utils games
MY_P=0ad-${PV/_/-}
DESCRIPTION="A free, real-time strategy game"
-HOMEPAGE="http://wildfiregames.com/0ad/"
+HOMEPAGE="http://play0ad.com/"
SRC_URI="http://releases.wildfiregames.com/${MY_P}-unix-build.tar.xz"
LICENSE="GPL-2 LGPL-2.1 MIT CC-BY-SA-3.0 ZLIB"
@@ -48,7 +48,8 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/${MY_P}
src_prepare() {
- epatch "${FILESDIR}"/${P}-gentoo.patch
+ epatch "${FILESDIR}"/${P}-gentoo.patch \
+ "${FILESDIR}"/${P}-gcc-4.9.patch
}
src_configure() {
diff --git a/games-strategy/0ad/ChangeLog b/games-strategy/0ad/ChangeLog
index cfaa91c56b18..d1a443bb0881 100644
--- a/games-strategy/0ad/ChangeLog
+++ b/games-strategy/0ad/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-strategy/0ad
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/0ad/ChangeLog,v 1.2 2014/05/22 12:06:23 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/0ad/ChangeLog,v 1.3 2014/06/17 20:44:55 hasufell Exp $
+
+*0ad-0.0.16_alpha-r2 (17 Jun 2014)
+
+ 17 Jun 2014; Julian Ospald <hasufell@gentoo.org> -0ad-0.0.16_alpha-r1.ebuild,
+ +0ad-0.0.16_alpha-r2.ebuild, +files/0ad-0.0.16_alpha-gcc-4.9.patch:
+ add patch that fixes UD, fix HOMEPAGE
*0ad-0.0.16_alpha-r1 (22 May 2014)
diff --git a/games-strategy/0ad/files/0ad-0.0.16_alpha-gcc-4.9.patch b/games-strategy/0ad/files/0ad-0.0.16_alpha-gcc-4.9.patch
new file mode 100644
index 000000000000..5b17120b4f7b
--- /dev/null
+++ b/games-strategy/0ad/files/0ad-0.0.16_alpha-gcc-4.9.patch
@@ -0,0 +1,42 @@
+Index: /ps/trunk/source/lib/allocators/headerless.cpp
+===================================================================
+--- /ps/trunk/source/lib/allocators/headerless.cpp (revision 15333)
++++ /ps/trunk/source/lib/allocators/headerless.cpp (revision 15334)
+@@ -55,10 +55,12 @@
+ }
+
+- FreedBlock(uintptr_t id, size_t size)
+- : m_magic(s_magic), m_size(size), m_id(id)
+- {
+- }
+-
+- ~FreedBlock()
++ void Setup(uintptr_t id, size_t size)
++ {
++ m_magic = s_magic;
++ m_size = size;
++ m_id = id;
++ }
++
++ void Reset()
+ {
+ // clear all fields to prevent accidental reuse
+@@ -411,6 +413,7 @@
+ FreedBlock* WriteTags(u8* p, size_t size)
+ {
+- FreedBlock* freedBlock = new(p) FreedBlock(s_headerId, size);
+- (void)new(Footer(freedBlock)) FreedBlock(s_footerId, size);
++ FreedBlock* freedBlock = (FreedBlock*)p;
++ freedBlock->Setup(s_headerId, size);
++ Footer(freedBlock)->Setup(s_footerId, size);
+
+ m_freeBlocks++;
+@@ -431,6 +434,6 @@
+
+ FreedBlock* footer = Footer(freedBlock);
+- freedBlock->~FreedBlock();
+- footer->~FreedBlock();
++ freedBlock->Reset();
++ footer->Reset();
+ }
+