summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2015-05-04 21:21:32 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2015-05-04 21:21:32 +0000
commita461ef096589748fb9b39857dfe3c8e35a34fe0b (patch)
tree5e2b5198cbeee3daf9198023a802a8dfd1c3540c /games-strategy
parentFix documentation of 3 variables in php-ext-source-r2 eclass (diff)
downloadgentoo-2-a461ef096589748fb9b39857dfe3c8e35a34fe0b.tar.gz
gentoo-2-a461ef096589748fb9b39857dfe3c8e35a34fe0b.tar.bz2
gentoo-2-a461ef096589748fb9b39857dfe3c8e35a34fe0b.zip
add patch from zimous to fix building with gcc49 (bug #538580)
(Portage version: 2.2.18/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/glob2/ChangeLog10
-rw-r--r--games-strategy/glob2/files/glob2-0.9.4.4-gcc44.patch4
-rw-r--r--games-strategy/glob2/files/glob2-0.9.4.4-gcc49.patch35
-rw-r--r--games-strategy/glob2/files/glob2-0.9.4.4-scons-blows.patch4
-rw-r--r--games-strategy/glob2/files/glob2-0.9.4.4-underlinking.patch5
-rw-r--r--games-strategy/glob2/glob2-0.9.4.4-r1.ebuild6
6 files changed, 52 insertions, 12 deletions
diff --git a/games-strategy/glob2/ChangeLog b/games-strategy/glob2/ChangeLog
index a80e17a9b488..b6c1f7b34690 100644
--- a/games-strategy/glob2/ChangeLog
+++ b/games-strategy/glob2/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-strategy/glob2
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/glob2/ChangeLog,v 1.60 2014/08/25 20:33:05 mr_bones_ Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/glob2/ChangeLog,v 1.61 2015/05/04 21:21:32 mr_bones_ Exp $
+
+ 04 May 2015; Michael Sterrett <mr_bones_@gentoo.org>
+ +files/glob2-0.9.4.4-gcc49.patch, files/glob2-0.9.4.4-gcc44.patch,
+ files/glob2-0.9.4.4-scons-blows.patch, files/glob2-0.9.4.4-underlinking.patch,
+ glob2-0.9.4.4-r1.ebuild:
+ add patch from zimous to fix building with gcc49 (bug #538580)
25 Aug 2014; Michael Sterrett <mr_bones_@gentoo.org> -glob2-0.9.4.4.ebuild:
old
diff --git a/games-strategy/glob2/files/glob2-0.9.4.4-gcc44.patch b/games-strategy/glob2/files/glob2-0.9.4.4-gcc44.patch
index 67aa1a0789c4..5ce62ea6e46c 100644
--- a/games-strategy/glob2/files/glob2-0.9.4.4-gcc44.patch
+++ b/games-strategy/glob2/files/glob2-0.9.4.4-gcc44.patch
@@ -1,5 +1,5 @@
---- libgag/include/StreamBackend.h.old 2009-07-13 10:52:36.000000000 +0200
-+++ libgag/include/StreamBackend.h 2009-07-13 10:52:57.000000000 +0200
+--- libgag/include/StreamBackend.h.old
++++ libgag/include/StreamBackend.h
@@ -28,6 +28,9 @@
#ifdef putc
#undef putc
diff --git a/games-strategy/glob2/files/glob2-0.9.4.4-gcc49.patch b/games-strategy/glob2/files/glob2-0.9.4.4-gcc49.patch
new file mode 100644
index 000000000000..fca1efb5891a
--- /dev/null
+++ b/games-strategy/glob2/files/glob2-0.9.4.4-gcc49.patch
@@ -0,0 +1,35 @@
+From https://bugs.gentoo.org/show_bug.cgi?id=538580
+
+Works around this build failure:
+
+In file included from src/AICastor.cpp:26:0:
+src/Game.h: In member function 'void AICastor::computeBuildingNeighbourMap(int, int)':
+src/Game.h:152:9: error: 'struct Game::BuildProject' is private
+ struct BuildProject
+ ^
+src/AICastor.cpp:2296:23: error: within this context
+ for (std::list<Game::BuildProject>::iterator bpi=game->buildProjects.begin(); bpi!=game->buildProjects.end(); bpi++)
+ ^
+scons: *** [src/AICastor.o] Error 1
+scons: building terminated because of errors.
+
+patch submitted by zimous
+
+--- glob2-0.9.4.4.orig/src/Game.h
++++ glob2-0.9.4.4/src/Game.h
+@@ -149,6 +149,7 @@
+ BOTTOM_TO_TOP
+ };
+
++public:
+ struct BuildProject
+ {
+ int posX;
+@@ -159,6 +160,7 @@
+ int unitWorkingFuture;
+ };
+
++private:
+ ///Initiates Game
+ void init(GameGUI *gui, MapEdit* edit);
+
diff --git a/games-strategy/glob2/files/glob2-0.9.4.4-scons-blows.patch b/games-strategy/glob2/files/glob2-0.9.4.4-scons-blows.patch
index e8aa31d84d94..70619f04839d 100644
--- a/games-strategy/glob2/files/glob2-0.9.4.4-scons-blows.patch
+++ b/games-strategy/glob2/files/glob2-0.9.4.4-scons-blows.patch
@@ -1,5 +1,5 @@
---- SConstruct.orig 2010-11-19 17:56:30.206360948 -0500
-+++ SConstruct 2010-11-19 17:58:48.914746243 -0500
+--- SConstruct.orig
++++ SConstruct
@@ -1,6 +1,7 @@
EnsureSConsVersion(0, 96, 92)
import sys
diff --git a/games-strategy/glob2/files/glob2-0.9.4.4-underlinking.patch b/games-strategy/glob2/files/glob2-0.9.4.4-underlinking.patch
index 2b6342276f46..65eba48717db 100644
--- a/games-strategy/glob2/files/glob2-0.9.4.4-underlinking.patch
+++ b/games-strategy/glob2/files/glob2-0.9.4.4-underlinking.patch
@@ -1,6 +1,5 @@
-diff -burN glob2-0.9.4.4.orig/SConstruct glob2-0.9.4.4/SConstruct
---- glob2-0.9.4.4.orig/SConstruct 2009-08-30 21:23:30.000000000 +0200
-+++ glob2-0.9.4.4/SConstruct 2013-10-24 21:03:46.755492770 +0200
+--- glob2-0.9.4.4.orig/SConstruct
++++ glob2-0.9.4.4/SConstruct
@@ -110,6 +110,16 @@
print "Could not find libz or zlib1.dll"
missing.append("zlib")
diff --git a/games-strategy/glob2/glob2-0.9.4.4-r1.ebuild b/games-strategy/glob2/glob2-0.9.4.4-r1.ebuild
index a7d768e51c79..33cf73dd1960 100644
--- a/games-strategy/glob2/glob2-0.9.4.4-r1.ebuild
+++ b/games-strategy/glob2/glob2-0.9.4.4-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/glob2/glob2-0.9.4.4-r1.ebuild,v 1.4 2013/12/24 12:57:42 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/glob2/glob2-0.9.4.4-r1.ebuild,v 1.5 2015/05/04 21:21:32 mr_bones_ Exp $
EAPI=5
inherit eutils gnome2-utils scons-utils games
@@ -27,7 +27,7 @@ RDEPEND="
virtual/opengl"
DEPEND="${RDEPEND}"
-PATCHES=( "${FILESDIR}"/${P}-{gcc44,scons-blows,underlinking}.patch )
+PATCHES=( "${FILESDIR}"/${P}-{gcc44,scons-blows,underlinking,gcc49}.patch )
src_configure() {
myesconsargs=(