summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-12-21 15:47:32 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-12-21 15:47:32 +0000
commit2f682e6e8f2107a14f83f0e83646071db9a54acc (patch)
tree9cdc86560590fe3d7666d3c4bfb3cd104aef7743 /games-util/joystick
parentAdd ~sparc wrt #284740 (diff)
downloadgentoo-2-2f682e6e8f2107a14f83f0e83646071db9a54acc.tar.gz
gentoo-2-2f682e6e8f2107a14f83f0e83646071db9a54acc.tar.bz2
gentoo-2-2f682e6e8f2107a14f83f0e83646071db9a54acc.zip
Fix building with -Wl,--as-needed wrt #247514 by Kacper Kowalik.
(Portage version: 2.2_rc59/cvs/Linux x86_64)
Diffstat (limited to 'games-util/joystick')
-rw-r--r--games-util/joystick/ChangeLog6
-rw-r--r--games-util/joystick/files/joystick-20060731-asneeded.patch27
-rw-r--r--games-util/joystick/joystick-20060731.ebuild5
3 files changed, 35 insertions, 3 deletions
diff --git a/games-util/joystick/ChangeLog b/games-util/joystick/ChangeLog
index 1ebbd2f39ea2..b7169527e9ef 100644
--- a/games-util/joystick/ChangeLog
+++ b/games-util/joystick/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-util/joystick
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-util/joystick/ChangeLog,v 1.7 2009/08/14 17:01:26 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-util/joystick/ChangeLog,v 1.8 2009/12/21 15:47:29 ssuominen Exp $
+
+ 21 Dec 2009; Samuli Suominen <ssuominen@gentoo.org>
+ joystick-20060731.ebuild, +files/joystick-20060731-asneeded.patch:
+ Fix building with -Wl,--as-needed wrt #247514 by Kacper Kowalik.
14 Aug 2009; Michael Sterrett <mr_bones_@gentoo.org>
joystick-20060731.ebuild:
diff --git a/games-util/joystick/files/joystick-20060731-asneeded.patch b/games-util/joystick/files/joystick-20060731-asneeded.patch
new file mode 100644
index 000000000000..3bfe30f01ea2
--- /dev/null
+++ b/games-util/joystick/files/joystick-20060731-asneeded.patch
@@ -0,0 +1,27 @@
+--- utils.orig/Makefile 2006-07-31 06:50:01.000000000 +0200
++++ utils/Makefile 2009-12-09 20:11:17.962976029 +0100
+@@ -46,7 +45,7 @@
+
+ ffcfstress: ffcfstress.c
+ $(CC) $(CFLAGS) -funsigned-char \
+- -lm ffcfstress.c -o ffcfstress
++ ffcfstress.c -o ffcfstress -lm
+
+ ffmvforce.o: ffmvforce.c
+ $(CC) -c $(CFLAGS) $(CPPFLAGS) $^ -o $@ `sdl-config --cflags`
+@@ -55,13 +54,13 @@
+ $(CC) $^ -o $@ $(LDFLAGS) $(CFLAGS) -lm `sdl-config --libs`
+
+ jscal: jscal.o
+- $(CC) $(CFLAGS) $(CPPFLAGS) -lm $^ -o $@
++ $(CC) $(CFLAGS) $(CPPFLAGS) $^ -o $@ -lm
+
+ gencodes: gencodes.c scancodes.h
+ $(CC) $(CFLAGS) $(CPPFLAGS) gencodes.c -o gencodes
+
+ acceltest: acceltest.c
+- $(CC) $(CFLAGS) $(CPPFLAGS) -lm $^ -o $@
++ $(CC) $(CFLAGS) $(CPPFLAGS) $^ -o $@ -lm
+
+ dist:
+ tar jcf ../joystick-`date +%Y%m%d`.tar.bz2 -C .. utils
diff --git a/games-util/joystick/joystick-20060731.ebuild b/games-util/joystick/joystick-20060731.ebuild
index 2771a27b7134..1649235b761d 100644
--- a/games-util/joystick/joystick-20060731.ebuild
+++ b/games-util/joystick/joystick-20060731.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-util/joystick/joystick-20060731.ebuild,v 1.5 2009/08/14 17:01:26 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-util/joystick/joystick-20060731.ebuild,v 1.6 2009/12/21 15:47:29 ssuominen Exp $
EAPI=2
inherit eutils toolchain-funcs
@@ -22,7 +22,8 @@ S=${WORKDIR}/utils
src_prepare() {
epatch \
"${FILESDIR}"/joystick-MCS-defines.patch \
- "${FILESDIR}"/joystick-jstest-segv.patch
+ "${FILESDIR}"/joystick-jstest-segv.patch \
+ "${FILESDIR}"/${P}-asneeded.patch
sed -i \
-e '/^CC/d' \
Makefile \