summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2005-03-24 20:42:32 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2005-03-24 20:42:32 +0000
commit48429dd1de22bce5066c3e2a5d59938ddac4a530 (patch)
treec3cda7ba8018717c11ff331baf71d8ed78cec55e /games-util/loki_patch
parentCorrected valgrind-2.4.0 SRC_URI (diff)
downloadgentoo-2-48429dd1de22bce5066c3e2a5d59938ddac4a530.tar.gz
gentoo-2-48429dd1de22bce5066c3e2a5d59938ddac4a530.tar.bz2
gentoo-2-48429dd1de22bce5066c3e2a5d59938ddac4a530.zip
Updated to 20050324 CVS snapshot and added patch to allow it to build on amd64. This could conceivably allow older Loki titles to work/install on amd64.
(Portage version: 2.0.51.19)
Diffstat (limited to 'games-util/loki_patch')
-rw-r--r--games-util/loki_patch/ChangeLog12
-rw-r--r--games-util/loki_patch/files/digest-loki_patch-200503241
-rw-r--r--games-util/loki_patch/files/loki_patch-20050324-amd64.patch12
-rw-r--r--games-util/loki_patch/loki_patch-20050324.ebuild40
4 files changed, 63 insertions, 2 deletions
diff --git a/games-util/loki_patch/ChangeLog b/games-util/loki_patch/ChangeLog
index edbf66e2f38d..0062681cc022 100644
--- a/games-util/loki_patch/ChangeLog
+++ b/games-util/loki_patch/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for games-util/loki_patch
-# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-util/loki_patch/ChangeLog,v 1.2 2004/10/17 09:53:32 dholm Exp $
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-util/loki_patch/ChangeLog,v 1.3 2005/03/24 20:42:32 wolf31o2 Exp $
+
+*loki_patch-20050324 (24 Mar 2005)
+
+ 24 Mar 2005; Chris Gianelloni <wolf31o2@gentoo.org>
+ +files/loki_patch-20050324-amd64.patch, +loki_patch-20050324.ebuild:
+ Updated to 20050324 CVS snapshot and added patch to allow it to build on
+ amd64. This could conceivably allow older Loki titles to work/install on
+ amd64.
17 Oct 2004; David Holm <dholm@gentoo.org> loki_patch-20040916.ebuild:
Added to ~ppc.
diff --git a/games-util/loki_patch/files/digest-loki_patch-20050324 b/games-util/loki_patch/files/digest-loki_patch-20050324
new file mode 100644
index 000000000000..da86fe23d31f
--- /dev/null
+++ b/games-util/loki_patch/files/digest-loki_patch-20050324
@@ -0,0 +1 @@
+MD5 366edc4210c26502a9c9b7fa4cd705c6 loki_patch-20050324.tar.bz2 410111
diff --git a/games-util/loki_patch/files/loki_patch-20050324-amd64.patch b/games-util/loki_patch/files/loki_patch-20050324-amd64.patch
new file mode 100644
index 000000000000..abb35d950693
--- /dev/null
+++ b/games-util/loki_patch/files/loki_patch-20050324-amd64.patch
@@ -0,0 +1,12 @@
+diff -urN loki_patch.orig/configure.in loki_patch/configure.in
+--- loki_patch-20050324.orig/configure.in 2005-03-24 15:20:27.000000000 -0500
++++ loki_patch-20050324/configure.in 2005-03-24 15:21:11.000000000 -0500
+@@ -21,6 +21,8 @@
+ case "$target" in
+ *i?86*)
+ ARCH=x86 ;;
++ *x86_64*)
++ ARCH=amd64 ;;
+ *alpha*)
+ CFLAGS="$CFLAGS -mcpu=ev4 -Wa,-mall"
+ ARCH=alpha ;;
diff --git a/games-util/loki_patch/loki_patch-20050324.ebuild b/games-util/loki_patch/loki_patch-20050324.ebuild
new file mode 100644
index 000000000000..2dcfac78f63a
--- /dev/null
+++ b/games-util/loki_patch/loki_patch-20050324.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-util/loki_patch/loki_patch-20050324.ebuild,v 1.1 2005/03/24 20:42:32 wolf31o2 Exp $
+
+inherit eutils
+
+DESCRIPTION="Loki Software binary patch tool"
+HOMEPAGE="http://www.icculus.org/loki_setup/"
+SRC_URI="http://dev.gentoo.org/~wolf31o2/sources/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~amd64"
+IUSE=""
+
+DEPEND="dev-util/xdelta
+ dev-libs/libxml
+ games-util/loki_setupdb"
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/${P}-amd64.patch
+}
+
+src_compile() {
+ ./autogen.sh || die "autogen failed."
+ econf \
+ --with-setupdb=/usr/share/loki_setupdb \
+ || die "econf failed."
+ sed -i \
+ -e 's/\.\.\/loki_setupdb/\/usr\/share\/loki_setupdb/' \
+ -e 's/-I$(SETUPDB)/-I$(SETUPDB)\/include/' \
+ Makefile
+ emake || die "emake failed"
+}
+
+src_install() {
+ dobin loki_patch make_patch || die "doexe failed"
+ dodoc CHANGES NOTES README TODO
+}