summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Kohl <citizen428@gentoo.org>2004-12-03 14:40:56 +0000
committerMichael Kohl <citizen428@gentoo.org>2004-12-03 14:40:56 +0000
commit8427e4d5f00355b00335e38819319880a29faf85 (patch)
tree8b0f11e29866942655ff3a51c8b69f4afe7574d4 /games-util/xgame/xgame-1.7.1.ebuild
parentInitial 2005.0 profile. (diff)
downloadgentoo-2-8427e4d5f00355b00335e38819319880a29faf85.tar.gz
gentoo-2-8427e4d5f00355b00335e38819319880a29faf85.tar.bz2
gentoo-2-8427e4d5f00355b00335e38819319880a29faf85.zip
Initial commit; ebuild submitted by Nexu <nexu@pingzero.com> in bug #66714
Diffstat (limited to 'games-util/xgame/xgame-1.7.1.ebuild')
-rw-r--r--games-util/xgame/xgame-1.7.1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/games-util/xgame/xgame-1.7.1.ebuild b/games-util/xgame/xgame-1.7.1.ebuild
new file mode 100644
index 000000000000..8a60d0d2f6a8
--- /dev/null
+++ b/games-util/xgame/xgame-1.7.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-util/xgame/xgame-1.7.1.ebuild,v 1.1 2004/12/03 14:40:56 citizen428 Exp $
+
+inherit eutils
+
+IUSE=""
+
+DESCRIPTION="Run games in a separate X session"
+HOMEPAGE="http://xgame.tlhiv.com/"
+SRC_URI="http://downloads.tlhiv.com/xgame/${PF}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+RDEPEND="dev-lang/perl"
+
+src_install() {
+ exeinto /usr/games/bin
+ exeopts -m0650
+ doexe xgame || die "doexe failed"
+ # Only members of the group 'games' can use this
+ fowners root:games /usr/games/bin/xgame || die "fowner failed"
+ dodoc README || die "dodoc failed"
+}
+
+pkg_postinst() {
+ echo
+ ewarn "Remember, in order to play games, you have to"
+ ewarn "be in the 'games' group."
+ echo
+ einfo "See the usermod(8) manpage for more information."
+ echo
+}