summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2015-03-11 05:31:33 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2015-03-11 05:31:33 +0000
commit676b4bfcc63a66ae13121bf43438ab4a8f7efec1 (patch)
tree0448c8970965f9f5866c8f8ea3f229ac6abdbae8 /games-util
parentbup (diff)
downloadgentoo-2-676b4bfcc63a66ae13121bf43438ab4a8f7efec1.tar.gz
gentoo-2-676b4bfcc63a66ae13121bf43438ab4a8f7efec1.tar.bz2
gentoo-2-676b4bfcc63a66ae13121bf43438ab4a8f7efec1.zip
version bump (bug #542864)
(Portage version: 2.2.14/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-util')
-rw-r--r--games-util/lutris/ChangeLog7
-rw-r--r--games-util/lutris/lutris-0.3.6.2.ebuild67
2 files changed, 73 insertions, 1 deletions
diff --git a/games-util/lutris/ChangeLog b/games-util/lutris/ChangeLog
index 111430fa2415..cd954621b6f2 100644
--- a/games-util/lutris/ChangeLog
+++ b/games-util/lutris/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-util/lutris
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-util/lutris/ChangeLog,v 1.12 2015/02/25 15:53:40 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-util/lutris/ChangeLog,v 1.13 2015/03/11 05:31:33 mr_bones_ Exp $
+
+*lutris-0.3.6.2 (11 Mar 2015)
+
+ 11 Mar 2015; Michael Sterrett <mr_bones_@gentoo.org> +lutris-0.3.6.2.ebuild:
+ version bump (bug #542864)
25 Feb 2015; Agostino Sarubbo <ago@gentoo.org> lutris-0.3.6.1.ebuild:
Stable for x86, wrt bug #540244
diff --git a/games-util/lutris/lutris-0.3.6.2.ebuild b/games-util/lutris/lutris-0.3.6.2.ebuild
new file mode 100644
index 000000000000..90aa7244e641
--- /dev/null
+++ b/games-util/lutris/lutris-0.3.6.2.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-util/lutris/lutris-0.3.6.2.ebuild,v 1.1 2015/03/11 05:31:33 mr_bones_ Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="sqlite,threads"
+
+inherit distutils-r1 gnome2-utils games
+
+DESCRIPTION="Gaming platform for GNU/Linux"
+HOMEPAGE="http://lutris.net/"
+SRC_URI="https://github.com/lutris/lutris/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/pyxdg[${PYTHON_USEDEP}]
+ gnome-base/gvfs[http]
+ x11-apps/xrandr
+ x11-apps/xgamma
+ x11-misc/xdg-utils"
+
+# INSTALL contains list of optional deps
+DOCS=( AUTHORS README.rst INSTALL )
+
+python_install() {
+ distutils-r1_python_install --install-scripts="${GAMES_BINDIR}"
+}
+
+src_prepare() {
+ distutils-r1_src_prepare
+}
+
+src_compile() {
+ distutils-r1_src_compile
+}
+
+src_install() {
+ distutils-r1_src_install
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ gnome2_icon_cache_update
+ gnome2_schemas_update
+
+ elog "For a list of optional deps (runners), see"
+ elog "/usr/share/doc/${PF}/INSTALL"
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ gnome2_schemas_update
+}