summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2008-03-22 17:52:45 +0000
committerMart Raudsepp <leio@gentoo.org>2008-03-22 17:52:45 +0000
commit418a2ec9e5c9928051f52670449cff2766d3c00b (patch)
treef1f28ccb0c7a7ab6b3e6056a7021a926d4c2d3d9 /gnome-base/gconf
parentStable for HPPA (bug #214281). (diff)
downloadgentoo-2-418a2ec9e5c9928051f52670449cff2766d3c00b.tar.gz
gentoo-2-418a2ec9e5c9928051f52670449cff2766d3c00b.tar.bz2
gentoo-2-418a2ec9e5c9928051f52670449cff2766d3c00b.zip
New version for GNOME-2.22 with various code cleanups, string fixes and more
(Portage version: 2.1.4.4)
Diffstat (limited to 'gnome-base/gconf')
-rw-r--r--gnome-base/gconf/ChangeLog8
-rw-r--r--gnome-base/gconf/files/gconf-2.22.0-automagic-ldap.patch379
-rw-r--r--gnome-base/gconf/gconf-2.22.0.ebuild83
3 files changed, 469 insertions, 1 deletions
diff --git a/gnome-base/gconf/ChangeLog b/gnome-base/gconf/ChangeLog
index fe7e8435cb17..a0a295b18335 100644
--- a/gnome-base/gconf/ChangeLog
+++ b/gnome-base/gconf/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for gnome-base/gconf
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gconf/ChangeLog,v 1.187 2008/03/03 22:01:33 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gconf/ChangeLog,v 1.188 2008/03/22 17:52:45 leio Exp $
+
+*gconf-2.22.0 (22 Mar 2008)
+
+ 22 Mar 2008; Mart Raudsepp <leio@gentoo.org>
+ +files/gconf-2.22.0-automagic-ldap.patch, +gconf-2.22.0.ebuild:
+ New version for GNOME-2.22 with various code cleanups, string fixes and more
03 Mar 2008; Gilles Dartiguelongue <eva@gentoo.org> -gconf-2.20.1.ebuild,
gconf-2.20.1-r1.ebuild:
diff --git a/gnome-base/gconf/files/gconf-2.22.0-automagic-ldap.patch b/gnome-base/gconf/files/gconf-2.22.0-automagic-ldap.patch
new file mode 100644
index 000000000000..efaa68c5c76f
--- /dev/null
+++ b/gnome-base/gconf/files/gconf-2.22.0-automagic-ldap.patch
@@ -0,0 +1,379 @@
+This is the same as gconf-2.20.1-automagic-ldap.patch but with configure patched too to avoid eautoreconf caused gtk-doc and intltoolize mess
+
+Index: configure.in
+===================================================================
+--- configure.in (révision 2495)
++++ configure.in (copie de travail)
+@@ -177,36 +182,55 @@
+
+ AC_CHECK_FUNCS(getuid sigaction fsync fchmod fdwalk)
+
++dnl **************************************************
++dnl LDAP support.
++dnl **************************************************
+
+ LDAP_LIBS=
+-AC_CHECK_HEADER(ldap.h, [
+- AC_CHECK_LIB(ldap, ldap_init, AC_CHECK_LIB(lber, ber_free, [LDAP_LIBS="-lldap -llber"]))
++
++AC_ARG_WITH(openldap,
++ AC_HELP_STRING([--with-openldap],
++ [Enable LDAP backend @<:@default=auto@:>@]),
++ ,with_openldap=auto)
++
++if test x"$with_openldap" != xno; then
++ AC_CHECK_HEADER(ldap.h, [
++ AC_CHECK_LIB(ldap, ldap_init, AC_CHECK_LIB(lber, ber_free, [LDAP_LIBS="-lldap -llber"]))
+ ])
+-AC_SUBST(LDAP_LIBS)
+-AM_CONDITIONAL(LDAP_SUPPORT, test -n "$LDAP_LIBS")
++ AC_SUBST(LDAP_LIBS)
+
+-dnl **************************************************
+-dnl LDAP support.
+-dnl **************************************************
+-if test "$os_win32" != yes; then
++ if test "$os_win32" != yes; then
++ SAVE_CFLAGS="$CFLAGS"
++ SAVE_LIBS="$LIBS"
++ LDAP_CFLAGS="-DLDAP_DEPRECATED"
++ CFLAGS="$CFLAGS $LDAP_CFLAGS"
++ LIBS="$LIBS $LDAP_LIBS"
++ AC_CHECK_FUNCS(ldap_ntlm_bind)
++ CFLAGS="$SAVE_CFLAGS"
++ LIBS="$SAVE_LIBS"
++
++ else # Win32
++ LDAP_CFLAGS="-DLDAP_DEPRECATED"
++ LDAP_LIBS="-lwldap32"
++ AC_SUBST(LDAP_CFLAGS)
++ AC_SUBST(LDAP_LIBS)
++ AC_DEFINE(HAVE_LDAP,1,[Define if you have LDAP support])
++ msg_ldap="yes"
++ fi # Win32
++
++ if test -z "$LDAP_LIBS"; then
++ if test x"$with_openldap" = xyes; then
++ AC_MSG_ERROR([*** LDAP support explicitely requested but not found ***])
++ else
++ AC_MSG_WARN([*** LDAP support not found ***])
++ fi
++ fi
++
++else
++ AC_DEFINE(HAVE_LDAP,0,[Define if you have LDAP support])
++fi
+
+-SAVE_CFLAGS="$CFLAGS"
+-SAVE_LIBS="$LIBS"
+-LDAP_CFLAGS="-DLDAP_DEPRECATED"
+-CFLAGS="$CFLAGS $LDAP_CFLAGS"
+-LIBS="$LIBS $LDAP_LIBS"
+-AC_CHECK_FUNCS(ldap_ntlm_bind)
+-CFLAGS="$SAVE_CFLAGS"
+-LIBS="$SAVE_LIBS"
+-
+-else # Win32
+-LDAP_CFLAGS="-DLDAP_DEPRECATED"
+-LDAP_LIBS="-lwldap32"
+-AC_SUBST(LDAP_CFLAGS)
+-AC_SUBST(LDAP_LIBS)
+-AC_DEFINE(HAVE_LDAP,1,[Define if you have LDAP support])
+-msg_ldap="yes"
+-fi # Win32
++AM_CONDITIONAL(LDAP_SUPPORT, test -n "$LDAP_LIBS")
+
+ IT_PROG_INTLTOOL([0.35.0])
+
+--- configure.orig 2008-03-22 17:37:56.000000000 +0200
++++ configure 2008-03-22 17:40:01.000000000 +0200
+@@ -1584,6 +1584,7 @@
+ --with-tags[=TAGS] include additional configurations [automatic]
+ --with-sysconfsubdir directory name used under sysconfdir, default=gconf
+ --with-html-dir=PATH path to installed docs
++ --with-openldap Enable LDAP backend [default=auto]
+
+ Some influential environment variables:
+ CC C compiler command
+@@ -6241,7 +6242,7 @@
+ ;;
+ *-*-irix6*)
+ # Find out which ABI we are using.
+- echo '#line 6244 "configure"' > conftest.$ac_ext
++ echo '#line 6245 "configure"' > conftest.$ac_ext
+ if { (eval echo "$as_me:$LINENO: \"$ac_compile\"") >&5
+ (eval $ac_compile) 2>&5
+ ac_status=$?
+@@ -8397,11 +8398,11 @@
+ -e 's:.*FLAGS}\{0,1\} :&$lt_compiler_flag :; t' \
+ -e 's: [^ ]*conftest\.: $lt_compiler_flag&:; t' \
+ -e 's:$: $lt_compiler_flag:'`
+- (eval echo "\"\$as_me:8400: $lt_compile\"" >&5)
++ (eval echo "\"\$as_me:8401: $lt_compile\"" >&5)
+ (eval "$lt_compile" 2>conftest.err)
+ ac_status=$?
+ cat conftest.err >&5
+- echo "$as_me:8404: \$? = $ac_status" >&5
++ echo "$as_me:8405: \$? = $ac_status" >&5
+ if (exit $ac_status) && test -s "$ac_outfile"; then
+ # The compiler can only warn and ignore the option if not recognized
+ # So say no if there are warnings other than the usual output.
+@@ -8687,11 +8688,11 @@
+ -e 's:.*FLAGS}\{0,1\} :&$lt_compiler_flag :; t' \
+ -e 's: [^ ]*conftest\.: $lt_compiler_flag&:; t' \
+ -e 's:$: $lt_compiler_flag:'`
+- (eval echo "\"\$as_me:8690: $lt_compile\"" >&5)
++ (eval echo "\"\$as_me:8691: $lt_compile\"" >&5)
+ (eval "$lt_compile" 2>conftest.err)
+ ac_status=$?
+ cat conftest.err >&5
+- echo "$as_me:8694: \$? = $ac_status" >&5
++ echo "$as_me:8695: \$? = $ac_status" >&5
+ if (exit $ac_status) && test -s "$ac_outfile"; then
+ # The compiler can only warn and ignore the option if not recognized
+ # So say no if there are warnings other than the usual output.
+@@ -8791,11 +8792,11 @@
+ -e 's:.*FLAGS}\{0,1\} :&$lt_compiler_flag :; t' \
+ -e 's: [^ ]*conftest\.: $lt_compiler_flag&:; t' \
+ -e 's:$: $lt_compiler_flag:'`
+- (eval echo "\"\$as_me:8794: $lt_compile\"" >&5)
++ (eval echo "\"\$as_me:8795: $lt_compile\"" >&5)
+ (eval "$lt_compile" 2>out/conftest.err)
+ ac_status=$?
+ cat out/conftest.err >&5
+- echo "$as_me:8798: \$? = $ac_status" >&5
++ echo "$as_me:8799: \$? = $ac_status" >&5
+ if (exit $ac_status) && test -s out/conftest2.$ac_objext
+ then
+ # The compiler can only warn and ignore the option if not recognized
+@@ -11142,7 +11143,7 @@
+ lt_dlunknown=0; lt_dlno_uscore=1; lt_dlneed_uscore=2
+ lt_status=$lt_dlunknown
+ cat > conftest.$ac_ext <<EOF
+-#line 11145 "configure"
++#line 11146 "configure"
+ #include "confdefs.h"
+
+ #if HAVE_DLFCN_H
+@@ -11242,7 +11243,7 @@
+ lt_dlunknown=0; lt_dlno_uscore=1; lt_dlneed_uscore=2
+ lt_status=$lt_dlunknown
+ cat > conftest.$ac_ext <<EOF
+-#line 11245 "configure"
++#line 11246 "configure"
+ #include "confdefs.h"
+
+ #if HAVE_DLFCN_H
+@@ -13662,11 +13663,11 @@
+ -e 's:.*FLAGS}\{0,1\} :&$lt_compiler_flag :; t' \
+ -e 's: [^ ]*conftest\.: $lt_compiler_flag&:; t' \
+ -e 's:$: $lt_compiler_flag:'`
+- (eval echo "\"\$as_me:13665: $lt_compile\"" >&5)
++ (eval echo "\"\$as_me:13666: $lt_compile\"" >&5)
+ (eval "$lt_compile" 2>conftest.err)
+ ac_status=$?
+ cat conftest.err >&5
+- echo "$as_me:13669: \$? = $ac_status" >&5
++ echo "$as_me:13670: \$? = $ac_status" >&5
+ if (exit $ac_status) && test -s "$ac_outfile"; then
+ # The compiler can only warn and ignore the option if not recognized
+ # So say no if there are warnings other than the usual output.
+@@ -13766,11 +13767,11 @@
+ -e 's:.*FLAGS}\{0,1\} :&$lt_compiler_flag :; t' \
+ -e 's: [^ ]*conftest\.: $lt_compiler_flag&:; t' \
+ -e 's:$: $lt_compiler_flag:'`
+- (eval echo "\"\$as_me:13769: $lt_compile\"" >&5)
++ (eval echo "\"\$as_me:13770: $lt_compile\"" >&5)
+ (eval "$lt_compile" 2>out/conftest.err)
+ ac_status=$?
+ cat out/conftest.err >&5
+- echo "$as_me:13773: \$? = $ac_status" >&5
++ echo "$as_me:13774: \$? = $ac_status" >&5
+ if (exit $ac_status) && test -s out/conftest2.$ac_objext
+ then
+ # The compiler can only warn and ignore the option if not recognized
+@@ -15330,11 +15331,11 @@
+ -e 's:.*FLAGS}\{0,1\} :&$lt_compiler_flag :; t' \
+ -e 's: [^ ]*conftest\.: $lt_compiler_flag&:; t' \
+ -e 's:$: $lt_compiler_flag:'`
+- (eval echo "\"\$as_me:15333: $lt_compile\"" >&5)
++ (eval echo "\"\$as_me:15334: $lt_compile\"" >&5)
+ (eval "$lt_compile" 2>conftest.err)
+ ac_status=$?
+ cat conftest.err >&5
+- echo "$as_me:15337: \$? = $ac_status" >&5
++ echo "$as_me:15338: \$? = $ac_status" >&5
+ if (exit $ac_status) && test -s "$ac_outfile"; then
+ # The compiler can only warn and ignore the option if not recognized
+ # So say no if there are warnings other than the usual output.
+@@ -15434,11 +15435,11 @@
+ -e 's:.*FLAGS}\{0,1\} :&$lt_compiler_flag :; t' \
+ -e 's: [^ ]*conftest\.: $lt_compiler_flag&:; t' \
+ -e 's:$: $lt_compiler_flag:'`
+- (eval echo "\"\$as_me:15437: $lt_compile\"" >&5)
++ (eval echo "\"\$as_me:15438: $lt_compile\"" >&5)
+ (eval "$lt_compile" 2>out/conftest.err)
+ ac_status=$?
+ cat out/conftest.err >&5
+- echo "$as_me:15441: \$? = $ac_status" >&5
++ echo "$as_me:15442: \$? = $ac_status" >&5
+ if (exit $ac_status) && test -s out/conftest2.$ac_objext
+ then
+ # The compiler can only warn and ignore the option if not recognized
+@@ -17623,11 +17624,11 @@
+ -e 's:.*FLAGS}\{0,1\} :&$lt_compiler_flag :; t' \
+ -e 's: [^ ]*conftest\.: $lt_compiler_flag&:; t' \
+ -e 's:$: $lt_compiler_flag:'`
+- (eval echo "\"\$as_me:17626: $lt_compile\"" >&5)
++ (eval echo "\"\$as_me:17627: $lt_compile\"" >&5)
+ (eval "$lt_compile" 2>conftest.err)
+ ac_status=$?
+ cat conftest.err >&5
+- echo "$as_me:17630: \$? = $ac_status" >&5
++ echo "$as_me:17631: \$? = $ac_status" >&5
+ if (exit $ac_status) && test -s "$ac_outfile"; then
+ # The compiler can only warn and ignore the option if not recognized
+ # So say no if there are warnings other than the usual output.
+@@ -17913,11 +17914,11 @@
+ -e 's:.*FLAGS}\{0,1\} :&$lt_compiler_flag :; t' \
+ -e 's: [^ ]*conftest\.: $lt_compiler_flag&:; t' \
+ -e 's:$: $lt_compiler_flag:'`
+- (eval echo "\"\$as_me:17916: $lt_compile\"" >&5)
++ (eval echo "\"\$as_me:17917: $lt_compile\"" >&5)
+ (eval "$lt_compile" 2>conftest.err)
+ ac_status=$?
+ cat conftest.err >&5
+- echo "$as_me:17920: \$? = $ac_status" >&5
++ echo "$as_me:17921: \$? = $ac_status" >&5
+ if (exit $ac_status) && test -s "$ac_outfile"; then
+ # The compiler can only warn and ignore the option if not recognized
+ # So say no if there are warnings other than the usual output.
+@@ -18017,11 +18018,11 @@
+ -e 's:.*FLAGS}\{0,1\} :&$lt_compiler_flag :; t' \
+ -e 's: [^ ]*conftest\.: $lt_compiler_flag&:; t' \
+ -e 's:$: $lt_compiler_flag:'`
+- (eval echo "\"\$as_me:18020: $lt_compile\"" >&5)
++ (eval echo "\"\$as_me:18021: $lt_compile\"" >&5)
+ (eval "$lt_compile" 2>out/conftest.err)
+ ac_status=$?
+ cat out/conftest.err >&5
+- echo "$as_me:18024: \$? = $ac_status" >&5
++ echo "$as_me:18025: \$? = $ac_status" >&5
+ if (exit $ac_status) && test -s out/conftest2.$ac_objext
+ then
+ # The compiler can only warn and ignore the option if not recognized
+@@ -21816,7 +21817,18 @@
+
+
+ LDAP_LIBS=
+-if test "${ac_cv_header_ldap_h+set}" = set; then
++
++
++# Check whether --with-openldap was given.
++if test "${with_openldap+set}" = set; then
++ withval=$with_openldap;
++else
++ with_openldap=auto
++fi
++
++
++if test x"$with_openldap" != xno; then
++ if test "${ac_cv_header_ldap_h+set}" = set; then
+ { echo "$as_me:$LINENO: checking for ldap.h" >&5
+ echo $ECHO_N "checking for ldap.h... $ECHO_C" >&6; }
+ if test "${ac_cv_header_ldap_h+set}" = set; then
+@@ -21948,7 +21960,7 @@
+ fi
+ if test $ac_cv_header_ldap_h = yes; then
+
+- { echo "$as_me:$LINENO: checking for ldap_init in -lldap" >&5
++ { echo "$as_me:$LINENO: checking for ldap_init in -lldap" >&5
+ echo $ECHO_N "checking for ldap_init in -lldap... $ECHO_C" >&6; }
+ if test "${ac_cv_lib_ldap_ldap_init+set}" = set; then
+ echo $ECHO_N "(cached) $ECHO_C" >&6
+@@ -22082,22 +22094,13 @@
+
+
+
+- if test -n "$LDAP_LIBS"; then
+- LDAP_SUPPORT_TRUE=
+- LDAP_SUPPORT_FALSE='#'
+-else
+- LDAP_SUPPORT_TRUE='#'
+- LDAP_SUPPORT_FALSE=
+-fi
+-
+
+-if test "$os_win32" != yes; then
+-
+-SAVE_CFLAGS="$CFLAGS"
+-SAVE_LIBS="$LIBS"
+-LDAP_CFLAGS="-DLDAP_DEPRECATED"
+-CFLAGS="$CFLAGS $LDAP_CFLAGS"
+-LIBS="$LIBS $LDAP_LIBS"
++ if test "$os_win32" != yes; then
++ SAVE_CFLAGS="$CFLAGS"
++ SAVE_LIBS="$LIBS"
++ LDAP_CFLAGS="-DLDAP_DEPRECATED"
++ CFLAGS="$CFLAGS $LDAP_CFLAGS"
++ LIBS="$LIBS $LDAP_LIBS"
+
+ for ac_func in ldap_ntlm_bind
+ do
+@@ -22192,12 +22195,12 @@
+ fi
+ done
+
+-CFLAGS="$SAVE_CFLAGS"
+-LIBS="$SAVE_LIBS"
++ CFLAGS="$SAVE_CFLAGS"
++ LIBS="$SAVE_LIBS"
+
+-else # Win32
+-LDAP_CFLAGS="-DLDAP_DEPRECATED"
+-LDAP_LIBS="-lwldap32"
++ else # Win32
++ LDAP_CFLAGS="-DLDAP_DEPRECATED"
++ LDAP_LIBS="-lwldap32"
+
+
+
+@@ -22205,8 +22208,36 @@
+ #define HAVE_LDAP 1
+ _ACEOF
+
+-msg_ldap="yes"
+-fi # Win32
++ msg_ldap="yes"
++ fi # Win32
++
++ if test -z "$LDAP_LIBS"; then
++ if test x"$with_openldap" = xyes; then
++ { { echo "$as_me:$LINENO: error: *** LDAP support explicitely requested but not found ***" >&5
++echo "$as_me: error: *** LDAP support explicitely requested but not found ***" >&2;}
++ { (exit 1); exit 1; }; }
++ else
++ { echo "$as_me:$LINENO: WARNING: *** LDAP support not found ***" >&5
++echo "$as_me: WARNING: *** LDAP support not found ***" >&2;}
++ fi
++ fi
++
++else
++
++cat >>confdefs.h <<\_ACEOF
++#define HAVE_LDAP 0
++_ACEOF
++
++fi
++
++ if test -n "$LDAP_LIBS"; then
++ LDAP_SUPPORT_TRUE=
++ LDAP_SUPPORT_FALSE='#'
++else
++ LDAP_SUPPORT_TRUE='#'
++ LDAP_SUPPORT_FALSE=
++fi
++
+
+
+ case "$am__api_version" in
diff --git a/gnome-base/gconf/gconf-2.22.0.ebuild b/gnome-base/gconf/gconf-2.22.0.ebuild
new file mode 100644
index 000000000000..e64d0cc19489
--- /dev/null
+++ b/gnome-base/gconf/gconf-2.22.0.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gconf/gconf-2.22.0.ebuild,v 1.1 2008/03/22 17:52:45 leio Exp $
+
+inherit eutils gnome2
+
+MY_PN=GConf
+MY_P=${MY_PN}-${PV}
+PVP=(${PV//[-\._]/ })
+
+DESCRIPTION="Gnome Configuration System and Daemon"
+HOMEPAGE="http://www.gnome.org/"
+SRC_URI="mirror://gnome/sources/${MY_PN}/${PVP[0]}.${PVP[1]}/${MY_P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="debug doc ldap"
+
+RDEPEND=">=dev-libs/glib-2.10
+ >=x11-libs/gtk+-2.8.16
+ >=gnome-base/orbit-2.4
+ >=dev-libs/libxml2-2"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.35
+ >=dev-util/pkgconfig-0.9
+ doc? ( >=dev-util/gtk-doc-1 )"
+
+# FIXME : consider merging the tree (?)
+DOCS="AUTHORS ChangeLog NEWS README TODO"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ G2CONF="${G2CONF} --enable-gtk $(use_enable debug) $(use_with ldap openldap)"
+ kill_gconf
+}
+
+src_unpack() {
+ gnome2_src_unpack
+
+ # fix bug #193442, GNOME bug #498934
+ epatch "${FILESDIR}/${P}-automagic-ldap.patch"
+}
+
+src_install() {
+ gnome2_src_install
+
+ # hack hack
+ dodir /etc/gconf/gconf.xml.mandatory
+ dodir /etc/gconf/gconf.xml.defaults
+ touch "${D}"/etc/gconf/gconf.xml.mandatory/.keep${SLOT}
+ touch "${D}"/etc/gconf/gconf.xml.defaults/.keep${SLOT}
+
+ echo 'CONFIG_PROTECT_MASK="/etc/gconf"' > 50gconf
+ doenvd 50gconf || die
+ dodir /root/.gconfd
+}
+
+pkg_preinst() {
+ kill_gconf
+}
+
+pkg_postinst() {
+ kill_gconf
+
+ #change the permissions to avoid some gconf bugs
+ einfo "changing permissions for gconf dirs"
+ find /etc/gconf/ -type d -exec chmod ugo+rx "{}" \;
+
+ einfo "changing permissions for gconf files"
+ find /etc/gconf/ -type f -exec chmod ugo+r "{}" \;
+}
+
+kill_gconf() {
+ # This function will kill all running gconfd-2 that could be causing troubles
+ if [ -x /usr/bin/gconftool-2 ]
+ then
+ /usr/bin/gconftool-2 --shutdown
+ fi
+
+ return 0
+}