summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2013-05-05 08:09:17 +0000
committerPacho Ramos <pacho@gentoo.org>2013-05-05 08:09:17 +0000
commit9a7dfe696979aad0b9e17b98998a9fa43ee6611e (patch)
treeec507b7fd3743b72a8e3eb71023a88b76d301682 /gnome-base/gnome-keyring
parentConvert to multilib, bug #466608. (diff)
downloadgentoo-2-9a7dfe696979aad0b9e17b98998a9fa43ee6611e.tar.gz
gentoo-2-9a7dfe696979aad0b9e17b98998a9fa43ee6611e.tar.bz2
gentoo-2-9a7dfe696979aad0b9e17b98998a9fa43ee6611e.zip
Version bump, drop old
(Portage version: 2.1.11.62/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'gnome-base/gnome-keyring')
-rw-r--r--gnome-base/gnome-keyring/ChangeLog8
-rw-r--r--gnome-base/gnome-keyring/gnome-keyring-3.8.2.ebuild (renamed from gnome-base/gnome-keyring/gnome-keyring-3.8.0.ebuild)52
2 files changed, 11 insertions, 49 deletions
diff --git a/gnome-base/gnome-keyring/ChangeLog b/gnome-base/gnome-keyring/ChangeLog
index b48b7bf3d660..ffb944eaee7e 100644
--- a/gnome-base/gnome-keyring/ChangeLog
+++ b/gnome-base/gnome-keyring/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for gnome-base/gnome-keyring
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-keyring/ChangeLog,v 1.231 2013/04/28 13:38:52 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-keyring/ChangeLog,v 1.232 2013/05/05 08:09:17 pacho Exp $
+
+*gnome-keyring-3.8.2 (05 May 2013)
+
+ 05 May 2013; Pacho Ramos <pacho@gentoo.org> +gnome-keyring-3.8.2.ebuild,
+ -gnome-keyring-3.8.0.ebuild:
+ Version bump, drop old
*gnome-keyring-3.8.1 (28 Apr 2013)
diff --git a/gnome-base/gnome-keyring/gnome-keyring-3.8.0.ebuild b/gnome-base/gnome-keyring/gnome-keyring-3.8.2.ebuild
index f81ddb218c7a..cf169fca8a43 100644
--- a/gnome-base/gnome-keyring/gnome-keyring-3.8.0.ebuild
+++ b/gnome-base/gnome-keyring/gnome-keyring-3.8.2.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-keyring/gnome-keyring-3.8.0.ebuild,v 1.2 2013/03/30 23:01:13 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-keyring/gnome-keyring-3.8.2.ebuild,v 1.1 2013/05/05 08:09:17 pacho Exp $
EAPI="5"
GCONF_DEBUG="yes" # Not gnome macro but similar
GNOME2_LA_PUNT="yes"
-inherit gnome2 pam versionator virtualx
+inherit fcaps gnome2 pam versionator virtualx
DESCRIPTION="Password and keyring managing daemon"
HOMEPAGE="http://live.gnome.org/GnomeKeyring"
@@ -17,7 +17,7 @@ IUSE="+caps debug pam selinux"
KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~sparc-solaris ~x86-solaris"
RDEPEND="
- >=app-crypt/gcr-3.5.3:=
+ >=app-crypt/gcr-3.5.3:=[gtk]
>=dev-libs/glib-2.32.0:2
app-misc/ca-certificates
>=dev-libs/libgcrypt-1.2.2:=
@@ -63,8 +63,6 @@ src_configure() {
$(use_enable pam) \
$(use_with pam pam-dir $(getpam_mod_dir)) \
$(use_enable selinux) \
- --with-root-certs="${EPREFIX}"/etc/ssl/certs/ \
- --with-ca-certificates="${EPREFIX}"/etc/ssl/certs/ca-certificates.crt \
--enable-ssh-agent \
--enable-gpg-agent
}
@@ -75,48 +73,6 @@ src_test() {
}
pkg_postinst() {
- use caps && fcaps 0:0 755 cap_ipc_lock "${EROOT}"/usr/bin/gnome-keyring-daemon
+ fcaps cap_ipc_lock usr/bin/gnome-keyring-daemon
gnome2_pkg_postinst
}
-
-# borrowed from GSoC2010_Gentoo_Capabilities by constanze and Flameeyes
-# @FUNCTION: fcaps
-# @USAGE: fcaps {uid:gid} {file-mode} {cap1[,cap2,...]} {file}
-# @RETURN: 0 if all okay; non-zero if failure and fallback
-# @DESCRIPTION:
-# fcaps sets the specified capabilities in the effective and permitted set of
-# the given file. In case of failure fcaps sets the given file-mode.
-# Requires versionator.eclass
-fcaps() {
- local uid_gid=$1
- local perms=$2
- local capset=$3
- local path=$4
- local res
-
- chmod $perms $path && \
- chown $uid_gid $path
- res=$?
-
- use caps || return $res
-
- #set the capability
- setcap "$capset=ep" "$path" &> /dev/null
- #check if the capability got set correctly
- setcap -v "$capset=ep" "$path" &> /dev/null
- res=$?
-
- if [ $res -ne 0 ]; then
- ewarn "Failed to set capabilities. Probable reason is missing kernel support."
- ewarn "Your kernel must have <FS>_FS_SECURITY enabled (e.g. EXT4_FS_SECURITY)"
- ewarn "where <FS> is the filesystem to store ${path}"
- if ! version_is_at_least 2.6.33 "$(uname -r)"; then
- ewarn "For kernel 2.6.32 or older, you will also need to enable"
- ewarn "SECURITY_FILE_CAPABILITIES."
- fi
- ewarn
- ewarn "Falling back to suid now..."
- chmod u+s ${path}
- fi
- return $res
-}