summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2008-03-31 21:24:07 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2008-03-31 21:24:07 +0000
commit4f29eb7c3fb9e0864c848ad8090bdc1d01c52ba4 (patch)
treeb3a6b003c6efc959ef6f65c3c5bce1b987d8260c /gnome-base/gvfs
parentamd64 stable, bug #208918 (diff)
downloadgentoo-2-4f29eb7c3fb9e0864c848ad8090bdc1d01c52ba4.tar.gz
gentoo-2-4f29eb7c3fb9e0864c848ad8090bdc1d01c52ba4.tar.bz2
gentoo-2-4f29eb7c3fb9e0864c848ad8090bdc1d01c52ba4.zip
bump to 0.2.2, fix crashes and leaks and silent overwrites (sftp).
Fix bug #215322 by raising media-libs/gphoto2 dependency to 2.4. (Portage version: 2.1.4.4)
Diffstat (limited to 'gnome-base/gvfs')
-rw-r--r--gnome-base/gvfs/ChangeLog8
-rw-r--r--gnome-base/gvfs/gvfs-0.2.2.ebuild55
2 files changed, 62 insertions, 1 deletions
diff --git a/gnome-base/gvfs/ChangeLog b/gnome-base/gvfs/ChangeLog
index c053984a72e5..c2ca869260cc 100644
--- a/gnome-base/gvfs/ChangeLog
+++ b/gnome-base/gvfs/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for gnome-base/gvfs
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gvfs/ChangeLog,v 1.2 2008/03/24 00:35:36 compnerd Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gvfs/ChangeLog,v 1.3 2008/03/31 21:24:07 eva Exp $
+
+*gvfs-0.2.2 (31 Mar 2008)
+
+ 31 Mar 2008; Gilles Dartiguelongue <eva@gentoo.org> +gvfs-0.2.2.ebuild:
+ bump to 0.2.2, fix crashes and leaks and silent overwrites (sftp). Fix bug
+ #215322 by raising media-libs/gphoto2 dependency to 2.4.
24 Mar 2008; Saleem Abdulrasool <compnerd@gentoo.org> gvfs-0.2.1.ebuild:
add hal dep for cdda
diff --git a/gnome-base/gvfs/gvfs-0.2.2.ebuild b/gnome-base/gvfs/gvfs-0.2.2.ebuild
new file mode 100644
index 000000000000..838fa081dc5e
--- /dev/null
+++ b/gnome-base/gvfs/gvfs-0.2.2.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gvfs/gvfs-0.2.2.ebuild,v 1.1 2008/03/31 21:24:07 eva Exp $
+
+inherit autotools gnome2
+
+DESCRIPTION="GNOME Virtual Filesystem Layer"
+HOMEPAGE="http://www.gnome.org"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="avahi bluetooth cdda doc fuse gnome gphoto2 hal keyring samba"
+
+RDEPEND=">=dev-libs/glib-2.16
+ >=sys-apps/dbus-1.0
+ >=net-libs/libsoup-2.4
+ dev-libs/libxml2
+ net-misc/openssh
+ avahi? ( >=net-dns/avahi-0.6 )
+ cdda? (
+ >=sys-apps/hal-0.5.10
+ >=dev-libs/libcdio-0.78.2
+ )
+ fuse? ( sys-fs/fuse )
+ gnome? ( >=gnome-base/gconf-2.0 )
+ hal? ( >=sys-apps/hal-0.5.10 )
+ bluetooth? (
+ dev-libs/dbus-glib
+ >=net-wireless/bluez-libs-3.12
+ dev-libs/expat
+ )
+ gphoto2? ( >=media-libs/libgphoto2-2.4 )
+ keyring? ( >=gnome-base/gnome-keyring-1.0 )
+ samba? ( >=net-fs/samba-3 )"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.35
+ >=dev-util/pkgconfig-0.19
+ doc? ( >=dev-util/gtk-doc-1 )"
+
+DOCS="AUTHORS ChangeLog NEWS README TODO"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ --enable-http
+ $(use_enable avahi)
+ $(use_enable bluetooth obexftp)
+ $(use_enable cdda)
+ $(use_enable fuse)
+ $(use_enable gnome gconf)
+ $(use_enable gphoto2)
+ $(use_enable hal)
+ $(use_enable keyring)
+ $(use_enable samba)"
+}