summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2013-06-18 19:39:05 +0000
committerPacho Ramos <pacho@gentoo.org>2013-06-18 19:39:05 +0000
commit342f4a78c1c3b52b3ecce4b5d872aa1657b4f655 (patch)
tree6f808a21274322647c4449f258b67acb854f3a2b /gnome-base/nautilus
parentDrop old. (diff)
downloadgentoo-2-342f4a78c1c3b52b3ecce4b5d872aa1657b4f655.tar.gz
gentoo-2-342f4a78c1c3b52b3ecce4b5d872aa1657b4f655.tar.bz2
gentoo-2-342f4a78c1c3b52b3ecce4b5d872aa1657b4f655.zip
Version bump, drop old.
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'gnome-base/nautilus')
-rw-r--r--gnome-base/nautilus/ChangeLog8
-rw-r--r--gnome-base/nautilus/nautilus-3.8.2.ebuild (renamed from gnome-base/nautilus/nautilus-3.8.0.ebuild)58
2 files changed, 44 insertions, 22 deletions
diff --git a/gnome-base/nautilus/ChangeLog b/gnome-base/nautilus/ChangeLog
index d3dd93686ea8..a67e69875ce6 100644
--- a/gnome-base/nautilus/ChangeLog
+++ b/gnome-base/nautilus/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for gnome-base/nautilus
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/nautilus/ChangeLog,v 1.410 2013/04/20 12:08:17 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/nautilus/ChangeLog,v 1.411 2013/06/18 19:39:05 pacho Exp $
+
+*nautilus-3.8.2 (18 Jun 2013)
+
+ 18 Jun 2013; Pacho Ramos <pacho@gentoo.org> +nautilus-3.8.2.ebuild,
+ -nautilus-3.8.0.ebuild:
+ Version bump, drop old.
*nautilus-3.8.1 (20 Apr 2013)
diff --git a/gnome-base/nautilus/nautilus-3.8.0.ebuild b/gnome-base/nautilus/nautilus-3.8.2.ebuild
index 156656c8cf66..22fc02153326 100644
--- a/gnome-base/nautilus/nautilus-3.8.0.ebuild
+++ b/gnome-base/nautilus/nautilus-3.8.2.ebuild
@@ -1,18 +1,19 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/nautilus/nautilus-3.8.0.ebuild,v 1.3 2013/03/31 13:02:59 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/nautilus/nautilus-3.8.2.ebuild,v 1.1 2013/06/18 19:39:05 pacho Exp $
EAPI="5"
GCONF_DEBUG="no"
GNOME2_LA_PUNT="yes" # Needed with USE 'sendto'
-inherit eutils gnome2 virtualx
+inherit eutils gnome2 readme.gentoo virtualx
DESCRIPTION="A file manager for the GNOME desktop"
HOMEPAGE="http://live.gnome.org/Nautilus"
LICENSE="GPL-2+ LGPL-2+ FDL-1.1"
SLOT="0"
+
# profiling?
IUSE="debug exif gnome +introspection packagekit +previewer sendto tracker xmp"
KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux"
@@ -41,7 +42,8 @@ COMMON_DEPEND="
exif? ( >=media-libs/libexif-0.6.20 )
introspection? ( >=dev-libs/gobject-introspection-0.6.4 )
tracker? ( >=app-misc/tracker-0.16:= )
- xmp? ( >=media-libs/exempi-2.1.0 )"
+ xmp? ( >=media-libs/exempi-2.1.0 )
+"
DEPEND="${COMMON_DEPEND}
>=dev-lang/perl-5
>=dev-util/gdbus-codegen-2.33
@@ -49,23 +51,35 @@ DEPEND="${COMMON_DEPEND}
>=dev-util/intltool-0.40.1
sys-devel/gettext
virtual/pkgconfig
- x11-proto/xproto"
+ x11-proto/xproto
+"
RDEPEND="${COMMON_DEPEND}
packagekit? ( app-admin/packagekit-base )
- sendto? ( !<gnome-extra/nautilus-sendto-3.0.1 )"
+ sendto? ( !<gnome-extra/nautilus-sendto-3.0.1 )
+"
+
# For eautoreconf
# gnome-base/gnome-common
# dev-util/gtk-doc-am"
-PDEPEND="gnome? (
+
+PDEPEND="
+ gnome? (
>=x11-themes/gnome-icon-theme-1.1.91
x11-themes/gnome-icon-theme-symbolic )
tracker? ( >=gnome-extra/nautilus-tracker-tags-0.12 )
previewer? ( >=gnome-extra/sushi-0.1.9 )
sendto? ( >=gnome-extra/nautilus-sendto-3.0.1 )
- >=gnome-base/gvfs-1.14[gtk]"
+ >=gnome-base/gvfs-1.14[gtk]
+"
# Need gvfs[gtk] for recent:/// support
src_prepare() {
+ if use previewer; then
+ DOC_CONTENTS="nautilus uses gnome-extra/sushi to preview media files.
+ To activate the previewer, select a file and press space; to
+ close the previewer, press space again."
+ fi
+
# Restore the nautilus-2.x Delete shortcut (Ctrl+Delete will still work);
# bug #393663
epatch "${FILESDIR}/${PN}-3.5.91-delete.patch"
@@ -78,17 +92,16 @@ src_prepare() {
src_configure() {
DOCS="AUTHORS ChangeLog* HACKING MAINTAINERS NEWS README THANKS"
- G2CONF="${G2CONF}
- --disable-profiling
- --disable-update-mimedb
- $(use_enable debug)
- $(use_enable exif libexif)
- $(use_enable introspection)
- $(use_enable packagekit)
- $(use_enable sendto nst-extension)
- $(use_enable tracker)
- $(use_enable xmp)"
- gnome2_src_configure
+ gnome2_src_configure \
+ --disable-profiling \
+ --disable-update-mimedb \
+ $(use_enable debug) \
+ $(use_enable exif libexif) \
+ $(use_enable introspection) \
+ $(use_enable packagekit) \
+ $(use_enable sendto nst-extension) \
+ $(use_enable tracker) \
+ $(use_enable xmp)
}
src_test() {
@@ -99,13 +112,16 @@ src_test() {
unset GSETTINGS_BACKEND
}
+src_install() {
+ use previewer && readme.gentoo_create_doc
+ gnome2_src_install
+}
+
pkg_postinst() {
gnome2_pkg_postinst
if use previewer; then
- elog "nautilus uses gnome-extra/sushi to preview media files."
- elog "To activate the previewer, select a file and press space; to"
- elog "close the previewer, press space again."
+ readme.gentoo_print_elog
else
elog "To preview media files, emerge nautilus with USE=previewer"
fi