summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Haubenwallner <haubi@gentoo.org>2014-07-08 07:16:16 +0000
committerMichael Haubenwallner <haubi@gentoo.org>2014-07-08 07:16:16 +0000
commitc6f65e1eb603bd7205f8147c9c73b377f6bdc274 (patch)
tree027744f378b98107c91da57d9e7b7afa7a2a50f4 /gnome-base/orbit
parentDrop live keywords (diff)
downloadgentoo-2-c6f65e1eb603bd7205f8147c9c73b377f6bdc274.tar.gz
gentoo-2-c6f65e1eb603bd7205f8147c9c73b377f6bdc274.tar.bz2
gentoo-2-c6f65e1eb603bd7205f8147c9c73b377f6bdc274.zip
+orbit-2.14.19-r4: Support Prefix, fix ppc-aix, drop G2CONF (#515094). Build parallel (#273031).
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key A630CCB8)
Diffstat (limited to 'gnome-base/orbit')
-rw-r--r--gnome-base/orbit/ChangeLog9
-rw-r--r--gnome-base/orbit/files/orbit-2.14.19-aix-func_data.patch99
-rw-r--r--gnome-base/orbit/files/orbit-2.14.19-parallel-build.patch25
-rw-r--r--gnome-base/orbit/orbit-2.14.19-r4.ebuild84
4 files changed, 216 insertions, 1 deletions
diff --git a/gnome-base/orbit/ChangeLog b/gnome-base/orbit/ChangeLog
index bd83f7288daa..cb22ff0934c5 100644
--- a/gnome-base/orbit/ChangeLog
+++ b/gnome-base/orbit/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for gnome-base/orbit
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/orbit/ChangeLog,v 1.207 2014/04/26 18:47:00 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/orbit/ChangeLog,v 1.208 2014/07/08 07:16:15 haubi Exp $
+
+*orbit-2.14.19-r4 (08 Jul 2014)
+
+ 08 Jul 2014; Michael Haubenwallner <haubi@gentoo.org>
+ +orbit-2.14.19-r4.ebuild, +files/orbit-2.14.19-aix-func_data.patch,
+ +files/orbit-2.14.19-parallel-build.patch:
+ Support Prefix, fix ppc-aix, drop G2CONF (#515094). Build parallel (#273031).
26 Apr 2014; Pacho Ramos <pacho@gentoo.org> -orbit-2.14.19-r1.ebuild,
-orbit-2.14.19-r2.ebuild:
diff --git a/gnome-base/orbit/files/orbit-2.14.19-aix-func_data.patch b/gnome-base/orbit/files/orbit-2.14.19-aix-func_data.patch
new file mode 100644
index 000000000000..b58fd00a10b8
--- /dev/null
+++ b/gnome-base/orbit/files/orbit-2.14.19-aix-func_data.patch
@@ -0,0 +1,99 @@
+From c50f193f69f9b14dd26fafb7cb4c9514eaa6f15e Mon Sep 17 00:00:00 2001
+From: Michael Haubenwallner <michael.haubenwallner@ssi-schaefer.com>
+Date: Thu, 26 Jun 2014 12:45:18 +0200
+Subject: [PATCH 1/2] bug#732275: rename func_data to gfunc_data for AIX
+
+---
+ include/orbit/orb-core/allocators.h | 2 +-
+ src/idl-compiler/orbit-idl-utils.c | 14 +++++++-------
+ src/idl-compiler/orbit-idl2.h | 4 ++--
+ 3 files changed, 10 insertions(+), 10 deletions(-)
+
+diff --git a/include/orbit/orb-core/allocators.h b/include/orbit/orb-core/allocators.h
+index 0401a15..1861ca1 100644
+--- a/include/orbit/orb-core/allocators.h
++++ b/include/orbit/orb-core/allocators.h
+@@ -41,7 +41,7 @@ gpointer ORBit_realloc_tcval (gpointer old,
+ Below, some magic values of the fnc ptr are defined.
+ **/
+ typedef gpointer (*ORBit_Mem_free_fn) (gpointer mem,
+- gpointer func_data);
++ gpointer gfunc_data);
+
+ #define ORBIT_MEMHOW_HOW(how) ((how) & 0x3)
+ #define ORBIT_MEMHOW_ELEMENTS(how) ((how) >> 2)
+diff --git a/src/idl-compiler/orbit-idl-utils.c b/src/idl-compiler/orbit-idl-utils.c
+index 3bb0467..04fe4a2 100644
+--- a/src/idl-compiler/orbit-idl-utils.c
++++ b/src/idl-compiler/orbit-idl-utils.c
+@@ -362,7 +362,7 @@ orbit_idl_print_node(IDL_tree node, int indent_level)
+
+ static void
+ IDL_tree_traverse_helper(IDL_tree p, GFunc f,
+- gconstpointer func_data,
++ gconstpointer gfunc_data,
+ GHashTable *visited_nodes,
+ gboolean include_self)
+ {
+@@ -376,17 +376,17 @@ IDL_tree_traverse_helper(IDL_tree p, GFunc f,
+ for (curitem = IDL_INTERFACE (p).inheritance_spec; curitem;
+ curitem = IDL_LIST (curitem).next) {
+ IDL_tree_traverse_helper (IDL_get_parent_node
+- (IDL_LIST (curitem).data, IDLN_INTERFACE, NULL), f, func_data, visited_nodes, TRUE);
++ (IDL_LIST (curitem).data, IDLN_INTERFACE, NULL), f, gfunc_data, visited_nodes, TRUE);
+ }
+
+ if (include_self)
+- f(p, (gpointer)func_data);
++ f(p, (gpointer)gfunc_data);
+ }
+
+ void
+ IDL_tree_traverse_parents_full (IDL_tree p,
+ GFunc f,
+- gconstpointer func_data,
++ gconstpointer gfunc_data,
+ gboolean include_self)
+ {
+ GHashTable *visited_nodes = g_hash_table_new (NULL, g_direct_equal);
+@@ -400,7 +400,7 @@ IDL_tree_traverse_parents_full (IDL_tree p,
+ if (!p)
+ return;
+
+- IDL_tree_traverse_helper (p, f, func_data, visited_nodes, include_self);
++ IDL_tree_traverse_helper (p, f, gfunc_data, visited_nodes, include_self);
+
+ g_hash_table_destroy (visited_nodes);
+ }
+@@ -408,9 +408,9 @@ IDL_tree_traverse_parents_full (IDL_tree p,
+ void
+ IDL_tree_traverse_parents (IDL_tree p,
+ GFunc f,
+- gconstpointer func_data)
++ gconstpointer gfunc_data)
+ {
+- IDL_tree_traverse_parents_full (p, f, func_data, TRUE);
++ IDL_tree_traverse_parents_full (p, f, gfunc_data, TRUE);
+ }
+
+ /* For use by below function */
+diff --git a/src/idl-compiler/orbit-idl2.h b/src/idl-compiler/orbit-idl2.h
+index b58f57f..670e072 100644
+--- a/src/idl-compiler/orbit-idl2.h
++++ b/src/idl-compiler/orbit-idl2.h
+@@ -16,10 +16,10 @@ void orbit_idl_print_node (IDL_tree node,
+ int indent_level);
+ void IDL_tree_traverse_parents (IDL_tree p,
+ GFunc f,
+- gconstpointer func_data);
++ gconstpointer gfunc_data);
+ void IDL_tree_traverse_parents_full (IDL_tree p,
+ GFunc f,
+- gconstpointer func_data,
++ gconstpointer gfunc_data,
+ gboolean include_self);
+ gboolean orbit_cbe_type_contains_complex (IDL_tree ts);
+ void orbit_idl_check_oneway_op (IDL_tree op);
+--
+1.8.3.2
+
diff --git a/gnome-base/orbit/files/orbit-2.14.19-parallel-build.patch b/gnome-base/orbit/files/orbit-2.14.19-parallel-build.patch
new file mode 100644
index 000000000000..113b90465bae
--- /dev/null
+++ b/gnome-base/orbit/files/orbit-2.14.19-parallel-build.patch
@@ -0,0 +1,25 @@
+From c67303ecfdf80072a2852433c7f7818113e61c06 Mon Sep 17 00:00:00 2001
+From: Michael Haubenwallner <michael.haubenwallner@ssi-schaefer.com>
+Date: Thu, 26 Jun 2014 12:37:59 +0200
+Subject: [PATCH 2/2] bug#732274: fix parallel build failure
+
+---
+ src/services/name/Makefile.am | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/services/name/Makefile.am b/src/services/name/Makefile.am
+index deda1ed..8cf868e 100644
+--- a/src/services/name/Makefile.am
++++ b/src/services/name/Makefile.am
+@@ -68,7 +68,7 @@ libname_server_2_a_DEPENDENCIES = $(DEPS) CosNaming.h
+
+ orbit_name_server_2_SOURCES = boot.c
+ orbit_name_server_2_LDFLAGS = $(FLAGS)
+-orbit_name_server_2_DEPENDENCIES = $(DEPS) CosNaming.h
++orbit_name_server_2_DEPENDENCIES = $(DEPS) CosNaming.h libname-server-2.a
+ orbit_name_server_2_LDADD = libname-server-2.a $(LDADDS)
+
+ $(libname_server_2_a_OBJECTS) $(name_client_2_OBJECTS) $(orbit_name_server_2_OBJECTS) : CosNaming.h
+--
+1.8.3.2
+
diff --git a/gnome-base/orbit/orbit-2.14.19-r4.ebuild b/gnome-base/orbit/orbit-2.14.19-r4.ebuild
new file mode 100644
index 000000000000..a0c046e77540
--- /dev/null
+++ b/gnome-base/orbit/orbit-2.14.19-r4.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/orbit/orbit-2.14.19-r4.ebuild,v 1.1 2014/07/08 07:16:15 haubi Exp $
+
+EAPI="5"
+GCONF_DEBUG="yes"
+GNOME_ORG_MODULE="ORBit2"
+GNOME_TARBALL_SUFFIX="bz2"
+GNOME2_LA_PUNT="yes"
+
+inherit eutils gnome2 toolchain-funcs autotools
+
+DESCRIPTION="ORBit2 is a high-performance CORBA ORB"
+HOMEPAGE="http://projects.gnome.org/ORBit2/"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~ia64-hpux ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
+IUSE="pic static-libs test"
+REQUIRED_USE="test? ( debug )"
+
+RDEPEND=">=dev-libs/glib-2.8:2
+ >=dev-libs/libIDL-0.8.2
+"
+DEPEND="${RDEPEND}
+ dev-util/gtk-doc-am
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ # Fix wrong process kill, bug #268142
+ sed "s:killall lt-timeout-server:killall timeout-server:" \
+ -i test/timeout.sh || die "sed 1 failed"
+
+ # Do not mess with CFLAGS
+ sed 's/-ggdb -O0//' -i configure.in configure || die "sed 2 failed"
+
+ if ! use test; then
+ sed -i -e 's/test //' Makefile.am || die
+ fi
+
+ # Drop failing test, bug #331709
+ sed -i -e 's/test-mem //' test/Makefile.am || die
+
+ # Fix link_protocol_is_local() for ipv4 on machines with ipv6
+ # https://bugzilla.gnome.org/show_bug.cgi?id=693636
+ epatch "${FILESDIR}/${PN}-2.14.19-link_protocol_is_local.patch"
+
+ # Build libname-server-2.a with -fPIC on hardened, bug #312161
+ epatch "${FILESDIR}/${PN}-2.14.19-fPIC.patch"
+
+ epatch "${FILESDIR}"/${P}-automake-1.13.patch
+ epatch "${FILESDIR}"/${P}-parallel-build.patch #273031
+ epatch "${FILESDIR}"/${P}-aix-func_data.patch #515094
+
+ eautoreconf
+ gnome2_src_prepare
+}
+
+src_configure() {
+ local myconf=()
+ DOCS="AUTHORS ChangeLog HACKING MAINTAINERS NEWS README* TODO"
+
+ # We need to unset IDL_DIR, which is set by RSI's IDL. This causes certain
+ # files to be not found by autotools when compiling ORBit. See bug #58540
+ # for more information. Please don't remove -- 8/18/06
+ unset IDL_DIR
+
+ # We need to use the hosts IDL compiler if cross-compiling, bug #262741
+ if tc-is-cross-compiler; then
+ # check that host version is present and executable
+ [[ -x ${EPREFIX}/usr/bin/orbit-idl-2 ]] || die "Please emerge ~${CATEGORY}/${P} on the host system first"
+ myconf=("${myconf[@]}" "--with-idl-compiler=${EPREFIX}/usr/bin/orbit-idl-2")
+ fi
+ gnome2_src_configure \
+ $(use_enable pic libname-server-pic) \
+ $(use_enable static-libs static) \
+ "${myconf[@]}"
+}
+
+src_test() {
+ # can fail in parallel, see bug #235994
+ emake -j1 check
+}